aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:28:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:59:12 +0000
commitc2412f4dfecfabea70177e3c85892049ff454899 (patch)
tree99a3c1c392380c51c1f6259f2faa0d60a851cf0c
parent5b3d2118c412358dee2f84e9648d79521680b690 (diff)
downloadports-c2412f4dfecfabea70177e3c85892049ff454899.tar.gz
ports-c2412f4dfecfabea70177e3c85892049ff454899.zip
www/libnghttp2: Change back to make
- Bump PORTREVISION for package change
-rw-r--r--www/libnghttp2/Makefile17
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt20
-rw-r--r--www/libnghttp2/files/patch-Makefile.in21
3 files changed, 29 insertions, 29 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 2f3c4983e106..5b3b17eddd77 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,8 @@
PORTNAME= nghttp2
-DISTVERSION= 1.51.0
+PORTVERSION= 1.51.0
+PORTREVISION= 1
CATEGORIES= www net
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -11,14 +12,12 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++14-lang pathfix pkgconfig tar:xz
+USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
+CONFIGURE_ARGS= --enable-lib-only
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
-CMAKE_OFF= ENABLE_DOC \
- ENABLE_HTTP3 \
- ENABLE_PYTHON_BINDINGS
-CMAKE_ON= ENABLE_LIB_ONLY \
- ENABLE_STATIC_LIB
-
.include <bsd.port.mk>
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
deleted file mode 100644
index 9eb3864499c1..000000000000
--- a/www/libnghttp2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- CMakeLists.txt.orig 2022-12-24 08:18:29 UTC
-+++ CMakeLists.txt
-@@ -503,7 +503,7 @@ include_directories(
- set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/${CMAKE_PROJECT_NAME}")
- set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}")
-
--install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-+#install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-
- add_subdirectory(lib)
- #add_subdirectory(lib/includes)
-@@ -519,7 +519,7 @@ if(ENABLE_DOC)
- add_subdirectory(doc)
- endif()
- add_subdirectory(contrib)
--add_subdirectory(script)
-+#add_subdirectory(script)
- add_subdirectory(bpf)
-
-
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
new file mode 100644
index 000000000000..3aad251a6069
--- /dev/null
+++ b/www/libnghttp2/files/patch-Makefile.in
@@ -0,0 +1,21 @@
+--- Makefile.in.orig 2022-11-13 06:53:28 UTC
++++ Makefile.in
+@@ -465,8 +465,7 @@ top_srcdir = @top_srcdir@
+ # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+ # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+-SUBDIRS = lib third-party src bpf examples python tests integration-tests \
+- doc contrib script
++SUBDIRS = lib
+
+
+ # Now with python setuptools, make uninstall will leave many files we
+@@ -474,7 +473,7 @@ SUBDIRS = lib third-party src bpf examples python test
+ # distcheck rule.
+ AM_DISTCHECK_CONFIGURE_FLAGS = --disable-python-bindings
+ ACLOCAL_AMFLAGS = -I m4
+-dist_doc_DATA = README.rst
++dist_doc_DATA =
+ EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
+ Dockerfile.android \
+ cmakeconfig.h.in \