aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2024-10-04 08:58:16 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2024-10-06 09:38:55 +0000
commitc27d2322b009732adbdc4211c38e1ff66dedf987 (patch)
treef6d2a71bf1c4ae08604dcf7aa26a550221b7114c
parentfb44c7458e63a27bb2eb471ae15d4a9a454853b6 (diff)
www/c-icap: update to 0.6.3
Switch c-icap server from branch 5.X to 6.X Full changelog: 0.6.2 changelog: - link c-icap server binaries with the math library - Add new records to c-icap.magic, which are required for virus scan service. 0.6.1 changelog: - Internal web server for use with services - Improved statistics and statistics API - Support histograms creation from statistic values - The pthread inter-process locking scheme - The new lmdb_tables module, to provide support for lmdb based lookup tables - Extended changes and fixes to the ldap support module - The ci_server_shared_memblob_* functions to access small memory blocks which are shared across c-icap processes. - Many fixes/improvements and new API functions. 0.6.0 changelog: - Support for lmdb based databases as an alternate to BerkeleyDB. - Improved info service to show c-icap statistics - Internal web server - The pthread inter-process locking scheme. - New development APIs: c-icap server shared memblocks, flat arrays - C-icap statistics for server and services: Time based statistics, histograms, API to retrieve statistics values, improved update operations
-rw-r--r--UPDATING11
-rw-r--r--www/c-icap/Makefile13
-rw-r--r--www/c-icap/distinfo8
-rw-r--r--www/c-icap/files/patch-c_icap_stretch.c11
-rw-r--r--www/c-icap/files/patch-mpmt__server.c15
-rw-r--r--www/c-icap/files/patch-txt__format.c11
-rw-r--r--www/c-icap/pkg-plist13
7 files changed, 46 insertions, 36 deletions
diff --git a/UPDATING b/UPDATING
index d1d05921154e..42d09e72f139 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20241004:
+ AFFECTS:users of www/c-icap
+ AUTHOR: rodrigo@FreeBSD.org
+
+ The c-icap server version is moving from branch 5.X to 6.X.
+ An in-place upgrade may require some changes in your current
+ configuration.
+ For installation instructions please refer :
+ https://sourceforge.net/p/c-icap/wiki/configcicap
+ https://sourceforge.net/p/c-icap/wiki
+
20240930:
AFFECTS: users of sysutils/nq
AUTHOR: 0mp@FreeBSD.org
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index 737fbd3947de..63067addf0d4 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -1,10 +1,13 @@
PORTNAME= c-icap
-PORTVERSION= 0.5.12
+PORTVERSION= 0.6.3
PORTEPOCH= 2
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.5.x/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.6.x/
DISTNAME= c_icap-${PORTVERSION}
+PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}-server/commit/
+PATCHFILES+= aa28041.patch:-p1 # https://github.com/c-icap/c-icap-server/pull/67
+
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= ICAP server implementation
WWW= https://c-icap.sourceforge.net/
@@ -20,9 +23,9 @@ CPE_VENDOR= c-icap_project
USE_LDCONFIG= yes
USE_RC_SUBR= c-icap
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var \
- --sysconfdir="${PREFIX}/etc/c-icap"
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var \
+ --sysconfdir="${PREFIX}/etc/c-icap"
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
INSTALL_TARGET= install-strip
diff --git a/www/c-icap/distinfo b/www/c-icap/distinfo
index 7ce97b5be7fd..217f1e40a5ef 100644
--- a/www/c-icap/distinfo
+++ b/www/c-icap/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1720627955
-SHA256 (c_icap-0.5.12.tar.gz) = 765263ddfb3eea9904e1e47c14021d29a5892904116cfb0f9b21412f3f2b92d1
-SIZE (c_icap-0.5.12.tar.gz) = 699391
+TIMESTAMP = 1728030106
+SHA256 (c_icap-0.6.3.tar.gz) = 3ead2da64f75383dd449750ad1d9d1a18957fa527957137cdf15d1335fb80e7c
+SIZE (c_icap-0.6.3.tar.gz) = 812473
+SHA256 (aa28041.patch) = f6c2fe0ca011f7269b97c3773bf00fd6fb96f98aa7ebc20460306e4a00097d26
+SIZE (aa28041.patch) = 7444
diff --git a/www/c-icap/files/patch-c_icap_stretch.c b/www/c-icap/files/patch-c_icap_stretch.c
new file mode 100644
index 000000000000..db7141393928
--- /dev/null
+++ b/www/c-icap/files/patch-c_icap_stretch.c
@@ -0,0 +1,11 @@
+--- utils/c-icap-stretch.c.orig 2024-10-04 08:22:44 UTC
++++ utils/c-icap-stretch.c
+@@ -71,7 +71,7 @@
+
+ int pid_to_int(ci_thread_t id)
+ {
+-#if defined(_WIN32)|| defined(__CYGWIN__)
++#if defined(_WIN32)|| defined(__CYGWIN__) || defined(__FreeBSD__)
+ return (int)(uintptr_t)id;
+ #else
+ return id;
diff --git a/www/c-icap/files/patch-mpmt__server.c b/www/c-icap/files/patch-mpmt__server.c
deleted file mode 100644
index 856677fbfe85..000000000000
--- a/www/c-icap/files/patch-mpmt__server.c
+++ /dev/null
@@ -1,15 +0,0 @@
-Invalid integer/pointer conversion. Already fixed upstream:
-https://github.com/c-icap/c-icap-server/commit/8ef8966237865ec699ab16d208ff56edaac4ff7b
-
-Index: mpmt_server.c
---- mpmt_server.c.orig 2021-09-02 14:45:30 UTC
-+++ mpmt_server.c
-@@ -75,7 +75,7 @@ server_decl_t **threads_list = NULL;
-
- ci_thread_mutex_t threads_list_mtx;
- server_decl_t **threads_list = NULL;
--ci_thread_t listener_thread_id = -1;
-+ci_thread_t listener_thread_id;
- int listener_running = 0;
-
- ci_thread_cond_t free_server_cond;
diff --git a/www/c-icap/files/patch-txt__format.c b/www/c-icap/files/patch-txt__format.c
deleted file mode 100644
index 50e1c92d9569..000000000000
--- a/www/c-icap/files/patch-txt__format.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- txt_format.c.orig 2018-11-09 09:42:02 UTC
-+++ txt_format.c
-@@ -417,7 +417,7 @@ int fmt_seconds(ci_request_t *req, char *buf,int len,
- {
- time_t tm;
- time(&tm);
-- return snprintf(buf, len, "%ld", tm);
-+ return snprintf(buf, len, "%" PRId64 , (uint64_t) tm);
- }
-
- int fmt_httpclientip(ci_request_t *req, char *buf,int len, const char *param)
diff --git a/www/c-icap/pkg-plist b/www/c-icap/pkg-plist
index d0620eebd7b9..cd9c858fafe3 100644
--- a/www/c-icap/pkg-plist
+++ b/www/c-icap/pkg-plist
@@ -9,6 +9,7 @@ bin/c-icap-stretch
include/c_icap/access.h
include/c_icap/acl.h
include/c_icap/array.h
+include/c_icap/atomic.h
include/c_icap/body.h
include/c_icap/c-icap-conf.h
include/c_icap/c-icap.h
@@ -16,12 +17,16 @@ include/c_icap/cache.h
include/c_icap/cfg_param.h
include/c_icap/ci_regex.h
include/c_icap/ci_threads.h
+include/c_icap/ci_time.h
+include/c_icap/client.h
include/c_icap/commands.h
include/c_icap/debug.h
include/c_icap/dlib.h
+include/c_icap/encoding.h
include/c_icap/filetype.h
include/c_icap/hash.h
include/c_icap/header.h
+include/c_icap/http_server.h
include/c_icap/log.h
include/c_icap/lookup_table.h
include/c_icap/md5.h
@@ -29,11 +34,14 @@ include/c_icap/mem.h
include/c_icap/module.h
include/c_icap/net_io.h
include/c_icap/net_io_ssl.h
+include/c_icap/openssl_support.h
include/c_icap/port.h
include/c_icap/proc_mutex.h
include/c_icap/proc_threads_queues.h
include/c_icap/registry.h
include/c_icap/request.h
+include/c_icap/request_util.h
+include/c_icap/server.h
include/c_icap/service.h
include/c_icap/shared_mem.h
include/c_icap/simple_api.h
@@ -52,12 +60,13 @@ lib/c_icap/srv_echo.so
lib/c_icap/srv_ex206.so
lib/c_icap/sys_logger.so
lib/libicapapi.so
-lib/libicapapi.so.5
-lib/libicapapi.so.5.0.12
+lib/libicapapi.so.6
+lib/libicapapi.so.6.0.3
share/man/man8/c-icap-client.8.gz
share/man/man8/c-icap-config.8.gz
share/man/man8/c-icap-libicapapi-config.8.gz
share/man/man8/c-icap-mkbdb.8.gz
+share/man/man8/c-icap-mklmdb.8.gz
share/man/man8/c-icap-stretch.8.gz
share/man/man8/c-icap.8.gz
@dir(%%CICAP_USER%%,%%CICAP_GROUP%%,) %%RUN_DIR%%