aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:44:34 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 13:02:17 +0000
commitc29190941f56c3d5a4465b3408d4986b13cb944c (patch)
treec2cd959faf8c2f9f442584023047272898a653af
parentf0a70d02aa16506f10b07c4c4efefd5f5b16acca (diff)
downloadports-c29190941f56c3d5a4465b3408d4986b13cb944c.tar.gz
ports-c29190941f56c3d5a4465b3408d4986b13cb944c.zip
security/py-{acme,certbot*}: Update USES=python and version requirement of RUN_DEPENDS
-rw-r--r--security/py-acme/Makefile4
-rw-r--r--security/py-certbot-apache/Makefile5
-rw-r--r--security/py-certbot-dns-google/Makefile2
-rw-r--r--security/py-certbot-nginx/Makefile2
-rw-r--r--security/py-certbot/Makefile29
5 files changed, 18 insertions, 24 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 0930c6e2f196..f60005569e92 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -12,10 +12,10 @@ WWW= https://github.com/certbot/certbot/tree/master/acme
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.5.0:security/py-cryptography@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.5.0,1:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}josepy>=1.13.0:security/py-josepy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=17.5.0:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyrfc3339>=0:devel/py-pyrfc3339@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=2019.3,1:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.20.0:www/py-requests@${PY_FLAVOR}
diff --git a/security/py-certbot-apache/Makefile b/security/py-certbot-apache/Makefile
index c8d17494cbf4..1bb21459b71a 100644
--- a/security/py-certbot-apache/Makefile
+++ b/security/py-certbot-apache/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}python-augeas>0:textproc/py-python-augeas@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}python-augeas>=0:textproc/py-python-augeas@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
@@ -22,8 +22,7 @@ NO_ARCH= yes
post-patch:
@${REINPLACE_CMD} -e 's|apache2ctl|apachectl|' ${WRKSRC}/certbot_apache/_internal/configurator.py
- @${REINPLACE_CMD} -e 's|/etc/apache2|${LOCALBASE}/etc/apache24|' \
- ${WRKSRC}/certbot_apache/_internal/configurator.py
+ @${REINPLACE_CMD} -e 's|/etc/apache2|${LOCALBASE}/etc/apache24|' ${WRKSRC}/certbot_apache/_internal/configurator.py
.include "${.CURDIR}/../py-acme/version.mk"
.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-google/Makefile b/security/py-certbot-dns-google/Makefile
index 4ef2a8aa31f7..e8909ca14c01 100644
--- a/security/py-certbot-dns-google/Makefile
+++ b/security/py-certbot-dns-google/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}google-api-python-client>=1.5.5:www/py-google-api-python-client@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}httplib2>0:www/py-httplib2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oauth2client>=4.0:security/py-oauth2client@${PY_FLAVOR}
USES= python:3.7+
diff --git a/security/py-certbot-nginx/Makefile b/security/py-certbot-nginx/Makefile
index 6e6e0173df50..d8dfe870a1f8 100644
--- a/security/py-certbot-nginx/Makefile
+++ b/security/py-certbot-nginx/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${P
${PYTHON_PKGNAMEPREFIX}openssl>=17.5.0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.2.1:devel/py-pyparsing@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index e29fa51cc464..71553ec6f509 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -15,52 +15,47 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configobj>=5.0.6:devel/py-configobj@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=2.5.0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=2.5.0,1:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}distro>=1.0.1:sysutils/py-distro@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}josepy>=1.13.0:security/py-josepy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}parsedatetime>=2.4:devel/py-parsedatetime@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyrfc3339>=0:devel/py-pyrfc3339@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=2019.3,1:devel/py-pytz@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
-SUB_FILES= 500.certbot pkg-message
+
PLIST_FILES= etc/periodic/weekly/500.certbot-${PYTHON_VER}
+SUB_FILES= 500.certbot pkg-message
SUB_LIST= PYTHON_VER=${PYTHON_VER}
OPTIONS_DEFINE= MANPAGES
-OPTIONS_DEFAULT= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
MANPAGES_BUILD_DEPENDS= ${RUN_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}sphinx>=1.2,1:textproc/py-sphinx@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}repoze.sphinx.autointerface>0:devel/py-repoze.sphinx.autointerface@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>=0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}repoze.sphinx.autointerface>=0:devel/py-repoze.sphinx.autointerface@${PY_FLAVOR} \
MANPAGES_PLIST_FILES= share/man/man1/certbot.1.gz \
share/man/man7/certbot.7.gz
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/certbot/compat/misc.py \
- ${WRKSRC}/tests/cli_test.py
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/certbot/compat/misc.py ${WRKSRC}/tests/cli_test.py
post-build-MANPAGES-on:
# Avoid gmake / ${DO_MAKE_BUILD} -C ${WRKSRC}/docs man
- (cd ${WRKSRC}/docs && \
- sphinx-build-${PYTHON_VER} -N -b man . _build/man)
+ cd ${WRKSRC}/docs && sphinx-build-${PYTHON_VER} -N -b man . _build/man
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/weekly
- ${INSTALL_SCRIPT} ${WRKDIR}/500.certbot \
- ${STAGEDIR}${PREFIX}/etc/periodic/weekly/500.certbot-${PYTHON_VER}
+ ${INSTALL_SCRIPT} ${WRKDIR}/500.certbot ${STAGEDIR}${PREFIX}/etc/periodic/weekly/500.certbot-${PYTHON_VER}
post-install-MANPAGES-on:
- ${INSTALL_MAN} ${WRKSRC}/docs/_build/man/certbot.1 \
- ${STAGEDIR}${PREFIX}/share/man/man1
- ${INSTALL_MAN} ${WRKSRC}/docs/_build/man/certbot.7 \
- ${STAGEDIR}${PREFIX}/share/man/man7
+ ${INSTALL_MAN} ${WRKSRC}/docs/_build/man/certbot.1 ${STAGEDIR}${PREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/docs/_build/man/certbot.7 ${STAGEDIR}${PREFIX}/share/man/man7
.include "${.CURDIR}/../py-acme/version.mk"
.include <bsd.port.mk>