aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-10-06 11:24:59 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-10-06 11:24:59 +0000
commitc2aff595286b71b4b5e9b2cbb1c565333915b803 (patch)
tree44f76491cf7432c33d02f1fdcb872fadb129633b
parentbe3401c2f7644d53c35ea7c9ef4b9487d70f28cd (diff)
downloadports-c2aff595286b71b4b5e9b2cbb1c565333915b803.tar.gz
ports-c2aff595286b71b4b5e9b2cbb1c565333915b803.zip
Add x11/pmenu
Pmenu is a pie menu utility for X. Pmenu receives a menu specification in stdin, shows a menu for the user to select one of the options, and outputs the option selected to stdout. Pmenu comes with the following features: - Pmenu reads something in and prints something out, the UNIX way. - Submenus (some pie-menu slices can spawn another menu). - Icons (pie-menu slices can contain icon image). - X resources support (you don't need to recompile pmenu for configuring it). Check out my other project, xclickroot for an application that can spawn pmenu by right clicking on the root window (i.e. on the desktop). WWW: https://github.com/phillbush/pmenu
Notes
Notes: svn path=/head/; revision=551573
-rw-r--r--x11/Makefile1
-rw-r--r--x11/pmenu/Makefile41
-rw-r--r--x11/pmenu/distinfo5
-rw-r--r--x11/pmenu/files/patch-config.mk20
-rw-r--r--x11/pmenu/pkg-descr15
5 files changed, 82 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 93807c53ff54..59cfb34add6f 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -262,6 +262,7 @@
SUBDIR += plasma5-plasma-desktop
SUBDIR += plasma5-plasma-integration
SUBDIR += plasma5-plasma-workspace
+ SUBDIR += pmenu
SUBDIR += polybar
SUBDIR += printscreen
SUBDIR += py-caffeine-ng
diff --git a/x11/pmenu/Makefile b/x11/pmenu/Makefile
new file mode 100644
index 000000000000..c2403b7d869d
--- /dev/null
+++ b/x11/pmenu/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= pmenu
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.1.2
+CATEGORIES= x11
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 91d52b3dbe197681c3252703ae57594dfd755f5a.patch:-p1
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Pie menu for X
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libImlib2.so:graphics/imlib2
+
+USES= localbase xorg
+USE_GITHUB= yes
+GH_ACCOUNT= phillbush
+USE_XORG= x11 xext xft xinerama
+
+MAKE_ARGS= FREETYPEINC="${LOCALBASE}/include/freetype2" \
+ PREFIX="${PREFIX}"
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/man/man1/${PORTNAME}.1.gz
+
+PORTEXAMPLES= ${PORTNAME}.sh
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/x11/pmenu/distinfo b/x11/pmenu/distinfo
new file mode 100644
index 000000000000..05819b936790
--- /dev/null
+++ b/x11/pmenu/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1601983413
+SHA256 (phillbush-pmenu-v2.1.2_GH0.tar.gz) = 6e10de31b923f96ae0eb0b7fc37097c0ac94e8af6bf688dd931cc0cf554367e5
+SIZE (phillbush-pmenu-v2.1.2_GH0.tar.gz) = 14160
+SHA256 (91d52b3dbe197681c3252703ae57594dfd755f5a.patch) = 4d3bcde210d9e96c76a81507defe5a2e0f24997127405ba4ccb20aead3cec1b6
+SIZE (91d52b3dbe197681c3252703ae57594dfd755f5a.patch) = 939
diff --git a/x11/pmenu/files/patch-config.mk b/x11/pmenu/files/patch-config.mk
new file mode 100644
index 000000000000..b2dc6caa8b5a
--- /dev/null
+++ b/x11/pmenu/files/patch-config.mk
@@ -0,0 +1,20 @@
+--- config.mk.orig 2020-10-06 11:12:09 UTC
++++ config.mk
+@@ -17,12 +17,12 @@ FREETYPEINC = /usr/include/freetype2
+
+ # includes and libs
+ INCS = -I${LOCALINC} -I${X11INC} -I${FREETYPEINC}
+-LIBS = -L${LOCALLIB} -L${X11LIB} -lm -lfontconfig -lXft -lX11 -lXinerama -lXext -lImlib2
++LIBS += -L${LOCALLIB} -L${X11LIB} -lm -lfontconfig -lXft -lX11 -lXinerama -lXext -lImlib2
+
+ # flags
+-CPPFLAGS =
+-CFLAGS = -Wall -Wextra ${INCS} ${CPPFLAGS}
+-LDFLAGS = ${LIBS}
++CPPFLAGS +=
++CFLAGS += -Wall -Wextra ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
diff --git a/x11/pmenu/pkg-descr b/x11/pmenu/pkg-descr
new file mode 100644
index 000000000000..0e35fbd9a3f9
--- /dev/null
+++ b/x11/pmenu/pkg-descr
@@ -0,0 +1,15 @@
+Pmenu is a pie menu utility for X. Pmenu receives a menu specification
+in stdin, shows a menu for the user to select one of the options,
+and outputs the option selected to stdout.
+
+Pmenu comes with the following features:
+
+- Pmenu reads something in and prints something out, the UNIX way.
+- Submenus (some pie-menu slices can spawn another menu).
+- Icons (pie-menu slices can contain icon image).
+- X resources support (you don't need to recompile pmenu for configuring it).
+
+Check out my other project, xclickroot for an application that can spawn pmenu
+by right clicking on the root window (i.e. on the desktop).
+
+WWW: https://github.com/phillbush/pmenu