aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2021-09-13 21:22:34 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2021-09-30 22:02:10 +0000
commitc3a334e9f6f863f76a6491fd081f395d5b38f7e4 (patch)
tree57ad1becda9620acb71b253fb5e8a4ff950fbe2d
parent3c4ec09a8c62e4857cbbc91bf8aac2c0f0b381a2 (diff)
downloadports-c3a334e9f6f863f76a6491fd081f395d5b38f7e4.tar.gz
ports-c3a334e9f6f863f76a6491fd081f395d5b38f7e4.zip
lang/erlang-runtime24: import changes from the (future) lang/erlang.
- Add KQUEUE option - Add ODBC_CFLAGS and ODBC_LDFLAGS - Remove unnecessary call to "./otp_build autoconf" and patch "configure" rather than "configure.src" - Apply portclippy fixes
-rw-r--r--lang/erlang-runtime24/Makefile21
-rw-r--r--lang/erlang-runtime24/files/patch-configure (renamed from lang/erlang-runtime24/files/patch-configure.src)4
2 files changed, 13 insertions, 12 deletions
diff --git a/lang/erlang-runtime24/Makefile b/lang/erlang-runtime24/Makefile
index a66fea9c3edb..49c22f3a68fd 100644
--- a/lang/erlang-runtime24/Makefile
+++ b/lang/erlang-runtime24/Makefile
@@ -14,15 +14,14 @@ LICENSE= APACHE20
BROKEN_sparc64= Fails to build: error: fp_except undeclared
USES= autoreconf:build cpe gmake ncurses perl5
+CPE_VENDOR= erlang
+CPE_PRODUCT= erlang/otp
USE_GITHUB= nodefault
GH_ACCOUNT= erlang:otp,corba
GH_PROJECT= otp:otp corba:corba
GH_TAGNAME= 5.0.2:corba
USE_PERL5= build
-CPE_VENDOR= erlang
-CPE_PRODUCT= erlang/otp
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dirty-schedulers \
--enable-kernel-poll \
@@ -38,8 +37,9 @@ WRKSRC= ${WRKSRC_otp}
ERLANG_LIB= ${PORTNAME}${PORTVERSION:C/\..*//}
-OPTIONS_DEFINE= CHUNKS CORBA DTRACE JAVA ODBC OPENSSL SCTP SHARING WX
-OPTIONS_DEFAULT= CHUNKS CORBA DTRACE OPENSSL SCTP SHARING
+OPTIONS_DEFINE= CHUNKS CORBA DTRACE JAVA KQUEUE ODBC OPENSSL SCTP \
+ SHARING WX
+OPTIONS_DEFAULT= CHUNKS CORBA DTRACE KQUEUE OPENSSL SCTP SHARING
.if !exists(/usr/sbin/dtrace)
OPTIONS_EXCLUDE+= DTRACE
@@ -54,8 +54,9 @@ OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
OPTIONS_EXCLUDE_riscv64= DTRACE
-CHUNKS_DESC= Enable in-line documentation in erlang console
+CHUNKS_DESC= Enable in-line documentation in Erlang console
CORBA_DESC= Enable Corba support
+KQUEUE_DESC= Enable Kernel Poll (kqueue) support
SCTP_DESC= Enable SCTP support
SHARING_DESC= Enable term copy-and-share support
WX_DESC= Enable WX application
@@ -71,9 +72,12 @@ DTRACE_VARS= STRIP=""
JAVA_CONFIGURE_WITH= javac
JAVA_CONFIGURE_ENV= ac_cv_prog_JAVAC="${JAVAC}"
JAVA_VARS= USE_JAVA=yes
+KQUEUE_CONFIGURE_ENABLE= kernel-poll
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
-ODBC_CONFIGURE_WITH= odbc
ODBC_USES= localbase
+ODBC_CONFIGURE_WITH= odbc
+ODBC_CFLAGS= -I/usr/local/include
+ODBC_LDFLAGS= -L/usr/local/lib
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= ssl=${OPENSSLBASE}
SCTP_CONFIGURE_ENABLE= sctp
@@ -98,9 +102,6 @@ MAKE_ARGS+= ARCH=x86
MAKE_ARGS+= ARCH=arm
.endif
-pre-configure:
- @cd ${WRKSRC} && ./otp_build autoconf
-
pre-configure-WX-off:
echo "disabled by port options" > ${WRKSRC}/lib/debugger/SKIP
echo "disabled by port options" > ${WRKSRC}/lib/et/SKIP
diff --git a/lang/erlang-runtime24/files/patch-configure.src b/lang/erlang-runtime24/files/patch-configure
index 1d4dd2178a43..9713b597b9dc 100644
--- a/lang/erlang-runtime24/files/patch-configure.src
+++ b/lang/erlang-runtime24/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.src.orig 2021-05-27 09:36:50 UTC
-+++ configure.src
+--- configure.orig 2021-09-13 14:43:59 UTC
++++ configure
@@ -55,7 +55,7 @@ skip_applications=
while test $# != 0; do
case $1 in