aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Hutchinson <portmaster@bsdforge.com>2021-06-22 17:38:15 +0000
committerRenato Botelho <garga@FreeBSD.org>2021-06-22 17:42:25 +0000
commitc3dd3472dd49bc570f01294d7f7ad73202a3c684 (patch)
tree60d4fa7921a7ca5bab7b97131ab506475e78cc54
parent7734d779ae69dd4b9a4dea52d9787a0b1a7fcdcf (diff)
downloadports-c3dd3472dd49bc570f01294d7f7ad73202a3c684.tar.gz
ports-c3dd3472dd49bc570f01294d7f7ad73202a3c684.zip
devel/git: Fix contrib installation
In some cases installation is aborted when try to copy test.netrc.gpg, which is an empty file. This file is not actually needed so the fix here is to stop trying to install it PR: 255885 Sponsored by: Rubicon Communications, LLC ("Netgate")
-rw-r--r--devel/git/Makefile1
-rw-r--r--devel/git/pkg-plist1
2 files changed, 1 insertions, 1 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 3082a5968361..80112278449c 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -251,6 +251,7 @@ post-install-SUBTREE-on:
post-install-CONTRIB-on:
@${ECHO_MSG} "===> Installing contributed scripts"
${MKDIR} ${STAGEDIR}${PREFIX}/share/git-core/contrib
+ ${RM} ${WRKSRC}/contrib/credential/netrc/test.netrc.gpg
${CP} -R ${WRKSRC}/contrib/* ${STAGEDIR}${PREFIX}/share/git-core/contrib
post-install-P4-on:
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index be4df5922928..dcc1a917cefa 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -1244,7 +1244,6 @@ share/emacs/site-lisp/git/git.el
%%CONTRIB%%share/git-core/contrib/credential/netrc/test.command-option-gpg
%%CONTRIB%%share/git-core/contrib/credential/netrc/test.git-config-gpg
%%CONTRIB%%share/git-core/contrib/credential/netrc/test.netrc
-%%CONTRIB%%share/git-core/contrib/credential/netrc/test.netrc.gpg
%%CONTRIB%%share/git-core/contrib/credential/netrc/test.pl
%%CONTRIB%%share/git-core/contrib/credential/osxkeychain/.gitignore
%%CONTRIB%%share/git-core/contrib/credential/osxkeychain/Makefile