aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-09 19:54:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-09 19:54:48 +0000
commitc42ea9673625a08451314ccd2931fcca965aa138 (patch)
tree7bb4e323bf8321a7db6d96dbb8370ebaa4519ee4
parent3f3b8b8c42fd306069fecb7f5bd0779e9d75207e (diff)
downloadports-c42ea9673625a08451314ccd2931fcca965aa138.tar.gz
ports-c42ea9673625a08451314ccd2931fcca965aa138.zip
multimedia/mythtv: enable on powerpc
-rw-r--r--multimedia/mythtv/Makefile2
-rw-r--r--multimedia/mythtv/files/patch-libs_libmythtv_recorders_dvbchannel.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index f67e7a313b5b..fb2d61a49e7f 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -11,7 +11,7 @@ WWW= https://www.mythtv.org/
LICENSE= GPLv2+
-ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc64 powerpc64le
+ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc powerpc64 powerpc64le
.if ${/usr/bin/ld:L:tA} == /usr/bin/ld.lld
BROKEN_i386= ld: error: can't create dynamic relocation R_386_32 against local symbol in readonly segment
.endif
diff --git a/multimedia/mythtv/files/patch-libs_libmythtv_recorders_dvbchannel.cpp b/multimedia/mythtv/files/patch-libs_libmythtv_recorders_dvbchannel.cpp
new file mode 100644
index 000000000000..27cf5d5857ec
--- /dev/null
+++ b/multimedia/mythtv/files/patch-libs_libmythtv_recorders_dvbchannel.cpp
@@ -0,0 +1,11 @@
+--- libs/libmythtv/recorders/dvbchannel.cpp.orig 2023-05-09 18:32:34 UTC
++++ libs/libmythtv/recorders/dvbchannel.cpp
+@@ -1589,7 +1589,7 @@ bool DVBChannel::WaitForBackend(std::chrono::milliseco
+ const int fd = m_fdFrontend;
+ auto seconds = duration_cast<std::chrono::seconds>(timeout_ms);
+ auto usecs = duration_cast<std::chrono::microseconds>(timeout_ms) - seconds;
+- struct timeval select_timeout = { seconds.count(), usecs.count()};
++ struct timeval select_timeout = { seconds.count(), static_cast<suseconds_t>(usecs.count())};
+ fd_set fd_select_set;
+ FD_ZERO( &fd_select_set); // NOLINT(readability-isolate-declaration)
+ FD_SET (fd, &fd_select_set);