aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2024-02-22 19:28:03 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2024-02-22 20:15:52 +0000
commitc4523f5112499cb29de2ace8a204503c437840cb (patch)
tree9383a28004bc6c66aa84d7e1be3c527aa041519a
parent49cef766bf78d234b1896ad60560ab514e970dea (diff)
www/py-dj42-django-crispy-forms: New port
Django 4.2 version of www/py-django-crispy-forms, happy to pass it to its maintainer or make it disappear, once 4.2 is the default django version.
-rw-r--r--www/Makefile1
-rw-r--r--www/py-dj42-django-crispy-forms/Makefile27
-rw-r--r--www/py-dj42-django-crispy-forms/distinfo3
-rw-r--r--www/py-dj42-django-crispy-forms/pkg-descr12
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index eb853ddb3061..ed0c2e05ea1a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1499,6 +1499,7 @@
SUBDIR += py-dj42-django-celery-results
SUBDIR += py-dj42-django-compression-middleware
SUBDIR += py-dj42-django-cors-headers
+ SUBDIR += py-dj42-django-crispy-forms
SUBDIR += py-dj42-django-debug-toolbar
SUBDIR += py-dj42-django-extensions
SUBDIR += py-dj42-django-filter
diff --git a/www/py-dj42-django-crispy-forms/Makefile b/www/py-dj42-django-crispy-forms/Makefile
new file mode 100644
index 000000000000..b3fe83f8aa72
--- /dev/null
+++ b/www/py-dj42-django-crispy-forms/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= django-crispy-forms
+PORTVERSION= 2.0
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj42-
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Best way to have Django DRY forms
+WWW= https://github.com/django-crispy-forms/django-crispy-forms
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=0:www/py-django42@${PY_FLAVOR}
+
+USES= dos2unix python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}dj22-django-crispy-forms
+
+PORTSCOUT= skipv:2.1
+
+.include <bsd.port.mk>
diff --git a/www/py-dj42-django-crispy-forms/distinfo b/www/py-dj42-django-crispy-forms/distinfo
new file mode 100644
index 000000000000..b308d501a69b
--- /dev/null
+++ b/www/py-dj42-django-crispy-forms/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1684104566
+SHA256 (django-crispy-forms-2.0.tar.gz) = 90193b068bf948d9c68449bc8260afed1a8e2afe11ee0bac8c4ebfaeb175b322
+SIZE (django-crispy-forms-2.0.tar.gz) = 277697
diff --git a/www/py-dj42-django-crispy-forms/pkg-descr b/www/py-dj42-django-crispy-forms/pkg-descr
new file mode 100644
index 000000000000..dc5dff56bcd8
--- /dev/null
+++ b/www/py-dj42-django-crispy-forms/pkg-descr
@@ -0,0 +1,12 @@
+The best way to have Django DRY forms. Build programmatic reusable layouts out
+of components, having full control of the rendered HTML without writing HTML in
+templates. All this without breaking the standard way of doing things in Django,
+so it plays nice with any other form application.
+
+The application mainly provides:
+- A filter named |crispy that will render elegant div based forms. Think of it
+ as the built-in methods: as_table, as_ul and as_p. You cannot tune up the
+ output, but it is easy to start using it.
+- A tag named {% crispy %} that will render a form based on your configuration
+ and specific layout setup. This gives you amazing power without much hassle,
+ helping you save tons of time.