aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-19 16:28:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-19 17:18:24 +0000
commitc4c09be917ed7e69f2ced15d8a1fc40cebb1191c (patch)
tree81a3b4d4c372fede8104ba894681cf93d36fb06f
parent645b9abe350236ecad258c14e49f15b6722781d0 (diff)
downloadports-c4c09be917ed7e69f2ced15d8a1fc40cebb1191c.tar.gz
ports-c4c09be917ed7e69f2ced15d8a1fc40cebb1191c.zip
www/py-django-storages: Update to 1.13.2
- Update WWW - Add LICENSE_FILE - Remove PY_SETUPTOOLS: py-setuptools should be used rather than PY_SETUPTOOLS Changes: https://github.com/jschneier/django-storages/blob/master/CHANGELOG.rst
-rw-r--r--www/py-django-storages/Makefile29
-rw-r--r--www/py-django-storages/distinfo6
2 files changed, 21 insertions, 14 deletions
diff --git a/www/py-django-storages/Makefile b/www/py-django-storages/Makefile
index 43eb63de062b..95e544f1d534 100644
--- a/www/py-django-storages/Makefile
+++ b/www/py-django-storages/Makefile
@@ -1,17 +1,18 @@
PORTNAME= django-storages
-PORTVERSION= 1.14.2
-PORTREVISION= 1
+PORTVERSION= 1.14.3
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
COMMENT= Generic storages for Django
-WWW= https://github.com/jschneier/django-storages
+WWW= https://django-storages.readthedocs.io/en/latest/ \
+ https://github.com/jschneier/django-storages
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.2:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=3.2:www/py-django42@${PY_FLAVOR}
@@ -20,20 +21,26 @@ USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-# There is also an Azure backend (via AZURE option), but this requires a newer
-# version of py-azure-storage-blob.
-OPTIONS_DEFINE= DROPBOX GOOGLE LIBCLOUD S3 SFTP
-
+# AZURE option requires newer devel/py-azure-storage-blob (not yet in the ports tree).
+OPTIONS_DEFINE= DROPBOX GOOGLE LIBCLOUD S3 SFTP #AZURE
+#AZURE_DESC= Azure backend
DROPBOX_DESC= Dropbox backend
GOOGLE_DESC= Google Cloud Storage backend
LIBCLOUD_DESC= Apache Libcloud backend
S3_DESC= Amazon S3 backend
SFTP_DESC= SFTP backend
-DROPBOX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dropbox>=7.2.1:www/py-dropbox@${PY_FLAVOR}
+#AZURE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}azure-core>=1.13:devel/py-azure-core@${PY_FLAVOR} \
+# ${PYTHON_PKGNAMEPREFIX}azure-storage-blob>=12:devel/py-azure-storage-blob@${PY_FLAVOR}
GOOGLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-cloud-storage>=1.27:www/py-google-cloud-storage@${PY_FLAVOR}
-LIBCLOUD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libcloud>0:net/py-libcloud@${PY_FLAVOR}
+LIBCLOUD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libcloud>=0:net/py-libcloud@${PY_FLAVOR}
S3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1.4.4:www/py-boto3@${PY_FLAVOR}
SFTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.15:security/py-paramiko@${PY_FLAVOR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDROPBOX} && ${PYTHON_REL} < 31200
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dropbox>=7.2.1:www/py-dropbox@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-django-storages/distinfo b/www/py-django-storages/distinfo
index 31d6fcfadf8a..4d91ebfa6562 100644
--- a/www/py-django-storages/distinfo
+++ b/www/py-django-storages/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1704627222
-SHA256 (django-storages-1.14.2.tar.gz) = 51b36af28cc5813b98d5f3dfe7459af638d84428c8df4a03990c7d74d1bea4e5
-SIZE (django-storages-1.14.2.tar.gz) = 111090
+TIMESTAMP = 1715843838
+SHA256 (django-storages-1.14.3.tar.gz) = 95a12836cd998d4c7a4512347322331c662d9114c4344f932f5e9c0fce000608
+SIZE (django-storages-1.14.3.tar.gz) = 115310