aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeal Nelson <ports@nicandneal.net>2021-10-28 04:20:43 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-10-28 08:40:42 +0000
commitc5067c3e7ef42ebe1b7ad44cc436371e65d1d913 (patch)
tree20e8553719f7b9e314e2333c6b6e61142c05647e
parent02aae98be222822716025d2c37d9f43f2c1640c4 (diff)
downloadports-c5067c3e7ef42ebe1b7ad44cc436371e65d1d913.tar.gz
ports-c5067c3e7ef42ebe1b7ad44cc436371e65d1d913.zip
devel/py-cymbal: Add new port
Cymbal makes it easy to add functionality missing from libclang Python bindings The Clang libclang python bindings use ctypes to invoke functions present in libclang dynamic library. In some cases, only a subset of the C functions are available, because the platform or version specific Python bindings omit functions. Cymbal simplfies the process of dynamically adding those methods to Types and Cursors. PR: 256925
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cymbal/Makefile22
-rw-r--r--devel/py-cymbal/distinfo3
-rw-r--r--devel/py-cymbal/pkg-descr10
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7071a721ef14..9f394ba50ed4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4390,6 +4390,7 @@
SUBDIR += py-cwcwidth
SUBDIR += py-cxx
SUBDIR += py-cycler
+ SUBDIR += py-cymbal
SUBDIR += py-cymem
SUBDIR += py-cysignals
SUBDIR += py-cytoolz
diff --git a/devel/py-cymbal/Makefile b/devel/py-cymbal/Makefile
new file mode 100644
index 000000000000..cbf597f66f55
--- /dev/null
+++ b/devel/py-cymbal/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= cymbal
+DISTVERSION= 1.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@nicandneal.net
+COMMENT= Easily add functionality missing from libclang Python bindings
+
+LICENSE= MIT
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+TEST_TARGET= test
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m unittest2 discover
+
+.include <bsd.port.mk>
diff --git a/devel/py-cymbal/distinfo b/devel/py-cymbal/distinfo
new file mode 100644
index 000000000000..7da20799d163
--- /dev/null
+++ b/devel/py-cymbal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626094156
+SHA256 (cymbal-1.0.0.tar.gz) = 1c79a00190bc8646505392b904e6e76410e98018f96f247ff7d363365241e2e0
+SIZE (cymbal-1.0.0.tar.gz) = 4145
diff --git a/devel/py-cymbal/pkg-descr b/devel/py-cymbal/pkg-descr
new file mode 100644
index 000000000000..ad292a17beea
--- /dev/null
+++ b/devel/py-cymbal/pkg-descr
@@ -0,0 +1,10 @@
+Cymbal makes it easy to add functionality missing from libclang Python
+bindings
+
+The Clang libclang python bindings use ctypes to invoke functions
+present in libclang dynamic library. In some cases, only a subset of
+the C functions are available, because the platform or version
+specific Python bindings omit functions. Cymbal simplfies the process
+of dynamically adding those methods to Types and Cursors.
+
+WWW: https://github.com/CadQuery/cymbal