aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2024-09-01 14:30:46 +0000
committerRene Ladan <rene@FreeBSD.org>2024-09-01 14:30:46 +0000
commitc5785f87529c4e2c840e74311c318378503b896d (patch)
treec798e91e375d526dd293c79b02fcc6a16876ca0e
parentcefa8184e1bc2eb393aad7cdcd4c314253853ca1 (diff)
downloadports-c5785f87529c4e2c840e74311c318378503b896d.tar.gz
ports-c5785f87529c4e2c840e74311c318378503b896d.zip
sysutils/apache-mesos: Remove expired port
2024-05-31 sysutils/apache-mesos: Marked BROKEN for over a year
-rw-r--r--MOVED1
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/apache-mesos/Makefile117
-rw-r--r--sysutils/apache-mesos/distinfo5
-rw-r--r--sysutils/apache-mesos/files/extra-patch-src_java_mesos.pom.in20
-rw-r--r--sysutils/apache-mesos/files/maven-deps.pom53
-rw-r--r--sysutils/apache-mesos/files/patch-protobuf22
-rw-r--r--sysutils/apache-mesos/pkg-descr3
-rw-r--r--sysutils/apache-mesos/pkg-plist573
9 files changed, 1 insertions, 794 deletions
diff --git a/MOVED b/MOVED
index 75feea3b8f03..b7ddc7c8fec8 100644
--- a/MOVED
+++ b/MOVED
@@ -3452,3 +3452,4 @@ graphics/R-cran-rgdal||2024-09-01|Has expired: Fails to build and upstream recom
math/ploticus||2024-09-01|Has expired: Depends on expired graphics/ming
graphics/ming||2024-09-01|Has expired: SWF format is essentially dead after Flash Player's EoL
dns/adsuck||2024-09-01|Has expired: Obsolete, no longer relevant
+sysutils/apache-mesos||2024-09-01|Has expired: Marked BROKEN for over a year
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 08725c36f338..6eb8aae4d502 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -48,7 +48,6 @@
SUBDIR += ansible-sshjail
SUBDIR += ansible-sysrc
SUBDIR += anvil
- SUBDIR += apache-mesos
SUBDIR += apachetop
SUBDIR += apcctrl
SUBDIR += apcpwr
diff --git a/sysutils/apache-mesos/Makefile b/sysutils/apache-mesos/Makefile
deleted file mode 100644
index c059cf761c5b..000000000000
--- a/sysutils/apache-mesos/Makefile
+++ /dev/null
@@ -1,117 +0,0 @@
-PORTNAME= mesos
-PORTVERSION= 1.11.0
-PORTREVISION= 16
-CATEGORIES= sysutils
-MASTER_SITES= APACHE/mesos/${PORTVERSION}:mesos
-PKGNAMEPREFIX= apache-
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:mesos
-DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
-
-MAINTAINER= james.wright@digital-chaos.com
-COMMENT= Cluster manager providing resource isolation and sharing
-WWW= https://mesos.apache.org/
-
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-BROKEN= fails to build, configure: error: Cannot find the ELFIO headers
-DEPRECATED= Marked BROKEN for over a year
-EXPIRATION_DATE=2024-05-31
-
-BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
- elfio>0:devel/elfio \
- http-parser>0:www/http-parser \
- leveldb>0:databases/leveldb \
- picojson>0:devel/picojson \
- protobuf>0:devel/protobuf \
- rapidjson>0:devel/rapidjson \
- libzookeeper>0:devel/libzookeeper
-LIB_DEPENDS= libapr-1.so:devel/apr1 \
- libcurl.so:ftp/curl \
- libgpr.so:devel/grpc \
- libglog.so:devel/glog \
- libhttp_parser.so:www/http-parser \
- libev.so:devel/libev \
- libleveldb.so:databases/leveldb \
- libprotobuf.so:devel/protobuf \
- libsasl2.so:security/cyrus-sasl2 \
- libzookeeper_mt.so:devel/libzookeeper
-.if ${WITH_SUBVERSION_VER:U} == LTS
-LIB_DEPENDS+= libsvn_delta-1.so:devel/subversion-lts
-LIB_DEPENDS+= libsvn_subr-1.so:devel/subversion-lts
-.else
-LIB_DEPENDS+= libsvn_delta-1.so:devel/subversion
-LIB_DEPENDS+= libsvn_subr-1.so:devel/subversion
-.endif
-
-USES= cpe gmake libarchive libtool python:run shebangfix
-CPE_VENDOR= apache
-USE_LDCONFIG= yes
-SHEBANG_FILES= src/cli/mesos-cat \
- src/cli/mesos-ps \
- src/cli/mesos-scp \
- src/cli/mesos-tail
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-java \
- --disable-python \
- --disable-werror \
- --with-apr=${LOCALBASE} \
- --with-boost=${LOCALBASE} \
- --with-elfio=${LOCALBASE} \
- --with-glog=${LOCALBASE} \
- --with-grpc=${LOCALBASE} \
- --with-http_parser=${LOCALBASE} \
- --with-leveldb=${LOCALBASE} \
- --with-libarchive=${LOCALBASE} \
- --with-libev=${LOCALBASE} \
- --with-protobuf=${LOCALBASE} \
- --with-picojson=${LOCALBASE} \
- --with-rapidjson=${LOCALBASE} \
- --with-sasl=${LOCALBASE} \
- --with-svn=${LOCALBASE} \
- --with-zookeeper=${LOCALBASE}
-
-INSTALL_TARGET= install-strip
-
-OPTIONS_DEFINE= DEPLOY JAVA
-OPTIONS_SUB= yes
-
-DEPLOY_DESC= Install deploy scripts
-JAVA_DESC= Enable Java bindings
-
-JAVA_CONFIGURE_ENABLE= java
-JAVA_USE= java=yes
-JAVA_BUILD_DEPENDS= maven>0:devel/maven
-JAVA_FETCH_DEPENDS= maven>0:devel/maven
-JAVA_CONFIGURE_ENV= PROTOBUF_JAR="${MAVEN_REPO}/com/google/protobuf/protobuf-java/${PROTOBUF_VERSION}/protobuf-java-${PROTOBUF_VERSION}.jar"
-JAVA_MAKE_ENV= MAVEN_OPTS="${MAVEN_OPTS}"
-JAVA_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src_java_mesos.pom.in
-
-# REVIEW: Can we figure out the current Protobuf version in ports instead of hardcoding???
-PROTOBUF_VERSION= 3.14.0
-
-MAVEN_CMD= mvn
-MAVEN_REPO= ${WRKDIR}/mesos-maven-deps-${PORTVERSION}
-MAVEN_OPTS= -Dmaven.repo.local=${MAVEN_REPO}
-MAVEN_ENV= PROTOBUF_VERSION="${PROTOBUF_VERSION}" MAVEN_OPTS="${MAVEN_OPTS}"
-MAVEN_POM= ${FILESDIR}/maven-deps.pom
-
-DEV_BUILD_MODE= no
-
-.if (${DEV_BUILD_MODE} == "yes")
-# Fetch Maven build dependencies upfront into local Maven Repo
-# Needs to be after extract (as WRKDIR gets wiped) but before Configure
-post-extract-JAVA-on:
- @${SETENV} ${MAVEN_ENV} \
- ${MAVEN_CMD} -f ${MAVEN_POM} dependency:go-offline
-.else
-MASTER_SITES+= https://github.com/Digital-Chaos/mesos-maven-deps/archive/${DISTVERSION}/:maven
-DISTFILES+= mesos-maven-deps-${DISTVERSION}${EXTRACT_SUFX}:maven
-.endif
-
-# Replace Protobuf version in src/java/mesos.pom.in
-do-patch-JAVA-on:
- @${REINPLACE_CMD} -e 's|@PROTOBUF_VERSION@|${PROTOBUF_VERSION}|g' ${WRKSRC}/src/java/mesos.pom.in
-
-.include <bsd.port.mk>
diff --git a/sysutils/apache-mesos/distinfo b/sysutils/apache-mesos/distinfo
deleted file mode 100644
index 81c8c97caed9..000000000000
--- a/sysutils/apache-mesos/distinfo
+++ /dev/null
@@ -1,5 +0,0 @@
-TIMESTAMP = 1615762466
-SHA256 (apache-mesos/mesos-1.11.0.tar.gz) = ce08cb648a21502a4a0c45d240a596d9ac860fcaf717f9a3dc986da9d406fe34
-SIZE (apache-mesos/mesos-1.11.0.tar.gz) = 72210031
-SHA256 (apache-mesos/mesos-maven-deps-1.11.0.tar.gz) = 98acd50b2d22018f5c79127ea14245e863c4c1bd0092c65c85ef9a147d488def
-SIZE (apache-mesos/mesos-maven-deps-1.11.0.tar.gz) = 36003620
diff --git a/sysutils/apache-mesos/files/extra-patch-src_java_mesos.pom.in b/sysutils/apache-mesos/files/extra-patch-src_java_mesos.pom.in
deleted file mode 100644
index b674ea07205b..000000000000
--- a/sysutils/apache-mesos/files/extra-patch-src_java_mesos.pom.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/java/mesos.pom.in.orig 2020-06-16 03:05:20 UTC
-+++ src/java/mesos.pom.in
-@@ -36,7 +36,7 @@
- <dependency>
- <artifactId>protobuf-java</artifactId>
- <groupId>com.google.protobuf</groupId>
-- <version>3.5.0</version>
-+ <version>@PROTOBUF_VERSION@</version>
- </dependency>
- </dependencies>
- <build>
-@@ -168,7 +168,7 @@
- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-dependency-plugin</artifactId>
-- <version>2.8</version>
-+ <version>3.1.2</version>
- <executions>
- <execution>
- <id>copy-dependencies</id>
diff --git a/sysutils/apache-mesos/files/maven-deps.pom b/sysutils/apache-mesos/files/maven-deps.pom
deleted file mode 100644
index eba73b330d63..000000000000
--- a/sysutils/apache-mesos/files/maven-deps.pom
+++ /dev/null
@@ -1,53 +0,0 @@
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <groupId>org.apache.mesos</groupId>
- <artifactId>mesos</artifactId>
- <name>mesos</name>
- <version>1.11.0</version>
- <description>The Apache Mesos Java API jar.</description>
- <url>http://mesos.apache.org</url>
- <parent>
- <groupId>org.apache</groupId>
- <artifactId>apache</artifactId>
- <version>11</version>
- </parent>
- <dependencies>
- <dependency>
- <artifactId>protobuf-java</artifactId>
- <groupId>com.google.protobuf</groupId>
- <version>${env.PROTOBUF_VERSION}</version>
- </dependency>
- <dependency>
- <artifactId>apache-jar-resource-bundle</artifactId>
- <groupId>org.apache</groupId>
- <version>1.4</version>
- </dependency>
- </dependencies>
- <build>
- <plugins>
- <plugin>
- <artifactId>maven-dependency-plugin</artifactId>
- <version>3.1.2</version>
- </plugin>
- <plugin>
- <artifactId>maven-gpg-plugin</artifactId>
- </plugin>
- <plugin>
- <artifactId>maven-javadoc-plugin</artifactId>
- </plugin>
- <plugin>
- <artifactId>maven-shade-plugin</artifactId>
- <version>2.2</version>
- </plugin>
- <plugin>
- <artifactId>maven-source-plugin</artifactId>
- </plugin>
- <plugin>
- <groupId>org.codehaus.mojo</groupId>
- <artifactId>build-helper-maven-plugin</artifactId>
- <version>1.8</version>
- </plugin>
- </plugins>
- </build>
-</project>
-
diff --git a/sysutils/apache-mesos/files/patch-protobuf b/sysutils/apache-mesos/files/patch-protobuf
deleted file mode 100644
index a748c982f8b8..000000000000
--- a/sysutils/apache-mesos/files/patch-protobuf
+++ /dev/null
@@ -1,22 +0,0 @@
---- include/mesos/csi/v0.hpp.orig 2020-11-17 13:52:12 UTC
-+++ include/mesos/csi/v0.hpp
-@@ -94,7 +94,7 @@ std::ostream& operator<<(std::ostream& stream, const M
- google::protobuf::util::MessageToJsonString(message, &output);
-
- CHECK(status.ok())
-- << "Could not convert messages to string: " << status.error_message();
-+ << "Could not convert messages to string: " << status.message();
-
- return stream << output;
- }
---- include/mesos/csi/v1.hpp.orig 2020-11-17 13:52:12 UTC
-+++ include/mesos/csi/v1.hpp
-@@ -94,7 +94,7 @@ std::ostream& operator<<(std::ostream& stream, const M
- google::protobuf::util::MessageToJsonString(message, &output);
-
- CHECK(status.ok())
-- << "Could not convert messages to string: " << status.error_message();
-+ << "Could not convert messages to string: " << status.message();
-
- return stream << output;
- }
diff --git a/sysutils/apache-mesos/pkg-descr b/sysutils/apache-mesos/pkg-descr
deleted file mode 100644
index 65b339d0ef3c..000000000000
--- a/sysutils/apache-mesos/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Apache Mesos abstracts CPU, memory, storage, and other compute resources away
-from machines (physical or virtual), enabling fault-tolerant and elastic
-distributed systems to easily be built and run effectively.
diff --git a/sysutils/apache-mesos/pkg-plist b/sysutils/apache-mesos/pkg-plist
deleted file mode 100644
index f9d1a88a96bb..000000000000
--- a/sysutils/apache-mesos/pkg-plist
+++ /dev/null
@@ -1,573 +0,0 @@
-bin/mesos
-bin/mesos-cat
-bin/mesos-execute
-bin/mesos-local
-bin/mesos-log
-bin/mesos-ps
-bin/mesos-resolve
-bin/mesos-scp
-bin/mesos-tail
-%%DEPLOY%%@sample %%ETCDIR%%/mesos-agent-env.sh.template %%ETCDIR%%/mesos-agent-env.sh
-%%DEPLOY%%@sample %%ETCDIR%%/mesos-deploy-env.sh.template %%ETCDIR%%/mesos-deploy-env.sh
-%%DEPLOY%%@sample %%ETCDIR%%/mesos-master-env.sh.template %%ETCDIR%%/mesos-master-env.sh
-%%DEPLOY%%@sample %%ETCDIR%%/mesos-slave-env.sh.template %%ETCDIR%%/mesos-slave-env.sh
-include/concurrentqueue.h
-include/csi/v0/csi.grpc.pb.h
-include/csi/v0/csi.pb.h
-include/csi/v0/csi.proto
-include/csi/v1/csi.grpc.pb.h
-include/csi/v1/csi.pb.h
-include/csi/v1/csi.proto
-include/mesos/agent/agent.hpp
-include/mesos/agent/agent.pb.h
-include/mesos/agent/agent.proto
-include/mesos/agent/container_logger.hpp
-include/mesos/agent/containerizer.hpp
-include/mesos/agent/containerizer.pb.h
-include/mesos/agent/isolator.hpp
-include/mesos/agent/oversubscription.hpp
-include/mesos/agent/oversubscription.pb.h
-include/mesos/agent/oversubscription.proto
-include/mesos/agent/qos_controller.hpp
-include/mesos/agent/resource_estimator.hpp
-include/mesos/allocator/allocator.hpp
-include/mesos/allocator/allocator.pb.h
-include/mesos/allocator/allocator.proto
-include/mesos/appc/spec.hpp
-include/mesos/appc/spec.pb.h
-include/mesos/appc/spec.proto
-include/mesos/attributes.hpp
-include/mesos/authentication/authenticatee.hpp
-include/mesos/authentication/authentication.hpp
-include/mesos/authentication/authentication.pb.h
-include/mesos/authentication/authentication.proto
-include/mesos/authentication/authenticator.hpp
-include/mesos/authentication/http/authenticatee.hpp
-include/mesos/authentication/http/basic_authenticator_factory.hpp
-include/mesos/authentication/http/combined_authenticator.hpp
-include/mesos/authentication/secret_generator.hpp
-include/mesos/authorizer/acls.hpp
-include/mesos/authorizer/acls.pb.h
-include/mesos/authorizer/acls.proto
-include/mesos/authorizer/authorizer.hpp
-include/mesos/authorizer/authorizer.pb.h
-include/mesos/authorizer/authorizer.proto
-include/mesos/csi/v0.hpp
-include/mesos/csi/v1.hpp
-include/mesos/docker/spec.hpp
-include/mesos/docker/spec.pb.h
-include/mesos/docker/spec.proto
-include/mesos/docker/v1.hpp
-include/mesos/docker/v1.pb.h
-include/mesos/docker/v1.proto
-include/mesos/docker/v2.hpp
-include/mesos/docker/v2.pb.h
-include/mesos/docker/v2.proto
-include/mesos/docker/v2_2.hpp
-include/mesos/docker/v2_2.pb.h
-include/mesos/docker/v2_2.proto
-include/mesos/executor.hpp
-include/mesos/executor/executor.hpp
-include/mesos/executor/executor.pb.h
-include/mesos/executor/executor.proto
-include/mesos/fetcher/fetcher.hpp
-include/mesos/fetcher/fetcher.pb.h
-include/mesos/fetcher/fetcher.proto
-include/mesos/hook.hpp
-include/mesos/http.hpp
-include/mesos/log/log.hpp
-include/mesos/maintenance/maintenance.hpp
-include/mesos/maintenance/maintenance.pb.h
-include/mesos/maintenance/maintenance.proto
-include/mesos/master/contender.hpp
-include/mesos/master/detector.hpp
-include/mesos/master/master.hpp
-include/mesos/master/master.pb.h
-include/mesos/master/master.proto
-include/mesos/mesos.hpp
-include/mesos/mesos.pb.h
-include/mesos/mesos.proto
-include/mesos/module.hpp
-include/mesos/module/allocator.hpp
-include/mesos/module/anonymous.hpp
-include/mesos/module/authenticatee.hpp
-include/mesos/module/authenticator.hpp
-include/mesos/module/authorizer.hpp
-include/mesos/module/container_logger.hpp
-include/mesos/module/contender.hpp
-include/mesos/module/detector.hpp
-include/mesos/module/disk_profile_adaptor.hpp
-include/mesos/module/hook.hpp
-include/mesos/module/hook.pb.h
-include/mesos/module/hook.proto
-include/mesos/module/http_authenticatee.hpp
-include/mesos/module/http_authenticator.hpp
-include/mesos/module/isolator.hpp
-include/mesos/module/module.hpp
-include/mesos/module/module.pb.h
-include/mesos/module/module.proto
-include/mesos/module/qos_controller.hpp
-include/mesos/module/resource_estimator.hpp
-include/mesos/module/secret_generator.hpp
-include/mesos/module/secret_resolver.hpp
-include/mesos/oci/spec.hpp
-include/mesos/oci/spec.pb.h
-include/mesos/oci/spec.proto
-include/mesos/quota/quota.hpp
-include/mesos/quota/quota.pb.h
-include/mesos/quota/quota.proto
-include/mesos/resource_provider/resource_provider.hpp
-include/mesos/resource_provider/resource_provider.pb.h
-include/mesos/resource_provider/resource_provider.proto
-include/mesos/resource_provider/storage/disk_profile_adaptor.hpp
-include/mesos/resource_quantities.hpp
-include/mesos/resources.hpp
-include/mesos/roles.hpp
-include/mesos/scheduler.hpp
-include/mesos/scheduler/scheduler.hpp
-include/mesos/scheduler/scheduler.pb.h
-include/mesos/scheduler/scheduler.proto
-include/mesos/seccomp/seccomp.hpp
-include/mesos/seccomp/seccomp.pb.h
-include/mesos/seccomp/seccomp.proto
-include/mesos/secret/resolver.hpp
-include/mesos/slave
-include/mesos/state/in_memory.hpp
-include/mesos/state/leveldb.hpp
-include/mesos/state/log.hpp
-include/mesos/state/protobuf.hpp
-include/mesos/state/state.hpp
-include/mesos/state/state.pb.h
-include/mesos/state/state.proto
-include/mesos/state/storage.hpp
-include/mesos/state/zookeeper.hpp
-include/mesos/type_utils.hpp
-include/mesos/uri/fetcher.hpp
-include/mesos/uri/uri.hpp
-include/mesos/uri/uri.pb.h
-include/mesos/uri/uri.proto
-include/mesos/v1/agent/agent.hpp
-include/mesos/v1/agent/agent.pb.h
-include/mesos/v1/agent/agent.proto
-include/mesos/v1/allocator/allocator.pb.h
-include/mesos/v1/allocator/allocator.proto
-include/mesos/v1/attributes.hpp
-include/mesos/v1/executor.hpp
-include/mesos/v1/executor/executor.hpp
-include/mesos/v1/executor/executor.pb.h
-include/mesos/v1/executor/executor.proto
-include/mesos/v1/maintenance/maintenance.hpp
-include/mesos/v1/maintenance/maintenance.pb.h
-include/mesos/v1/maintenance/maintenance.proto
-include/mesos/v1/master/master.hpp
-include/mesos/v1/master/master.pb.h
-include/mesos/v1/master/master.proto
-include/mesos/v1/mesos.hpp
-include/mesos/v1/mesos.pb.h
-include/mesos/v1/mesos.proto
-include/mesos/v1/quota/quota.pb.h
-include/mesos/v1/quota/quota.proto
-include/mesos/v1/resource_provider.hpp
-include/mesos/v1/resource_provider/resource_provider.hpp
-include/mesos/v1/resource_provider/resource_provider.pb.h
-include/mesos/v1/resource_provider/resource_provider.proto
-include/mesos/v1/resources.hpp
-include/mesos/v1/scheduler.hpp
-include/mesos/v1/scheduler/scheduler.hpp
-include/mesos/v1/scheduler/scheduler.pb.h
-include/mesos/v1/scheduler/scheduler.proto
-include/mesos/v1/values.hpp
-include/mesos/values.hpp
-include/mesos/version.hpp
-include/mesos/zookeeper/authentication.hpp
-include/mesos/zookeeper/contender.hpp
-include/mesos/zookeeper/detector.hpp
-include/mesos/zookeeper/group.hpp
-include/mesos/zookeeper/url.hpp
-include/mesos/zookeeper/watcher.hpp
-include/mesos/zookeeper/zookeeper.hpp
-include/process/address.hpp
-include/process/after.hpp
-include/process/async.hpp
-include/process/authenticator.hpp
-include/process/check.hpp
-include/process/clock.hpp
-include/process/collect.hpp
-include/process/count_down_latch.hpp
-include/process/defer.hpp
-include/process/deferred.hpp
-include/process/delay.hpp
-include/process/dispatch.hpp
-include/process/event.hpp
-include/process/executor.hpp
-include/process/filter.hpp
-include/process/firewall.hpp
-include/process/future.hpp
-include/process/gmock.hpp
-include/process/grpc.hpp
-include/process/gtest.hpp
-include/process/gtest_constants.hpp
-include/process/help.hpp
-include/process/http.hpp
-include/process/id.hpp
-include/process/io.hpp
-include/process/jwt.hpp
-include/process/latch.hpp
-include/process/limiter.hpp
-include/process/logging.hpp
-include/process/loop.hpp
-include/process/message.hpp
-include/process/metrics/counter.hpp
-include/process/metrics/metric.hpp
-include/process/metrics/metrics.hpp
-include/process/metrics/pull_gauge.hpp
-include/process/metrics/push_gauge.hpp
-include/process/metrics/timer.hpp
-include/process/mime.hpp
-include/process/mutex.hpp
-include/process/network.hpp
-include/process/once.hpp
-include/process/owned.hpp
-include/process/pid.hpp
-include/process/process.hpp
-include/process/profiler.hpp
-include/process/protobuf.hpp
-include/process/queue.hpp
-include/process/reap.hpp
-include/process/run.hpp
-include/process/rwlock.hpp
-include/process/sequence.hpp
-include/process/shared.hpp
-include/process/socket.hpp
-include/process/ssl/flags.hpp
-include/process/ssl/gtest.hpp
-include/process/ssl/tls_config.hpp
-include/process/ssl/utilities.hpp
-include/process/state_machine.hpp
-include/process/statistics.hpp
-include/process/subprocess.hpp
-include/process/system.hpp
-include/process/time.hpp
-include/process/timeout.hpp
-include/process/timer.hpp
-include/process/timeseries.hpp
-include/stout/abort.hpp
-include/stout/adaptor.hpp
-include/stout/archiver.hpp
-include/stout/assert.hpp
-include/stout/attributes.hpp
-include/stout/base64.hpp
-include/stout/bits.hpp
-include/stout/boundedhashmap.hpp
-include/stout/bytes.hpp
-include/stout/cache.hpp
-include/stout/check.hpp
-include/stout/circular_buffer.hpp
-include/stout/cpp14.hpp
-include/stout/cpp17.hpp
-include/stout/duration.hpp
-include/stout/dynamiclibrary.hpp
-include/stout/elf.hpp
-include/stout/error.hpp
-include/stout/errorbase.hpp
-include/stout/exit.hpp
-include/stout/flags.hpp
-include/stout/flags/fetch.hpp
-include/stout/flags/flag.hpp
-include/stout/flags/flags.hpp
-include/stout/flags/parse.hpp
-include/stout/foreach.hpp
-include/stout/format.hpp
-include/stout/fs.hpp
-include/stout/gtest.hpp
-include/stout/gzip.hpp
-include/stout/hashmap.hpp
-include/stout/hashset.hpp
-include/stout/internal/windows/attributes.hpp
-include/stout/internal/windows/grp.hpp
-include/stout/internal/windows/longpath.hpp
-include/stout/internal/windows/overlapped.hpp
-include/stout/internal/windows/pwd.hpp
-include/stout/internal/windows/reparsepoint.hpp
-include/stout/internal/windows/symlink.hpp
-include/stout/interval.hpp
-include/stout/ip.hpp
-include/stout/json.hpp
-include/stout/jsonify.hpp
-include/stout/lambda.hpp
-include/stout/linkedhashmap.hpp
-include/stout/mac.hpp
-include/stout/multihashmap.hpp
-include/stout/multimap.hpp
-include/stout/net.hpp
-include/stout/none.hpp
-include/stout/nothing.hpp
-include/stout/numify.hpp
-include/stout/option.hpp
-include/stout/os.hpp
-include/stout/os/access.hpp
-include/stout/os/bootid.hpp
-include/stout/os/chdir.hpp
-include/stout/os/chroot.hpp
-include/stout/os/close.hpp
-include/stout/os/constants.hpp
-include/stout/os/copyfile.hpp
-include/stout/os/dup.hpp
-include/stout/os/environment.hpp
-include/stout/os/exec.hpp
-include/stout/os/exists.hpp
-include/stout/os/fcntl.hpp
-include/stout/os/find.hpp
-include/stout/os/fork.hpp
-include/stout/os/freebsd.hpp
-include/stout/os/fsync.hpp
-include/stout/os/ftruncate.hpp
-include/stout/os/getcwd.hpp
-include/stout/os/getenv.hpp
-include/stout/os/int_fd.hpp
-include/stout/os/kill.hpp
-include/stout/os/killtree.hpp
-include/stout/os/linux.hpp
-include/stout/os/ls.hpp
-include/stout/os/lseek.hpp
-include/stout/os/lsof.hpp
-include/stout/os/mkdir.hpp
-include/stout/os/mkdtemp.hpp
-include/stout/os/mktemp.hpp
-include/stout/os/open.hpp
-include/stout/os/os.hpp
-include/stout/os/osx.hpp
-include/stout/os/pagesize.hpp
-include/stout/os/permissions.hpp
-include/stout/os/pipe.hpp
-include/stout/os/posix/bootid.hpp
-include/stout/os/posix/chdir.hpp
-include/stout/os/posix/chown.hpp
-include/stout/os/posix/chroot.hpp
-include/stout/os/posix/close.hpp
-include/stout/os/posix/copyfile.hpp
-include/stout/os/posix/dup.hpp
-include/stout/os/posix/environment.hpp
-include/stout/os/posix/exec.hpp
-include/stout/os/posix/exists.hpp
-include/stout/os/posix/fcntl.hpp
-include/stout/os/posix/fork.hpp
-include/stout/os/posix/fsync.hpp
-include/stout/os/posix/ftruncate.hpp
-include/stout/os/posix/getcwd.hpp
-include/stout/os/posix/getenv.hpp
-include/stout/os/posix/kill.hpp
-include/stout/os/posix/killtree.hpp
-include/stout/os/posix/ls.hpp
-include/stout/os/posix/lseek.hpp
-include/stout/os/posix/lsof.hpp
-include/stout/os/posix/mkdir.hpp
-include/stout/os/posix/mkdtemp.hpp
-include/stout/os/posix/mktemp.hpp
-include/stout/os/posix/open.hpp
-include/stout/os/posix/pagesize.hpp
-include/stout/os/posix/pipe.hpp
-include/stout/os/posix/read.hpp
-include/stout/os/posix/realpath.hpp
-include/stout/os/posix/rename.hpp
-include/stout/os/posix/rm.hpp
-include/stout/os/posix/rmdir.hpp
-include/stout/os/posix/sendfile.hpp
-include/stout/os/posix/shell.hpp
-include/stout/os/posix/signals.hpp
-include/stout/os/posix/socket.hpp
-include/stout/os/posix/stat.hpp
-include/stout/os/posix/su.hpp
-include/stout/os/posix/temp.hpp
-include/stout/os/posix/which.hpp
-include/stout/os/posix/write.hpp
-include/stout/os/posix/xattr.hpp
-include/stout/os/process.hpp
-include/stout/os/pstree.hpp
-include/stout/os/raw/argv.hpp
-include/stout/os/raw/environment.hpp
-include/stout/os/read.hpp
-include/stout/os/realpath.hpp
-include/stout/os/rename.hpp
-include/stout/os/rm.hpp
-include/stout/os/rmdir.hpp
-include/stout/os/sendfile.hpp
-include/stout/os/shell.hpp
-include/stout/os/signals.hpp
-include/stout/os/socket.hpp
-include/stout/os/stat.hpp
-include/stout/os/strerror.hpp
-include/stout/os/su.hpp
-include/stout/os/sysctl.hpp
-include/stout/os/temp.hpp
-include/stout/os/touch.hpp
-include/stout/os/utime.hpp
-include/stout/os/wait.hpp
-include/stout/os/which.hpp
-include/stout/os/windows/bootid.hpp
-include/stout/os/windows/chdir.hpp
-include/stout/os/windows/chroot.hpp
-include/stout/os/windows/close.hpp
-include/stout/os/windows/copyfile.hpp
-include/stout/os/windows/dup.hpp
-include/stout/os/windows/environment.hpp
-include/stout/os/windows/exec.hpp
-include/stout/os/windows/exists.hpp
-include/stout/os/windows/fcntl.hpp
-include/stout/os/windows/fd.hpp
-include/stout/os/windows/fork.hpp
-include/stout/os/windows/fsync.hpp
-include/stout/os/windows/ftruncate.hpp
-include/stout/os/windows/getcwd.hpp
-include/stout/os/windows/getenv.hpp
-include/stout/os/windows/jobobject.hpp
-include/stout/os/windows/kill.hpp
-include/stout/os/windows/killtree.hpp
-include/stout/os/windows/ls.hpp
-include/stout/os/windows/lseek.hpp
-include/stout/os/windows/lsof.hpp
-include/stout/os/windows/mkdir.hpp
-include/stout/os/windows/mkdtemp.hpp
-include/stout/os/windows/mktemp.hpp
-include/stout/os/windows/open.hpp
-include/stout/os/windows/pagesize.hpp
-include/stout/os/windows/pipe.hpp
-include/stout/os/windows/read.hpp
-include/stout/os/windows/realpath.hpp
-include/stout/os/windows/rename.hpp
-include/stout/os/windows/rm.hpp
-include/stout/os/windows/rmdir.hpp
-include/stout/os/windows/sendfile.hpp
-include/stout/os/windows/shell.hpp
-include/stout/os/windows/socket.hpp
-include/stout/os/windows/stat.hpp
-include/stout/os/windows/su.hpp
-include/stout/os/windows/temp.hpp
-include/stout/os/windows/which.hpp
-include/stout/os/windows/write.hpp
-include/stout/os/windows/xattr.hpp
-include/stout/os/write.hpp
-include/stout/os/xattr.hpp
-include/stout/overload.hpp
-include/stout/path.hpp
-include/stout/posix/dynamiclibrary.hpp
-include/stout/posix/fs.hpp
-include/stout/posix/ip.hpp
-include/stout/posix/mac.hpp
-include/stout/posix/net.hpp
-include/stout/posix/os.hpp
-include/stout/preprocessor.hpp
-include/stout/proc.hpp
-include/stout/protobuf.hpp
-include/stout/recordio.hpp
-include/stout/representation.hpp
-include/stout/result.hpp
-include/stout/result_of.hpp
-include/stout/set.hpp
-include/stout/some.hpp
-include/stout/stopwatch.hpp
-include/stout/stringify.hpp
-include/stout/strings.hpp
-include/stout/subcommand.hpp
-include/stout/svn.hpp
-include/stout/synchronized.hpp
-include/stout/tests/environment.hpp
-include/stout/tests/utils.hpp
-include/stout/traits.hpp
-include/stout/try.hpp
-include/stout/unimplemented.hpp
-include/stout/unreachable.hpp
-include/stout/uri.hpp
-include/stout/utils.hpp
-include/stout/uuid.hpp
-include/stout/variant.hpp
-include/stout/version.hpp
-include/stout/windows.hpp
-include/stout/windows/dynamiclibrary.hpp
-include/stout/windows/error.hpp
-include/stout/windows/format.hpp
-include/stout/windows/fs.hpp
-include/stout/windows/ip.hpp
-include/stout/windows/mac.hpp
-include/stout/windows/net.hpp
-include/stout/windows/os.hpp
-lib/libfixed_resource_estimator-1.11.0.so
-lib/libfixed_resource_estimator.so
-lib/libload_qos_controller-1.11.0.so
-lib/libload_qos_controller.so
-lib/liblogrotate_container_logger-1.11.0.so
-lib/liblogrotate_container_logger.so
-lib/libmesos-1.11.0.so
-lib/libmesos.so
-lib/mesos/modules/libfixed_resource_estimator-1.11.0.so
-lib/mesos/modules/libfixed_resource_estimator.so
-lib/mesos/modules/libload_qos_controller-1.11.0.so
-lib/mesos/modules/libload_qos_controller.so
-lib/mesos/modules/liblogrotate_container_logger-1.11.0.so
-lib/mesos/modules/liblogrotate_container_logger.so
-lib/mesos/modules/liburi_disk_profile_adaptor-1.11.0.so
-lib/mesos/modules/liburi_disk_profile_adaptor.so
-libdata/pkgconfig/mesos.pc
-libexec/mesos/mesos-containerizer
-libexec/mesos/mesos-default-executor
-libexec/mesos/mesos-docker-executor
-libexec/mesos/mesos-executor
-libexec/mesos/mesos-fetcher
-libexec/mesos/mesos-io-switchboard
-libexec/mesos/mesos-logrotate-logger
-libexec/mesos/mesos-tcp-connect
-libexec/mesos/mesos-usage
-sbin/mesos-agent
-%%DEPLOY%%sbin/mesos-daemon.sh
-sbin/mesos-master
-sbin/mesos-slave
-%%DEPLOY%%sbin/mesos-start-agents.sh
-%%DEPLOY%%sbin/mesos-start-cluster.sh
-%%DEPLOY%%sbin/mesos-start-masters.sh
-%%DEPLOY%%sbin/mesos-start-slaves.sh
-%%DEPLOY%%sbin/mesos-stop-agents.sh
-%%DEPLOY%%sbin/mesos-stop-cluster.sh
-%%DEPLOY%%sbin/mesos-stop-masters.sh
-%%DEPLOY%%sbin/mesos-stop-slaves.sh
-%%DATADIR%%/webui/app/agents/agent-browse.html
-%%DATADIR%%/webui/app/agents/agent-executor.html
-%%DATADIR%%/webui/app/agents/agent-framework.html
-%%DATADIR%%/webui/app/agents/agent.html
-%%DATADIR%%/webui/app/agents/agents.html
-%%DATADIR%%/webui/app/app.js
-%%DATADIR%%/webui/app/controllers.js
-%%DATADIR%%/webui/app/frameworks/framework.html
-%%DATADIR%%/webui/app/frameworks/frameworks.html
-%%DATADIR%%/webui/app/frameworks/roles-tree-root.html
-%%DATADIR%%/webui/app/frameworks/roles-tree.html
-%%DATADIR%%/webui/app/frameworks/roles.html
-%%DATADIR%%/webui/app/home.html
-%%DATADIR%%/webui/app/maintenance/maintenance.html
-%%DATADIR%%/webui/app/offers/offers.html
-%%DATADIR%%/webui/app/roles/roles.html
-%%DATADIR%%/webui/app/services.js
-%%DATADIR%%/webui/app/shared/pagination.html
-%%DATADIR%%/webui/app/shared/pailer.html
-%%DATADIR%%/webui/app/shared/table-header.html
-%%DATADIR%%/webui/app/shared/timestamp.html
-%%DATADIR%%/webui/assets/css/bootstrap-3.3.6.min.css
-%%DATADIR%%/webui/assets/css/bootstrap-table-1.11.1.min.css
-%%DATADIR%%/webui/assets/css/mesos.css
-%%DATADIR%%/webui/assets/fonts/glyphicons-halflings-regular.eot
-%%DATADIR%%/webui/assets/fonts/glyphicons-halflings-regular.svg
-%%DATADIR%%/webui/assets/fonts/glyphicons-halflings-regular.ttf
-%%DATADIR%%/webui/assets/fonts/glyphicons-halflings-regular.woff
-%%DATADIR%%/webui/assets/fonts/glyphicons-halflings-regular.woff2
-%%DATADIR%%/webui/assets/ico/favicon.ico
-%%DATADIR%%/webui/assets/img/loading.gif
-%%DATADIR%%/webui/assets/img/mesos-logo.png
-%%DATADIR%%/webui/assets/libs/angular-1.2.32.min.js
-%%DATADIR%%/webui/assets/libs/angular-route-1.2.32.min.js
-%%DATADIR%%/webui/assets/libs/bootstrap-table-1.11.1.min.js
-%%DATADIR%%/webui/assets/libs/clipboard-1.5.16.min.js
-%%DATADIR%%/webui/assets/libs/jquery-3.2.1.min.js
-%%DATADIR%%/webui/assets/libs/jquery.pailer.js
-%%DATADIR%%/webui/assets/libs/relative-date.js
-%%DATADIR%%/webui/assets/libs/ui-bootstrap-tpls-0.9.0.min.js
-%%DATADIR%%/webui/assets/libs/underscore-1.4.3.min.js
-%%DATADIR%%/webui/index.html