aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2024-09-10 21:06:53 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2024-09-10 21:06:53 +0000
commitc67ddb28c68d0f6bc1cd72d976ef7739a79e9089 (patch)
tree24840a1c0bd3efb486e8a226b5be79c2e679e84b
parent8b165065a29c2a26401f0eac1378abc2cfbf7165 (diff)
www/firefox{,-esr} mail/thunderbird: pet CPUTYPE builds
some combinations of custom CPUTYPE and compiler require special linker/compiler flags - try to chase this. PR: 277021 PR: 281404 Submitted by: jkim@ (based on)
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug155921357
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug155921363
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug155921363
6 files changed, 138 insertions, 51 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 7fdc1ecb947d..5ac54a27d523 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -1,6 +1,6 @@
PORTNAME= thunderbird
DISTVERSION= 128.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news net-im wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1559213 b/mail/thunderbird/files/patch-bug1559213
index cfdb9bbefb2b..ead3425fa70b 100644
--- a/mail/thunderbird/files/patch-bug1559213
+++ b/mail/thunderbird/files/patch-bug1559213
@@ -1,11 +1,16 @@
-commit 717bba28411c
-Author: Jory A. Pratt <anarchy@gentoo.org>
-Date: Thu Jun 13 11:53:00 2019 -0700
+commit 25a5572d5cd137aa6d893e09a00bd39908a59a18
+Author: Christoph Moench-Tegeder <cmt@burggraben.net>
+Date: Tue Sep 10 22:23:32 2024 +0200
- Bug 1559213 - Allow to use system av1 libs instead of bundled.
+ based on:
+ commit 717bba28411c
+ Author: Jory A. Pratt <anarchy@gentoo.org>
+ Date: Thu Jun 13 11:53:00 2019 -0700
+
+ Bug 1559213 - Allow to use system av1 libs instead of bundled.
diff --git config/external/moz.build config/external/moz.build
-index b6e174c5d6..49fe67a7ad 100644
+index a24b470396cf..547f5f5c9e04 100644
--- config/external/moz.build
+++ config/external/moz.build
@@ -40,8 +40,9 @@ if not CONFIG["MOZ_SYSTEM_LIBVPX"]:
@@ -21,10 +26,10 @@ index b6e174c5d6..49fe67a7ad 100644
if not CONFIG["MOZ_SYSTEM_PNG"]:
external_dirs += ["media/libpng"]
diff --git dom/media/platforms/moz.build dom/media/platforms/moz.build
-index 1933f8d73a..049ca0f710 100644
+index 61536cc6e225..29cf635bbb44 100644
--- dom/media/platforms/moz.build
+++ dom/media/platforms/moz.build
-@@ -73,6 +73,11 @@ if CONFIG["MOZ_AV1"]:
+@@ -71,6 +71,11 @@ if CONFIG["MOZ_AV1"]:
"agnostic/AOMDecoder.cpp",
"agnostic/DAV1DDecoder.cpp",
]
@@ -37,10 +42,10 @@ index 1933f8d73a..049ca0f710 100644
if CONFIG["MOZ_OMX"]:
EXPORTS += [
diff --git media/ffvpx/libavcodec/moz.build media/ffvpx/libavcodec/moz.build
-index 6f09049a60..2e63568bd1 100644
+index 6f09049a6068..90a82a19a9d1 100644
--- media/ffvpx/libavcodec/moz.build
+++ media/ffvpx/libavcodec/moz.build
-@@ -119,10 +119,14 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
+@@ -119,10 +119,16 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
'vp9recon.c',
'vpx_rac.c',
]
@@ -51,6 +56,8 @@ index 6f09049a60..2e63568bd1 100644
+ if CONFIG["MOZ_SYSTEM_AV1"]:
+ CFLAGS += CONFIG['MOZ_SYSTEM_LIBDAV1D_CFLAGS']
+ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBDAV1D_LIBS']
++ CFLAGS += CONFIG['MOZ_SYSTEM_LIBAOM_CFLAGS']
++ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBAOM_LIBS']
+ else:
+ USE_LIBS += [
+ 'dav1d',
@@ -59,11 +66,37 @@ index 6f09049a60..2e63568bd1 100644
if CONFIG["MOZ_WIDGET_TOOLKIT"] == "gtk":
LOCAL_INCLUDES += ['/media/mozva']
SOURCES += [
+diff --git media/libopus/moz.build media/libopus/moz.build
+index 943aee79ee99..4ad07e3e98af 100644
+--- media/libopus/moz.build
++++ media/libopus/moz.build
+@@ -58,7 +58,7 @@ if not CONFIG["MOZ_SAMPLE_TYPE_FLOAT32"]:
+ DEFINES["FIXED_POINT"] = 1
+ DEFINES["DISABLE_FLOAT_API"] = True
+
+-if CONFIG["OS_ARCH"] == "Linux":
++if CONFIG["OS_ARCH"] in ("FreeBSD", "Linux"):
+ OS_LIBS += [
+ "m",
+ ]
+diff --git media/libvorbis/moz.build media/libvorbis/moz.build
+index cd17d4f89759..816edd72a000 100644
+--- media/libvorbis/moz.build
++++ media/libvorbis/moz.build
+@@ -45,7 +45,7 @@ LOCAL_INCLUDES += ['lib']
+ if CONFIG['OS_ARCH'] == 'SunOS':
+ DEFINES['HAVE_ALLOCA_H'] = True
+
+-if CONFIG["OS_ARCH"] == "Linux":
++if CONFIG["OS_ARCH"] in ("FreeBSD", "Linux"):
+ OS_LIBS += [
+ "m",
+ ]
diff --git toolkit/moz.configure toolkit/moz.configure
-index a424446c7d..1d5babe8a9 100644
+index 1f85d2831f2f..07294b93f850 100644
--- toolkit/moz.configure
+++ toolkit/moz.configure
-@@ -789,7 +789,23 @@ def av1(value):
+@@ -883,7 +883,23 @@ def av1(value):
return True
@@ -88,7 +121,7 @@ index a424446c7d..1d5babe8a9 100644
def dav1d_asm(target):
if target.cpu in ("aarch64", "x86", "x86_64"):
return True
-@@ -805,6 +821,7 @@ set_config("MOZ_DAV1D_ASM", dav1d_asm)
+@@ -899,6 +915,7 @@ set_config("MOZ_DAV1D_ASM", dav1d_asm)
set_define("MOZ_DAV1D_ASM", dav1d_asm)
set_config("MOZ_AV1", av1)
set_define("MOZ_AV1", av1)
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 58ddc5ff2c96..cfbe910aed57 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -1,6 +1,6 @@
PORTNAME= firefox
DISTVERSION= 128.2.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1559213 b/www/firefox-esr/files/patch-bug1559213
index ae11fb38f989..ead3425fa70b 100644
--- a/www/firefox-esr/files/patch-bug1559213
+++ b/www/firefox-esr/files/patch-bug1559213
@@ -1,17 +1,16 @@
-commit 717bba28411c
-Author: Jory A. Pratt <anarchy@gentoo.org>
-Date: Thu Jun 13 11:53:00 2019 -0700
+commit 25a5572d5cd137aa6d893e09a00bd39908a59a18
+Author: Christoph Moench-Tegeder <cmt@burggraben.net>
+Date: Tue Sep 10 22:23:32 2024 +0200
- Bug 1559213 - Allow to use system av1 libs instead of bundled.
----
- config/external/moz.build | 5 +++--
- config/system-headers.mozbuild | 8 ++++++++
- dom/media/platforms/moz.build | 5 +++++
- toolkit/moz.configure | 19 ++++++++++++++++++-
- 4 files changed, 34 insertions(+), 3 deletions(-)
+ based on:
+ commit 717bba28411c
+ Author: Jory A. Pratt <anarchy@gentoo.org>
+ Date: Thu Jun 13 11:53:00 2019 -0700
+
+ Bug 1559213 - Allow to use system av1 libs instead of bundled.
diff --git config/external/moz.build config/external/moz.build
-index 2fc8df57992e..63d18e50a961 100644
+index a24b470396cf..547f5f5c9e04 100644
--- config/external/moz.build
+++ config/external/moz.build
@@ -40,8 +40,9 @@ if not CONFIG["MOZ_SYSTEM_LIBVPX"]:
@@ -27,10 +26,10 @@ index 2fc8df57992e..63d18e50a961 100644
if not CONFIG["MOZ_SYSTEM_PNG"]:
external_dirs += ["media/libpng"]
diff --git dom/media/platforms/moz.build dom/media/platforms/moz.build
-index 5c6e25b3980b..ce99ebfb6d3f 100644
+index 61536cc6e225..29cf635bbb44 100644
--- dom/media/platforms/moz.build
+++ dom/media/platforms/moz.build
-@@ -81,6 +81,11 @@ if CONFIG["MOZ_AV1"]:
+@@ -71,6 +71,11 @@ if CONFIG["MOZ_AV1"]:
"agnostic/AOMDecoder.cpp",
"agnostic/DAV1DDecoder.cpp",
]
@@ -43,10 +42,10 @@ index 5c6e25b3980b..ce99ebfb6d3f 100644
if CONFIG["MOZ_OMX"]:
EXPORTS += [
diff --git media/ffvpx/libavcodec/moz.build media/ffvpx/libavcodec/moz.build
-index 761fc8cf4cd9..793a5b8697a8 100644
+index 6f09049a6068..90a82a19a9d1 100644
--- media/ffvpx/libavcodec/moz.build
+++ media/ffvpx/libavcodec/moz.build
-@@ -120,10 +120,14 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
+@@ -119,10 +119,16 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
'vp9recon.c',
'vpx_rac.c',
]
@@ -57,6 +56,8 @@ index 761fc8cf4cd9..793a5b8697a8 100644
+ if CONFIG["MOZ_SYSTEM_AV1"]:
+ CFLAGS += CONFIG['MOZ_SYSTEM_LIBDAV1D_CFLAGS']
+ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBDAV1D_LIBS']
++ CFLAGS += CONFIG['MOZ_SYSTEM_LIBAOM_CFLAGS']
++ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBAOM_LIBS']
+ else:
+ USE_LIBS += [
+ 'dav1d',
@@ -65,11 +66,37 @@ index 761fc8cf4cd9..793a5b8697a8 100644
if CONFIG["MOZ_WIDGET_TOOLKIT"] == "gtk":
LOCAL_INCLUDES += ['/media/mozva']
SOURCES += [
+diff --git media/libopus/moz.build media/libopus/moz.build
+index 943aee79ee99..4ad07e3e98af 100644
+--- media/libopus/moz.build
++++ media/libopus/moz.build
+@@ -58,7 +58,7 @@ if not CONFIG["MOZ_SAMPLE_TYPE_FLOAT32"]:
+ DEFINES["FIXED_POINT"] = 1
+ DEFINES["DISABLE_FLOAT_API"] = True
+
+-if CONFIG["OS_ARCH"] == "Linux":
++if CONFIG["OS_ARCH"] in ("FreeBSD", "Linux"):
+ OS_LIBS += [
+ "m",
+ ]
+diff --git media/libvorbis/moz.build media/libvorbis/moz.build
+index cd17d4f89759..816edd72a000 100644
+--- media/libvorbis/moz.build
++++ media/libvorbis/moz.build
+@@ -45,7 +45,7 @@ LOCAL_INCLUDES += ['lib']
+ if CONFIG['OS_ARCH'] == 'SunOS':
+ DEFINES['HAVE_ALLOCA_H'] = True
+
+-if CONFIG["OS_ARCH"] == "Linux":
++if CONFIG["OS_ARCH"] in ("FreeBSD", "Linux"):
+ OS_LIBS += [
+ "m",
+ ]
diff --git toolkit/moz.configure toolkit/moz.configure
-index f93a5d64fec8..814357f4e979 100644
+index 1f85d2831f2f..07294b93f850 100644
--- toolkit/moz.configure
+++ toolkit/moz.configure
-@@ -744,7 +744,23 @@ def av1(value):
+@@ -883,7 +883,23 @@ def av1(value):
return True
@@ -94,7 +121,7 @@ index f93a5d64fec8..814357f4e979 100644
def dav1d_asm(target):
if target.cpu in ("aarch64", "x86", "x86_64"):
return True
-@@ -760,6 +776,7 @@ set_config("MOZ_DAV1D_ASM", dav1d_asm)
+@@ -899,6 +915,7 @@ set_config("MOZ_DAV1D_ASM", dav1d_asm)
set_define("MOZ_DAV1D_ASM", dav1d_asm)
set_config("MOZ_AV1", av1)
set_define("MOZ_AV1", av1)
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 0248b91cccd0..45def465f3ea 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= firefox
DISTVERSION= 130.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}${DISTVERSIONSUFFIX}/source \
diff --git a/www/firefox/files/patch-bug1559213 b/www/firefox/files/patch-bug1559213
index ae11fb38f989..ead3425fa70b 100644
--- a/www/firefox/files/patch-bug1559213
+++ b/www/firefox/files/patch-bug1559213
@@ -1,17 +1,16 @@
-commit 717bba28411c
-Author: Jory A. Pratt <anarchy@gentoo.org>
-Date: Thu Jun 13 11:53:00 2019 -0700
+commit 25a5572d5cd137aa6d893e09a00bd39908a59a18
+Author: Christoph Moench-Tegeder <cmt@burggraben.net>
+Date: Tue Sep 10 22:23:32 2024 +0200
- Bug 1559213 - Allow to use system av1 libs instead of bundled.
----
- config/external/moz.build | 5 +++--
- config/system-headers.mozbuild | 8 ++++++++
- dom/media/platforms/moz.build | 5 +++++
- toolkit/moz.configure | 19 ++++++++++++++++++-
- 4 files changed, 34 insertions(+), 3 deletions(-)
+ based on:
+ commit 717bba28411c
+ Author: Jory A. Pratt <anarchy@gentoo.org>
+ Date: Thu Jun 13 11:53:00 2019 -0700
+
+ Bug 1559213 - Allow to use system av1 libs instead of bundled.
diff --git config/external/moz.build config/external/moz.build
-index 2fc8df57992e..63d18e50a961 100644
+index a24b470396cf..547f5f5c9e04 100644
--- config/external/moz.build
+++ config/external/moz.build
@@ -40,8 +40,9 @@ if not CONFIG["MOZ_SYSTEM_LIBVPX"]:
@@ -27,10 +26,10 @@ index 2fc8df57992e..63d18e50a961 100644
if not CONFIG["MOZ_SYSTEM_PNG"]:
external_dirs += ["media/libpng"]
diff --git dom/media/platforms/moz.build dom/media/platforms/moz.build
-index 5c6e25b3980b..ce99ebfb6d3f 100644
+index 61536cc6e225..29cf635bbb44 100644
--- dom/media/platforms/moz.build
+++ dom/media/platforms/moz.build
-@@ -81,6 +81,11 @@ if CONFIG["MOZ_AV1"]:
+@@ -71,6 +71,11 @@ if CONFIG["MOZ_AV1"]:
"agnostic/AOMDecoder.cpp",
"agnostic/DAV1DDecoder.cpp",
]
@@ -43,10 +42,10 @@ index 5c6e25b3980b..ce99ebfb6d3f 100644
if CONFIG["MOZ_OMX"]:
EXPORTS += [
diff --git media/ffvpx/libavcodec/moz.build media/ffvpx/libavcodec/moz.build
-index 761fc8cf4cd9..793a5b8697a8 100644
+index 6f09049a6068..90a82a19a9d1 100644
--- media/ffvpx/libavcodec/moz.build
+++ media/ffvpx/libavcodec/moz.build
-@@ -120,10 +120,14 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
+@@ -119,10 +119,16 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
'vp9recon.c',
'vpx_rac.c',
]
@@ -57,6 +56,8 @@ index 761fc8cf4cd9..793a5b8697a8 100644
+ if CONFIG["MOZ_SYSTEM_AV1"]:
+ CFLAGS += CONFIG['MOZ_SYSTEM_LIBDAV1D_CFLAGS']
+ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBDAV1D_LIBS']
++ CFLAGS += CONFIG['MOZ_SYSTEM_LIBAOM_CFLAGS']
++ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBAOM_LIBS']
+ else:
+ USE_LIBS += [
+ 'dav1d',
@@ -65,11 +66,37 @@ index 761fc8cf4cd9..793a5b8697a8 100644
if CONFIG["MOZ_WIDGET_TOOLKIT"] == "gtk":
LOCAL_INCLUDES += ['/media/mozva']
SOURCES += [
+diff --git media/libopus/moz.build media/libopus/moz.build
+index 943aee79ee99..4ad07e3e98af 100644
+--- media/libopus/moz.build
++++ media/libopus/moz.build
+@@ -58,7 +58,7 @@ if not CONFIG["MOZ_SAMPLE_TYPE_FLOAT32"]:
+ DEFINES["FIXED_POINT"] = 1
+ DEFINES["DISABLE_FLOAT_API"] = True
+
+-if CONFIG["OS_ARCH"] == "Linux":
++if CONFIG["OS_ARCH"] in ("FreeBSD", "Linux"):
+ OS_LIBS += [
+ "m",
+ ]
+diff --git media/libvorbis/moz.build media/libvorbis/moz.build
+index cd17d4f89759..816edd72a000 100644
+--- media/libvorbis/moz.build
++++ media/libvorbis/moz.build
+@@ -45,7 +45,7 @@ LOCAL_INCLUDES += ['lib']
+ if CONFIG['OS_ARCH'] == 'SunOS':
+ DEFINES['HAVE_ALLOCA_H'] = True
+
+-if CONFIG["OS_ARCH"] == "Linux":
++if CONFIG["OS_ARCH"] in ("FreeBSD", "Linux"):
+ OS_LIBS += [
+ "m",
+ ]
diff --git toolkit/moz.configure toolkit/moz.configure
-index f93a5d64fec8..814357f4e979 100644
+index 1f85d2831f2f..07294b93f850 100644
--- toolkit/moz.configure
+++ toolkit/moz.configure
-@@ -744,7 +744,23 @@ def av1(value):
+@@ -883,7 +883,23 @@ def av1(value):
return True
@@ -94,7 +121,7 @@ index f93a5d64fec8..814357f4e979 100644
def dav1d_asm(target):
if target.cpu in ("aarch64", "x86", "x86_64"):
return True
-@@ -760,6 +776,7 @@ set_config("MOZ_DAV1D_ASM", dav1d_asm)
+@@ -899,6 +915,7 @@ set_config("MOZ_DAV1D_ASM", dav1d_asm)
set_define("MOZ_DAV1D_ASM", dav1d_asm)
set_config("MOZ_AV1", av1)
set_define("MOZ_AV1", av1)