aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-09-18 19:12:53 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-09-18 20:24:13 +0000
commitc75e8803b5ff85b592f425bb754860b51b1ac4cc (patch)
tree17085e3a2d7ec9f241502c0cf552fe42a98d3afd
parent12434f9d5dfb6fca8fec491661f3ff2738cd167b (diff)
downloadports-c75e8803b5ff85b592f425bb754860b51b1ac4cc.tar.gz
ports-c75e8803b5ff85b592f425bb754860b51b1ac4cc.zip
ftp/coeurl: fix build with {fmt} 10
- add fmt as a dependency, make it build by pulling in upstream commit 831e2ee8e9cf08ea1ee9736cde8370f9d0312abc PR: 273875 Provided by: diizzy@
-rw-r--r--ftp/coeurl/Makefile8
-rw-r--r--ftp/coeurl/files/patch-lib_client.cpp19
-rw-r--r--net-im/mtxclient/Makefile2
-rw-r--r--net-im/nheko/Makefile2
4 files changed, 25 insertions, 6 deletions
diff --git a/ftp/coeurl/Makefile b/ftp/coeurl/Makefile
index fd2e1535413d..b5e712acc127 100644
--- a/ftp/coeurl/Makefile
+++ b/ftp/coeurl/Makefile
@@ -1,6 +1,7 @@
PORTNAME= coeurl
DISTVERSIONPREFIX=v
DISTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= ftp www
MAINTAINER= adridg@FreeBSD.org
@@ -10,13 +11,12 @@ WWW= https://nheko.im/nheko-reborn/coeurl
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= \
- libcurl.so:ftp/curl \
+LIB_DEPENDS= libcurl.so:ftp/curl \
libevent.so:devel/libevent \
+ libfmt.so:devel/libfmt \
libspdlog.so:devel/spdlog
-USES= compiler:c++17-lang pkgconfig \
- meson tar:xz
+USES= compiler:c++17-lang meson pkgconfig tar:xz
USE_GITLAB= yes
GL_SITE= https://nheko.im/
diff --git a/ftp/coeurl/files/patch-lib_client.cpp b/ftp/coeurl/files/patch-lib_client.cpp
new file mode 100644
index 000000000000..e8e50673879e
--- /dev/null
+++ b/ftp/coeurl/files/patch-lib_client.cpp
@@ -0,0 +1,19 @@
+--- lib/client.cpp.orig 2023-01-10 04:14:36 UTC
++++ lib/client.cpp
+@@ -6,6 +6,7 @@
+ #include <thread>
+
+ #include "coeurl/request.hpp"
++#include "coeurl/errors.hpp"
+
+ namespace coeurl {
+ std::shared_ptr<spdlog::logger> Client::log = spdlog::null_logger_mt("coeurl_null");
+@@ -352,7 +353,7 @@ void Client::remove_request(Request *r) {
+ long http_code;
+ curl_easy_getinfo(req->easy, CURLINFO_RESPONSE_CODE, &http_code);
+
+- Client::log->trace("DONE: {} => {} ({}) http: {}", req->url_, req->curl_error, req->error, http_code);
++ Client::log->trace("DONE: {} => {} ({}) http: {}", req->url_, coeurl::to_string(req->curl_error), req->error, http_code);
+
+ if (req->on_complete_)
+ req->on_complete_(*req.get());
diff --git a/net-im/mtxclient/Makefile b/net-im/mtxclient/Makefile
index a2eb36e99eac..be7acccc0652 100644
--- a/net-im/mtxclient/Makefile
+++ b/net-im/mtxclient/Makefile
@@ -1,7 +1,7 @@
PORTNAME= mtxclient
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index cb6a3aa77690..4d58e2a41715 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
DISTVERSION= 0.11.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org