aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-07 23:37:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-08 02:40:00 +0000
commitc8081216224a32f8826f1d265cfbb5d301d988c7 (patch)
tree9f12b3d5ecac5c3285c8575237bec6d6cc1ba54e
parent019fd7b146aba0e388b8d3c91d8b2166c8c7ceaf (diff)
downloadports-c8081216224a32f8826f1d265cfbb5d301d988c7.tar.gz
ports-c8081216224a32f8826f1d265cfbb5d301d988c7.zip
graphics/py-fury: New port: Free Unified Rendering in Python
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-fury/Makefile32
-rw-r--r--graphics/py-fury/distinfo3
-rw-r--r--graphics/py-fury/pkg-descr2
4 files changed, 38 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b5929dc42f16..6704f771cd94 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -865,6 +865,7 @@
SUBDIR += py-fiona
SUBDIR += py-fotokilof
SUBDIR += py-freeimagepy
+ SUBDIR += py-fury
SUBDIR += py-gdal
SUBDIR += py-geomdl
SUBDIR += py-geopandas
diff --git a/graphics/py-fury/Makefile b/graphics/py-fury/Makefile
new file mode 100644
index 000000000000..500e6871cfd7
--- /dev/null
+++ b/graphics/py-fury/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= fury
+DISTVERSION= 0.9.0
+CATEGORIES= graphics
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Free Unified Rendering in Python
+WWW= https://fury.gl/latest/index.html
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.8.4:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.7.1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=8.0.1:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygltflib>=1.15.1:graphics/py-pygltflib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.4.0:science/py-scipy@${PY_FLAVOR} \
+ vtk${VTK_VER:R}>0:math/vtk${VTK_VER:R}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-vcs>0:devel/py-hatch-vcs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR} \
+ ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python
+USE_PYTHON= pep517 autoplist pytest # tests fail with signal 10, see https://github.com/fury-gl/fury/issues/795
+
+NO_ARCH= yes
+
+.include <../../math/vtk9/Makefile.version>
+.include <bsd.port.mk>
diff --git a/graphics/py-fury/distinfo b/graphics/py-fury/distinfo
new file mode 100644
index 000000000000..29fd7170a700
--- /dev/null
+++ b/graphics/py-fury/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1686173980
+SHA256 (fury-0.9.0.tar.gz) = 8f92cbb94ca04b7ee78047d83decb3735334f9bdff8b5a29bb1152b706cd71a6
+SIZE (fury-0.9.0.tar.gz) = 68194837
diff --git a/graphics/py-fury/pkg-descr b/graphics/py-fury/pkg-descr
new file mode 100644
index 000000000000..28fc5b5dff1b
--- /dev/null
+++ b/graphics/py-fury/pkg-descr
@@ -0,0 +1,2 @@
+FURY is a free and open-source software library for Scientific Visualization
+and 3D animations.