aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-06-05 10:13:10 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-06-05 10:27:00 +0000
commitc82d16a23610a57a13e2cb982fffb26a6e3a44a2 (patch)
treedcb4de8b4ab20fb3b4c1f15b83d41bb2170d2014
parent0ebc2a78cf405f9a92bcc8f0b824fac81981893f (diff)
downloadports-c82d16a23610a57a13e2cb982fffb26a6e3a44a2.tar.gz
ports-c82d16a23610a57a13e2cb982fffb26a6e3a44a2.zip
graphics/py-pytesseract: Bump PORTREVISION, add test
Bump PORTREVISION to pull in py-pillow requisite, missed in 2b87ac22. Add TEST_DEPENDS and do-test for "make test" support (requires py-tox).
-rw-r--r--graphics/py-pytesseract/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/py-pytesseract/Makefile b/graphics/py-pytesseract/Makefile
index df1dc4445bd9..b94c50f882b8 100644
--- a/graphics/py-pytesseract/Makefile
+++ b/graphics/py-pytesseract/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pytesseract
PORTVERSION= 0.3.7
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,13 +11,17 @@ COMMENT= wrapper for Google's Tesseract OCR engine
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= tesseract:graphics/tesseract \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+TEST_DEPENDS= tesseract:graphics/tesseract \
+ ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR}
USES= localbase python:3.4+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} tox
+
.include <bsd.port.mk>