aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-11 11:22:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-11 12:52:28 +0000
commitc8fe7cd180efae46753e602c4e86f302631bcf3b (patch)
tree34211421250afdb275933bc08030eb9dcdfa7d1e
parente671c95c41d9fcb99699206a385f07b212f79282 (diff)
downloadports-c8fe7cd180efae46753e602c4e86f302631bcf3b.tar.gz
ports-c8fe7cd180efae46753e602c4e86f302631bcf3b.zip
devel/fossology-nomos-standalone: update to 3.10.0
-rw-r--r--devel/fossology-nomos-standalone/Makefile5
-rw-r--r--devel/fossology-nomos-standalone/distinfo6
-rw-r--r--devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.c15
-rw-r--r--devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.h18
-rw-r--r--devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__regex.h11
-rw-r--r--devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.c12
-rw-r--r--devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.h13
7 files changed, 73 insertions, 7 deletions
diff --git a/devel/fossology-nomos-standalone/Makefile b/devel/fossology-nomos-standalone/Makefile
index c20471ea9ac3..eab6ce9b2c6e 100644
--- a/devel/fossology-nomos-standalone/Makefile
+++ b/devel/fossology-nomos-standalone/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fossology
-PORTVERSION= 3.9.0
+PORTVERSION= 3.10.0
CATEGORIES= devel
PKGNAMESUFFIX= -nomos-standalone
@@ -9,9 +9,6 @@ COMMENT= Standalone Nomos license scanner from fossology project
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: dbErrString
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: dbErrString
-
BUILD_DEPENDS= gawk:lang/gawk
LIB_DEPENDS= libjson-c.so:devel/json-c
diff --git a/devel/fossology-nomos-standalone/distinfo b/devel/fossology-nomos-standalone/distinfo
index 34ee80cd2578..54ca4dadbb2f 100644
--- a/devel/fossology-nomos-standalone/distinfo
+++ b/devel/fossology-nomos-standalone/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1607467946
-SHA256 (fossology-fossology-3.9.0_GH0.tar.gz) = cecb449e710b3b331fa2a5adf83648da6b94fdd12c97d45677694cb2295d0921
-SIZE (fossology-fossology-3.9.0_GH0.tar.gz) = 20751003
+TIMESTAMP = 1620670653
+SHA256 (fossology-fossology-3.10.0_GH0.tar.gz) = eb56e1c2cf426c817f3039308b9886dfdb3d4060b92e14cd29e5505093f066de
+SIZE (fossology-fossology-3.10.0_GH0.tar.gz) = 20835469
diff --git a/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.c b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.c
new file mode 100644
index 000000000000..5ce6251692e9
--- /dev/null
+++ b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.c
@@ -0,0 +1,15 @@
+--- src/nomos/agent/nomos.c.orig 2021-05-07 09:49:07 UTC
++++ src/nomos/agent/nomos.c
+@@ -33,6 +33,12 @@
+ #include "nomos.h"
+ #include "nomos_utils.h"
+
++char debugStr[myBUFSIZ];
++char dbErrString[myBUFSIZ];
++char saveLics[myBUFSIZ];
++
++size_t hashEntries;
++
+ extern licText_t licText[]; /* Defined in _autodata.c */
+ struct globals gl;
+ struct curScan cur;
diff --git a/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.h b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.h
new file mode 100644
index 000000000000..c7c0564d2b5f
--- /dev/null
+++ b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos.h
@@ -0,0 +1,18 @@
+--- src/nomos/agent/nomos.h.orig 2021-05-07 09:49:07 UTC
++++ src/nomos/agent/nomos.h
+@@ -156,11 +156,11 @@
+ #define OPTS_JSON_OUTPUT 0x20
+ #define OPTS_SCANNING_DIRECTORY 0x40
+
+-char debugStr[myBUFSIZ]; ///< Debug string
+-char dbErrString[myBUFSIZ]; ///< DB error string
+-char saveLics[myBUFSIZ]; ///< License string
++extern char debugStr[myBUFSIZ]; ///< Debug string
++extern char dbErrString[myBUFSIZ]; ///< DB error string
++extern char saveLics[myBUFSIZ]; ///< License string
+
+-size_t hashEntries; ///< Hash entries
++extern size_t hashEntries; ///< Hash entries
+
+ /**
+ Flags for program control
diff --git a/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__regex.h b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__regex.h
new file mode 100644
index 000000000000..37cfd3f8475a
--- /dev/null
+++ b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__regex.h
@@ -0,0 +1,11 @@
+--- src/nomos/agent/nomos_regex.h.orig 2021-05-07 09:49:07 UTC
++++ src/nomos/agent/nomos_regex.h
+@@ -25,8 +25,6 @@
+ #include "util.h"
+ #include "_autodefs.h"
+
+-regex_t regc[NFOOTPRINTS];
+-
+ void regexError(int ret, regex_t *regc, char *regex);
+ int endsIn(char *s, char *suffix);
+ int lineInFile(char *pathname, char *regex);
diff --git a/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.c b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.c
new file mode 100644
index 000000000000..f4928e8dc0df
--- /dev/null
+++ b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.c
@@ -0,0 +1,12 @@
+--- src/nomos/agent/nomos_utils.c.orig 2021-05-07 09:49:07 UTC
++++ src/nomos/agent/nomos_utils.c
+@@ -23,6 +23,9 @@
+ #include "nomos_utils.h"
+ #include "nomos.h"
+
++sem_t* mutexJson; ///< Mutex to handle JSON writes
++gboolean* printcomma; ///< True to print comma while printing JSON object
++
+ #define FUNCTION
+
+ /**
diff --git a/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.h b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.h
new file mode 100644
index 000000000000..593f57533d1f
--- /dev/null
+++ b/devel/fossology-nomos-standalone/files/patch-src_nomos_agent_nomos__utils.h
@@ -0,0 +1,13 @@
+--- src/nomos/agent/nomos_utils.h.orig 2021-05-07 09:49:07 UTC
++++ src/nomos/agent/nomos_utils.h
+@@ -35,8 +35,8 @@
+ #define LICENSE_REF_TABLE "ONLY license_ref"
+ #define SEM_DEFAULT_VALUE 4
+
+-sem_t* mutexJson; ///< Mutex to handle JSON writes
+-gboolean* printcomma; ///< True to print comma while printing JSON object
++extern sem_t* mutexJson; ///< Mutex to handle JSON writes
++extern gboolean* printcomma; ///< True to print comma while printing JSON object
+
+
+ /** shortname cache very simple nonresizing hash table */