aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 16:35:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-27 11:42:14 +0000
commitc93832241d436ee5965175151f85ee21768823a2 (patch)
tree6d7a8b8a136f5ef8ed6de4860438f5a48adea6a4
parent04ffc1149dcfe2812d5c0a511d556325cafda9fa (diff)
downloadports-c93832241d436ee5965175151f85ee21768823a2.tar.gz
ports-c93832241d436ee5965175151f85ee21768823a2.zip
security/py-tuf: switch to USES=pytest, document failing tests
Reported by: reprise Approved by: portmgr blanket
-rw-r--r--security/py-tuf/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/security/py-tuf/Makefile b/security/py-tuf/Makefile
index 57f05f9dafea..a8fdebc1f620 100644
--- a/security/py-tuf/Makefile
+++ b/security/py-tuf/Makefile
@@ -16,14 +16,13 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.19.1:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}securesystemslib>=0.22.0:security/py-securesystemslib@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= python:3.7+
+USES= python:3.7+ pytest
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-do-test:
- @cd ${WRKSRC}/tests && ${PYTHON_CMD} -m pytest -v -rs
+PYTEST_BROKEN_TESTS= test_cleanup \
+ TestRepoExamples # uses files missing from pypi distribution
.include <bsd.port.mk>