aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-14 03:49:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-14 04:41:15 +0000
commitc9fc5eee7aabfb09f3476e00f96b361f277af314 (patch)
treee98e276232a776dc9b236ea63b6696d14d77b539
parent53b98b0ec570c3edfd845aa1a2018acd2d2e49ee (diff)
downloadports-c9fc5eee7aabfb09f3476e00f96b361f277af314.tar.gz
ports-c9fc5eee7aabfb09f3476e00f96b361f277af314.zip
math/clingcon: New port: Extension of clingo to handle constraints over integers
-rw-r--r--math/Makefile1
-rw-r--r--math/clingcon/Makefile24
-rw-r--r--math/clingcon/distinfo3
-rw-r--r--math/clingcon/pkg-descr7
-rw-r--r--math/clingcon/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 35492690f529..addd782bbc3e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -223,6 +223,7 @@
SUBDIR += clblas
SUBDIR += clblast
SUBDIR += clfft
+ SUBDIR += clingcon
SUBDIR += clingo
SUBDIR += cliquer
SUBDIR += cln
diff --git a/math/clingcon/Makefile b/math/clingcon/Makefile
new file mode 100644
index 000000000000..c6b0cd38697d
--- /dev/null
+++ b/math/clingcon/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= clingcon
+DISTVERSIONPREFIX= v
+DISTVERSION= 5.2.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extension of clingo to handle constraints over integers
+WWW= https://potassco.org/clingcon/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libclingo.so:math/clingo
+
+USES= cmake:testing compiler:c++17-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= potassco
+
+CMAKE_OFF= PYCLINGCON_ENABLE
+CMAKE_TESTING_ON= CLINGCON_BUILD_TESTS
+
+.include <bsd.port.mk>
diff --git a/math/clingcon/distinfo b/math/clingcon/distinfo
new file mode 100644
index 000000000000..b107d00ced92
--- /dev/null
+++ b/math/clingcon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1663126357
+SHA256 (potassco-clingcon-v5.2.0_GH0.tar.gz) = 4b568475066e34be34110f481f7028b466c2b008e9ba41686e24ecbb468a40f2
+SIZE (potassco-clingcon-v5.2.0_GH0.tar.gz) = 333420
diff --git a/math/clingcon/pkg-descr b/math/clingcon/pkg-descr
new file mode 100644
index 000000000000..fb4f89b4be7d
--- /dev/null
+++ b/math/clingcon/pkg-descr
@@ -0,0 +1,7 @@
+Clingcon is an answer set solver for constraint logic programs, building upon
+the answer set solver clingo. It extends the high-level modeling language of ASP
+with constraint solving capacities. Constraints over finite domain integer
+variables can be used in logic programs. Clingcon adopts state-of-the-art
+techniques from the area of SMT, like conflict-driven learning and theory
+propagation. It uses lazy nogood and variable generation on the order encoding
+and features several preprocessing techniques.
diff --git a/math/clingcon/pkg-plist b/math/clingcon/pkg-plist
new file mode 100644
index 000000000000..7f9e3667eb41
--- /dev/null
+++ b/math/clingcon/pkg-plist
@@ -0,0 +1,7 @@
+bin/clingcon
+include/clingcon.h
+lib/cmake/Clingcon/ClingconConfig.cmake
+lib/cmake/Clingcon/ClingconConfigVersion.cmake
+lib/cmake/Clingcon/ClingconTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Clingcon/ClingconTargets.cmake
+lib/libclingcon.so