aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-07-13 17:46:54 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-13 20:23:24 +0000
commitca20c3923e519d174cb60b81f28c89d45b9b066d (patch)
tree694865c84247301cd59e100d70f0c4efea8823bb
parent3cd077fcff4b6258ea0460a51a0d8433bef567c5 (diff)
downloadports-ca20c3923e519d174cb60b81f28c89d45b9b066d.tar.gz
ports-ca20c3923e519d174cb60b81f28c89d45b9b066d.zip
security/unix-selfauth-helper: Update to 1.1
Changes: https://github.com/Zirias/unix-selfauth-helper/releases/tag/v1.1 Also remove the post-install script checking for FreeBSD versions with unpatched pam_exec.so. 13.0 and 13.1 were affected, 13.0 is long since EOL, 13.1 will be EOL in a few days and the issue was already fixed in -p1. Approved by: tcberner (mentor, implicit)
-rw-r--r--security/unix-selfauth-helper/Makefile14
-rw-r--r--security/unix-selfauth-helper/distinfo6
-rw-r--r--security/unix-selfauth-helper/pkg-post-install.lua53
3 files changed, 9 insertions, 64 deletions
diff --git a/security/unix-selfauth-helper/Makefile b/security/unix-selfauth-helper/Makefile
index 583fef50e42c..414cb4e19ab5 100644
--- a/security/unix-selfauth-helper/Makefile
+++ b/security/unix-selfauth-helper/Makefile
@@ -1,20 +1,18 @@
PORTNAME= unix-selfauth-helper
-DISTVERSION= 1.0.1
-DISTVERSIONPREFIX= v
+DISTVERSION= 1.1
CATEGORIES= security
+MASTER_SITES= ${WWW}/releases/download/v${DISTVERSION}/
MAINTAINER= zirias@FreeBSD.org
COMMENT= Local self-authentication for pam_exec
-WWW= https://github.com/Zirias/unix-selfauth-helper
+WWW= https://github.com/Zirias/${PORTNAME}
LICENSE= BSD2CLAUSE
-USES= uidfix
+USES= tar:xz
-USE_GITHUB= yes
-GH_ACCOUNT= Zirias
-
-PLIST_FILES= libexec/unix-selfauth-helper \
+PLIST_FILES= etc/pam.d/unix-selfauth \
+ libexec/unix-selfauth-helper \
man/man8/unix-selfauth-helper.8.gz
.include <bsd.port.mk>
diff --git a/security/unix-selfauth-helper/distinfo b/security/unix-selfauth-helper/distinfo
index b87f0b8f8154..66064486906e 100644
--- a/security/unix-selfauth-helper/distinfo
+++ b/security/unix-selfauth-helper/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659607930
-SHA256 (Zirias-unix-selfauth-helper-v1.0.1_GH0.tar.gz) = 24d72c04cc6f42b198378926af0e3d3c0efd7d39e68616482c8b218d4732d261
-SIZE (Zirias-unix-selfauth-helper-v1.0.1_GH0.tar.gz) = 3927
+TIMESTAMP = 1689275552
+SHA256 (unix-selfauth-helper-1.1.tar.xz) = a92c1269c5950425df4eee9cba3d96509807a68ac7973f430f3a7c2538a3ff29
+SIZE (unix-selfauth-helper-1.1.tar.xz) = 3960
diff --git a/security/unix-selfauth-helper/pkg-post-install.lua b/security/unix-selfauth-helper/pkg-post-install.lua
deleted file mode 100644
index 24b211cc0246..000000000000
--- a/security/unix-selfauth-helper/pkg-post-install.lua
+++ /dev/null
@@ -1,53 +0,0 @@
-function getfbsduvers ()
- local osrel = io.open("/etc/os-release")
- if (not osrel) then return nil end
- local reldat = {}
- for line in osrel:lines() do
- local k, v = string.match(line,
- '%s*(.+)%s*=%s*"?%s*([^"]+)%s*"?')
- if (k and v) then reldat[k] = v end
- end
- osrel:close()
- if (not reldat["ID"] or reldat["ID"] ~= "freebsd") then return nil end
- return reldat["VERSION"]
-end
-
-function printwarning (uvers, required)
- local msg=[=[
-======
-Message from $pkg:
-
-!!! ATTENTION !!!
-
-You are currently running FreeBSD $vcurr.
-
-Correct operation of $pkg requires a bugfix that was delivered
-in $vreq.
-
-This package is probably installed as a dependency of some screen locker,
-and without the bugfix, YOU WILL PROBABLY BE UNABLE TO UNLOCK YOUR SCREEN.
-
-Please use freebsd-update(8) to update your system before you continue.
-
-See also:
-<URL:https://security.FreeBSD.org/advisories/FreeBSD-EN-22:19.pam_exec.asc>
-]=]
- local warning = string.gsub(msg, '$(%w+)',
- {pkg = pkg_name, vcurr = uvers, vreq = required})
- pkg.print_msg(warning)
-end
-
-fbsduvers = getfbsduvers()
-if (fbsduvers and string.match(fbsduvers, '-RELEASE')) then
- umaj = tonumber(string.match(fbsduvers, '^[0-9]+'))
- umin = tonumber(string.match(fbsduvers, '%.([0-9]+)-'))
- uplv = tonumber(string.match(fbsduvers, '-p([0-9]+)'))
- if (not uplv) then uplv = 0 end
- if (umaj == 13 and umin <= 1) then
- if (umin == 0 and uplv < 12) then
- printwarning(fbsduvers, "13.0-RELEASE-p12")
- elseif (umin == 1 and uplv < 1) then
- printwarning(fbsduvers, "13.1-RELEASE-p1")
- end
- end
-end