aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-02-15 15:15:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-02-15 15:15:31 +0000
commitca59dd4aa92260864240ee02ae7874c81b88822c (patch)
tree207a5b80b9ab4ac5c3bd4a9947ae63e53919897a
parentc2848657ef8df23f3a5d515b589c2b33558b2ede (diff)
downloadports-ca59dd4aa92260864240ee02ae7874c81b88822c.tar.gz
ports-ca59dd4aa92260864240ee02ae7874c81b88822c.zip
security/py-pass-git-helper: Add new port
A git credential helper interfacing with pass, the standard unix password manager.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pass-git-helper/Makefile28
-rw-r--r--security/py-pass-git-helper/distinfo3
-rw-r--r--security/py-pass-git-helper/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index cc4da23540fd..66fc20840b95 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -947,6 +947,7 @@
SUBDIR += py-ospd-openvas
SUBDIR += py-paramiko
SUBDIR += py-pass-audit
+ SUBDIR += py-pass-git-helper
SUBDIR += py-passlib
SUBDIR += py-pbkdf2
SUBDIR += py-pgpdump
diff --git a/security/py-pass-git-helper/Makefile b/security/py-pass-git-helper/Makefile
new file mode 100644
index 000000000000..c8da993ac808
--- /dev/null
+++ b/security/py-pass-git-helper/Makefile
@@ -0,0 +1,28 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= pass-git-helper
+PORTVERSION= 1.1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Git credential helper interfacing with pass
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= languitar
+USE_PYTHON= autoplist concurrent distutils
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.mk>
diff --git a/security/py-pass-git-helper/distinfo b/security/py-pass-git-helper/distinfo
new file mode 100644
index 000000000000..3c36ca25d896
--- /dev/null
+++ b/security/py-pass-git-helper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1644936873
+SHA256 (languitar-pass-git-helper-v1.1.2_GH0.tar.gz) = 4acfb486d0873014376383167792ee2b46926386718eb2331a1b4564576a2076
+SIZE (languitar-pass-git-helper-v1.1.2_GH0.tar.gz) = 99760
diff --git a/security/py-pass-git-helper/pkg-descr b/security/py-pass-git-helper/pkg-descr
new file mode 100644
index 000000000000..d044abfaadf0
--- /dev/null
+++ b/security/py-pass-git-helper/pkg-descr
@@ -0,0 +1,4 @@
+A git credential helper interfacing with pass, the standard unix
+password manager.
+
+WWW: https://github.com/languitar/pass-git-helper