aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 18:43:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 18:43:17 +0000
commitca5f4a251d020b4e37255ef1ada583fc19c847b8 (patch)
treedb8c590fc93152a7d8b7fd3ad7080a00518c0a09
parent2151ed96d6e52dc628288d2bd848cbee5bf162bd (diff)
downloadports-ca5f4a251d020b4e37255ef1ada583fc19c847b8.tar.gz
ports-ca5f4a251d020b4e37255ef1ada583fc19c847b8.zip
devel/rubygem-google-apis-admin_directory_v1: Add rubygem-google-apis-admin_directory_v1 0.53.0
This is a simple client library for version V1 of the Admin SDK API. It provides: - A client object that connects to the HTTP/JSON REST endpoint for the service. - Ruby objects for data structures related to the service. - Integration with the googleauth gem for authentication using OAuth, API keys, and service accounts. - Control of retry, pagination, and timeouts.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-admin_directory_v1/Makefile20
-rw-r--r--devel/rubygem-google-apis-admin_directory_v1/distinfo3
-rw-r--r--devel/rubygem-google-apis-admin_directory_v1/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 76a1341ffad8..66e0f08a91c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7005,6 +7005,7 @@
SUBDIR += rubygem-glib2
SUBDIR += rubygem-gobject-introspection
SUBDIR += rubygem-google-api-client
+ SUBDIR += rubygem-google-apis-admin_directory_v1
SUBDIR += rubygem-google-apis-androidpublisher_v3
SUBDIR += rubygem-google-apis-androidpublisher_v3034
SUBDIR += rubygem-google-apis-bigquery_v2
diff --git a/devel/rubygem-google-apis-admin_directory_v1/Makefile b/devel/rubygem-google-apis-admin_directory_v1/Makefile
new file mode 100644
index 000000000000..1a8899785292
--- /dev/null
+++ b/devel/rubygem-google-apis-admin_directory_v1/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= google-apis-admin_directory_v1
+PORTVERSION= 0.53.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Admin SDK API V1
+WWW= https://github.com/googleapis/google-api-ruby-client/tree/main/generated/google-apis-admin_directory_v1 \
+ https://github.com/googleapis/google-api-ruby-client
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.14.0<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-admin_directory_v1/distinfo b/devel/rubygem-google-apis-admin_directory_v1/distinfo
new file mode 100644
index 000000000000..e265b6e319e5
--- /dev/null
+++ b/devel/rubygem-google-apis-admin_directory_v1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711860461
+SHA256 (rubygem/google-apis-admin_directory_v1-0.53.0.gem) = 22d05a550825e146a3c324466d1532117d144a1eca3b99be317521f018442b13
+SIZE (rubygem/google-apis-admin_directory_v1-0.53.0.gem) = 71168
diff --git a/devel/rubygem-google-apis-admin_directory_v1/pkg-descr b/devel/rubygem-google-apis-admin_directory_v1/pkg-descr
new file mode 100644
index 000000000000..bd4fa4afd9b6
--- /dev/null
+++ b/devel/rubygem-google-apis-admin_directory_v1/pkg-descr
@@ -0,0 +1,7 @@
+This is a simple client library for version V1 of the Admin SDK API. It
+provides:
+- A client object that connects to the HTTP/JSON REST endpoint for the service.
+- Ruby objects for data structures related to the service.
+- Integration with the googleauth gem for authentication using OAuth, API keys,
+ and service accounts.
+- Control of retry, pagination, and timeouts.