aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-06 16:50:04 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-06 17:47:38 +0000
commitca88d76e3423aa77ee9b10e093d2fc1efe472e67 (patch)
tree3176676e081ff878ba5abb2cca45483f9000e20e
parent8104a81e1dd691335ba9f59a8cd5392f757349d9 (diff)
downloadports-ca88d76e3423aa77ee9b10e093d2fc1efe472e67.tar.gz
ports-ca88d76e3423aa77ee9b10e093d2fc1efe472e67.zip
security/palisade: Fix build with llvm15
Approved by: portmgr (blanket)
-rw-r--r--security/palisade/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/palisade/Makefile b/security/palisade/Makefile
index 80b7ad07804a..bf72e4726979 100644
--- a/security/palisade/Makefile
+++ b/security/palisade/Makefile
@@ -48,4 +48,10 @@ OPENMP_CMAKE_BOOL= WITH_OPENMP
HEXL_CMAKE_BOOL= WITH_HEXL
HEXL_LIB_DEPENDS= libhexl.so:security/hexl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CXXFLAGS+= -Wno-error=unused-but-set-variable
+.endif
+
+.include <bsd.port.post.mk>