aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2025-01-13 12:07:41 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2025-01-17 12:45:34 +0000
commitcaacd6f039f43a7b0514b2107a81c51a8b33b3b1 (patch)
treebe6d5b60de2c579a8b78554232cf6778e690a718
parent4b8ab93c8222b4691f08af9c336b19d6f011c83d (diff)
audio/beets: chase kubo -> kubo-go rename
This time, actually fix the command invocations in the source code. Approved by: portmgr (build fix blanket) MFH: 2025Q1 (cherry picked from commit 32245e7007b4d7c039e83faa6834aa2787d51c7a)
-rw-r--r--audio/beets/Makefile3
-rw-r--r--audio/beets/files/patch-beetsplug_ipfs.py44
2 files changed, 46 insertions, 1 deletions
diff --git a/audio/beets/Makefile b/audio/beets/Makefile
index 8d78563be058..81b61145fcbe 100644
--- a/audio/beets/Makefile
+++ b/audio/beets/Makefile
@@ -1,5 +1,6 @@
PORTNAME= beets
DISTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= PYPI
@@ -70,7 +71,7 @@ EMBYUPDATE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_
FETCHART_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
FFMPEG_RUN_DEPENDS= ffmpeg>=2:multimedia/ffmpeg
IMAGEMAGICK_USES= magick:run
-IPFS_RUN_DEPENDS= kubo:sysutils/kubo-go
+IPFS_RUN_DEPENDS= kubo-go:sysutils/kubo-go
KODIUPDATE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
LASTFM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pylast>=0:audio/py-pylast@${PY_FLAVOR}
LASTIMPORT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
diff --git a/audio/beets/files/patch-beetsplug_ipfs.py b/audio/beets/files/patch-beetsplug_ipfs.py
new file mode 100644
index 000000000000..a97325cf3417
--- /dev/null
+++ b/audio/beets/files/patch-beetsplug_ipfs.py
@@ -0,0 +1,44 @@
+--- beetsplug/ipfs.py.orig 2025-01-13 12:04:44 UTC
++++ beetsplug/ipfs.py
+@@ -134,9 +134,9 @@ class IPFSPlugin(BeetsPlugin):
+ self._log.info("Adding {0} to ipfs", album_dir)
+
+ if self.config["nocopy"]:
+- cmd = "ipfs add --nocopy -q -r".split()
++ cmd = "kubo-go add --nocopy -q -r".split()
+ else:
+- cmd = "ipfs add -q -r".split()
++ cmd = "kubo-go add -q -r".split()
+ cmd.append(album_dir)
+ try:
+ output = util.command_output(cmd).stdout.split()
+@@ -178,7 +178,7 @@ class IPFSPlugin(BeetsPlugin):
+
+ def ipfs_get_from_hash(self, lib, _hash):
+ try:
+- cmd = "ipfs get".split()
++ cmd = "kubo-go get".split()
+ cmd.append(_hash)
+ util.command_output(cmd)
+ except (OSError, subprocess.CalledProcessError) as err:
+@@ -202,9 +202,9 @@ class IPFSPlugin(BeetsPlugin):
+ self.ipfs_added_albums(lib, tmp.name)
+ try:
+ if self.config["nocopy"]:
+- cmd = "ipfs add --nocopy -q ".split()
++ cmd = "kubo-go add --nocopy -q ".split()
+ else:
+- cmd = "ipfs add -q ".split()
++ cmd = "kubo-go add -q ".split()
+ cmd.append(tmp.name)
+ output = util.command_output(cmd).stdout
+ except (OSError, subprocess.CalledProcessError) as err:
+@@ -230,7 +230,7 @@ class IPFSPlugin(BeetsPlugin):
+ return False
+ path = os.path.join(remote_libs, lib_name.encode() + b".db")
+ if not os.path.exists(path):
+- cmd = f"ipfs get {_hash} -o".split()
++ cmd = f"kubo-go get {_hash} -o".split()
+ cmd.append(path)
+ try:
+ util.command_output(cmd)