aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-08-04 06:12:42 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-08-05 05:32:31 +0000
commitcabd9376521555cf8026b5416c5f033ebbd3d7b1 (patch)
treeb236fd87e3489f7ce2a7ab35a065802c22897bfe
parent079567cc48874444ea2cad0b91b00040e7a1ddc9 (diff)
downloadports-cabd9376521555cf8026b5416c5f033ebbd3d7b1.tar.gz
ports-cabd9376521555cf8026b5416c5f033ebbd3d7b1.zip
databases/mysql-udf: always add -fPIC
This fixes build for armv6 and armv7 PR: 265565 Reported by: fuz@fuz.su (maintainer) MFH: 2022Q3 (build fixes)
-rw-r--r--databases/mysql-udf/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/databases/mysql-udf/Makefile b/databases/mysql-udf/Makefile
index ba0f6c013d7a..57f4130684c1 100644
--- a/databases/mysql-udf/Makefile
+++ b/databases/mysql-udf/Makefile
@@ -10,13 +10,7 @@ COMMENT= Set of user-defined functions for the MySQL server
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= mysql
-CFLAGS_aarch64= -fPIC
-CFLAGS_amd64= -fPIC
-CFLAGS_i386= -fPIC
-CFLAGS_powerpc= -fPIC
-CFLAGS_powerpc64= -fPIC
-CFLAGS_powerpc64le= -fPIC
-CFLAGS_riscv64= -fPIC
+CFLAGS+= -fPIC
MODULES= colwidth confidence_higher confidence_lower correlation \
faculty geomean intercept kurtosis longest median noverm \