aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2022-08-31 20:30:12 +0000
committerLarry Rosenman <ler@FreeBSD.org>2022-08-31 20:37:29 +0000
commitcaf16d259243263f7c995825ae46781209e5218b (patch)
tree4bb1ef0ad32340a155be94cfdbd5518fd8cd5a29
parent4dc53e36820cea95b70722dae4abfac08aca8281 (diff)
downloadports-caf16d259243263f7c995825ae46781209e5218b.tar.gz
ports-caf16d259243263f7c995825ae46781209e5218b.zip
security/1password-client2-beta: [NEW PORT]
Make the beta version of the CLI available in FreeBSD ports. latest changelog: https://app-updates.agilebits.com/product_history/CLI2#v2070101 NOTE: you may need to check the "show betas" checkbox on that link.
-rw-r--r--security/1password-client2-beta/Makefile42
-rw-r--r--security/1password-client2-beta/distinfo9
-rw-r--r--security/1password-client2-beta/pkg-descr6
-rw-r--r--security/1password-client2/Makefile2
-rw-r--r--security/Makefile1
5 files changed, 59 insertions, 1 deletions
diff --git a/security/1password-client2-beta/Makefile b/security/1password-client2-beta/Makefile
new file mode 100644
index 000000000000..cca82f0b3780
--- /dev/null
+++ b/security/1password-client2-beta/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= 1password-client2-beta
+DISTVERSION= 2.7.1-beta.01
+CATEGORIES= security
+MASTER_SITES= https://cache.agilebits.com/dist/1P/op2/pkg/v${DISTVERSION}/
+
+MAINTAINER= ler@FreeBSD.org
+COMMENT= 1Password CLI client (BETA)
+
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
+
+USES= zip
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/op
+CONFLICTS_INSTALL= security/1password-client security/op security/1password-client2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/op \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+DISTNAME= op_freebsd_amd64_v${DISTVERSION}
+.elif ${ARCH} == armv6 || ${ARCH} == armv7
+DISTNAME= op_freebsd_arm_v${DISTVERSION}
+.elif ${ARCH} == aarch64
+DISTNAME= op_freebsd_arm64_v${DISTVERSION}
+.elif ${ARCH} == i386
+DISTNAME= op_freebsd_386_v${DISTVERSION}
+.endif
+
+.if ${.TARGETS} == "makesum"
+DISTFILES= op_freebsd_386_v${DISTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_amd64_v${DISTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_arm64_v${DISTVERSION}${EXTRACT_SUFX} \
+ op_freebsd_arm_v${DISTVERSION}${EXTRACT_SUFX}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/1password-client2-beta/distinfo b/security/1password-client2-beta/distinfo
new file mode 100644
index 000000000000..f515a52d93a4
--- /dev/null
+++ b/security/1password-client2-beta/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1661975474
+SHA256 (op_freebsd_386_v2.7.1-beta.01.zip) = 3875135b3c1023b726e6b2c6ae04ab390436f809d8f5108f0bcb443cd5090414
+SIZE (op_freebsd_386_v2.7.1-beta.01.zip) = 4376635
+SHA256 (op_freebsd_amd64_v2.7.1-beta.01.zip) = 43f9240c1c4d8fd77f093ba4dc095df9eb6f83a48c8236ac29c4f352a287005e
+SIZE (op_freebsd_amd64_v2.7.1-beta.01.zip) = 4809271
+SHA256 (op_freebsd_arm64_v2.7.1-beta.01.zip) = 3edb7454a4b523510f7bee0acc6fbc1a700c06cd71040e7f8e2e4a23956d351b
+SIZE (op_freebsd_arm64_v2.7.1-beta.01.zip) = 4360449
+SHA256 (op_freebsd_arm_v2.7.1-beta.01.zip) = ba5cd5df00b931750b5ce5a8fb9a72efc31c6e291d4658eb59ab49d297d95bcc
+SIZE (op_freebsd_arm_v2.7.1-beta.01.zip) = 4360412
diff --git a/security/1password-client2-beta/pkg-descr b/security/1password-client2-beta/pkg-descr
new file mode 100644
index 000000000000..a13b416af0ec
--- /dev/null
+++ b/security/1password-client2-beta/pkg-descr
@@ -0,0 +1,6 @@
+This is a command-line interface to the 1Password password management
+service. (BETA)
+
+This is the release of the CLI Version 2 (BETA).
+
+WWW: https://developer.1password.com/docs/cli/upgrade
diff --git a/security/1password-client2/Makefile b/security/1password-client2/Makefile
index 94995bf055d0..b0fb237db96a 100644
--- a/security/1password-client2/Makefile
+++ b/security/1password-client2/Makefile
@@ -14,7 +14,7 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/op
-CONFLICTS_INSTALL= security/1password-client security/op
+CONFLICTS_INSTALL= security/1password-client security/op security/1password-client2-beta
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/op \
diff --git a/security/Makefile b/security/Makefile
index c98246ee5b83..e536f5926a1b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -3,6 +3,7 @@
SUBDIR += 0d1n
SUBDIR += 1password-client
SUBDIR += 1password-client2
+ SUBDIR += 1password-client2-beta
SUBDIR += 2fa
SUBDIR += ADMsmb
SUBDIR += ADMsnmp