aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 09:34:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 12:46:15 +0000
commitcb33235b5dc2e8370752196c79441c193a53e833 (patch)
treead1124ca20c6148164f50c69f272f1dedfa4ee82
parent061707677a4c6e26b83046e925e8fa37e8e4f09b (diff)
downloadports-cb33235b5dc2e8370752196c79441c193a53e833.tar.gz
ports-cb33235b5dc2e8370752196c79441c193a53e833.zip
devel/py-libusb1: Update to 2.0.1
-rw-r--r--devel/py-libusb1/Makefile4
-rw-r--r--devel/py-libusb1/distinfo6
-rw-r--r--devel/py-libusb1/files/patch-usb1_____init____.py4
3 files changed, 8 insertions, 6 deletions
diff --git a/devel/py-libusb1/Makefile b/devel/py-libusb1/Makefile
index cc662187915e..18f959980e08 100644
--- a/devel/py-libusb1/Makefile
+++ b/devel/py-libusb1/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libusb1
-PORTVERSION?= 1.9.3
+PORTVERSION= 2.0.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -9,6 +9,8 @@ COMMENT= Pure-python wrapper for libusb-1.0
LICENSE= LGPL21+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyinstaller>=0:devel/py-pyinstaller@${PY_FLAVOR}
+
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/devel/py-libusb1/distinfo b/devel/py-libusb1/distinfo
index 625a11e6d887..dd367209993a 100644
--- a/devel/py-libusb1/distinfo
+++ b/devel/py-libusb1/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1625323581
-SHA256 (libusb1-1.9.3.tar.gz) = 60e6ce37be064f6e51d02b25da44230ecc9c0b1fdb6f14568c71457d963c1749
-SIZE (libusb1-1.9.3.tar.gz) = 81296
+TIMESTAMP = 1643971066
+SHA256 (libusb1-2.0.1.tar.gz) = d3ba82ecf7ab6a48d21dac6697e26504670cc3522b8e5941bd28fb56cf3f6c46
+SIZE (libusb1-2.0.1.tar.gz) = 82619
diff --git a/devel/py-libusb1/files/patch-usb1_____init____.py b/devel/py-libusb1/files/patch-usb1_____init____.py
index ba2bb144a328..bd827541152e 100644
--- a/devel/py-libusb1/files/patch-usb1_____init____.py
+++ b/devel/py-libusb1/files/patch-usb1_____init____.py
@@ -1,8 +1,8 @@
https://lists.freebsd.org/pipermail/freebsd-usb/2015-January/013586.html
---- usb1/__init__.py.orig 2021-07-02 12:59:01 UTC
+--- usb1/__init__.py.orig 2021-09-24 22:30:54 UTC
+++ usb1/__init__.py
-@@ -1864,8 +1864,10 @@ class USBDevice(object):
+@@ -1885,8 +1885,10 @@ class USBDevice:
Get the port number of each hub toward device.
"""
port_list = (c_uint8 * PATH_MAX_DEPTH)()