aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-06-03 15:29:22 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-06-03 15:29:22 +0000
commitcb4dde7e1f4bc930ee4faea4c575ed59eb6d8a6a (patch)
treea0a775e87d29beae9d539b2eb1d0e2405e99b05f
parent0932acb439f08739f7498b8de8267e32075c6ab7 (diff)
editors/mousepad: Add spelling support
- Add new SPELL option enabled by default to compile in spelling support - Remove unneeded dependency on xfconf - Also add missing INSTALLS_ICONS PR: 256303
-rw-r--r--editors/mousepad/Makefile18
-rw-r--r--editors/mousepad/pkg-plist1
2 files changed, 15 insertions, 4 deletions
diff --git a/editors/mousepad/Makefile b/editors/mousepad/Makefile
index a54fc99e3148..610c7c8409ec 100644
--- a/editors/mousepad/Makefile
+++ b/editors/mousepad/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mousepad
PORTVERSION= 0.5.5
+PORTREVISION= 1
CATEGORIES= editors xfce
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
@@ -12,22 +13,31 @@ COMMENT= Simple text editor for the Xfce Desktop
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
+
USES= desktop-file-utils gettext-tools gmake gnome libtool perl5 \
pkgconfig tar:bzip2 xfce
-USE_GNOME= cairo dconf gdkpixbuf2 glib20 gtk30 gtksourceview3 intlhack \
- intltool
-USE_XFCE= xfconf
+USE_GNOME= cairo dconf gdkpixbuf2 glib20 gtk30 gtksourceview3 intltool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.xfce.mousepad.gschema.xml
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS SPELL
+OPTIONS_DEFAULT= SPELL
OPTIONS_SUB= yes
+SPELL_DESC= Spell checking plugin
+
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
+SPELL_CONFIGURE_ENABLE= plugin-gspell
+SPELL_LIB_DEPENDS= libgspell-1.so:textproc/gspell \
+ libenchant-2.so:textproc/enchant2
+SPELL_VARS= GLIB_SCHEMAS+=org.xfce.mousepad.plugins.gspell.gschema.xml
+
.include <bsd.port.mk>
diff --git a/editors/mousepad/pkg-plist b/editors/mousepad/pkg-plist
index 0c2a92d3b181..bc953b801ad1 100644
--- a/editors/mousepad/pkg-plist
+++ b/editors/mousepad/pkg-plist
@@ -2,6 +2,7 @@ bin/mousepad
lib/libmousepad.so
lib/libmousepad.so.0
lib/libmousepad.so.0.0.0
+%%SPELL%%lib/mousepad/plugins/libmousepad-plugin-gspell.so
share/applications/mousepad-settings.desktop
share/applications/mousepad.desktop
share/icons/hicolor/128x128/apps/org.xfce.mousepad.png