aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-12 03:57:16 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-12 03:57:18 +0000
commitcb6dc5bf2186c496c10d715102af457276d80662 (patch)
treed9373f7531f1e6b2a79bcc384e7fcea3f74e6b6c
parent8c130154d24cd33a90aa5004734ef722f76c6949 (diff)
downloadports-cb6dc5bf2186c496c10d715102af457276d80662.tar.gz
ports-cb6dc5bf2186c496c10d715102af457276d80662.zip
misc/sfm: port of a simple file manager for Unix-like systems.
-rw-r--r--misc/Makefile1
-rw-r--r--misc/sfm/Makefile19
-rw-r--r--misc/sfm/distinfo3
-rw-r--r--misc/sfm/files/patch-config.mk16
-rw-r--r--misc/sfm/pkg-descr10
5 files changed, 49 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 4ea94a1ef975..75406a3b6b1a 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -460,6 +460,7 @@
SUBDIR += seabios
SUBDIR += sent
SUBDIR += seq2
+ SUBDIR += sfm
SUBDIR += shared-mime-info
SUBDIR += shc
SUBDIR += shuffle
diff --git a/misc/sfm/Makefile b/misc/sfm/Makefile
new file mode 100644
index 000000000000..a34f1e01e226
--- /dev/null
+++ b/misc/sfm/Makefile
@@ -0,0 +1,19 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= sfm
+PORTVERSION= 0.4
+DISTVERSIONPREFIX= v
+CATEGORIES= misc
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Simple file manager for Unix-like systems
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= afify
+
+PLIST_FILES= bin/sfm share/man/man1/sfm.1.gz
+
+.include <bsd.port.mk>
diff --git a/misc/sfm/distinfo b/misc/sfm/distinfo
new file mode 100644
index 000000000000..edb899480ec9
--- /dev/null
+++ b/misc/sfm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1636121495
+SHA256 (afify-sfm-v0.4_GH0.tar.gz) = c0fe7f36a4050256b68c6e6c5cb3b7065527c6a8f6a1b0ca020814a7d511c652
+SIZE (afify-sfm-v0.4_GH0.tar.gz) = 29483
diff --git a/misc/sfm/files/patch-config.mk b/misc/sfm/files/patch-config.mk
new file mode 100644
index 000000000000..e7f32ba430c0
--- /dev/null
+++ b/misc/sfm/files/patch-config.mk
@@ -0,0 +1,16 @@
+--- config.mk.orig 2021-11-05 14:11:35 UTC
++++ config.mk
+@@ -6,9 +6,9 @@ PREFIX = /usr/local
+ MANPREFIX = ${PREFIX}/share/man
+
+ # flags
+-CPPFLAGS = -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -DVERSION=\"${VERSION}\"
+-CFLAGS = -std=c99 -pedantic -Wextra -Wall -Wno-unused-parameter -Os ${CPPFLAGS}
+-LDFLAGS = -pthread -s
++CPPFLAGS += -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -DVERSION=\"${VERSION}\"
++CFLAGS += -pedantic -Wextra -Wall -Wno-unused-parameter ${CPPFLAGS}
++LDFLAGS += -pthread
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
diff --git a/misc/sfm/pkg-descr b/misc/sfm/pkg-descr
new file mode 100644
index 000000000000..a73a76e2eaad
--- /dev/null
+++ b/misc/sfm/pkg-descr
@@ -0,0 +1,10 @@
+sfm is a simple file manager for Unix-like systems. It features:
+
+ - pthread(3) to read events, no timers
+ - BSD kqueue(2) notification mechanism
+ - dual panel, bottom statusbar
+ - open files by extension
+ - bookmarks, filters
+ - vim-like key bindings
+
+WWW: https://git.afify.dev/sfm/