aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-20 15:55:32 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-20 15:59:26 +0000
commitcbf3be9c1eea2ea37873e00a456a1022b56e9265 (patch)
treef553c57512d65b2a6f06e302b08f9cfd29b0ff19
parentd2bcea7923017e575db20c991bf742cc0abc177e (diff)
*/*tex*: Fix USES=tex in some ports
During my previous commits I missed some ports which were using lowercase USE_tex which were not searched during my commits on more than 100 ports. I am still unsure how those ports were working as there was no option for lowercase tex in the previous bsd.tex.mk. Reported by: zirias
-rw-r--r--deskutils/nextcloudclient/Makefile3
-rw-r--r--editors/sly/Makefile3
-rw-r--r--graphics/atril/Makefile3
-rw-r--r--print/xreader/Makefile3
-rw-r--r--textproc/linuxdoc-tools/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/deskutils/nextcloudclient/Makefile b/deskutils/nextcloudclient/Makefile
index 753b9408a5e5..c94464de0ee9 100644
--- a/deskutils/nextcloudclient/Makefile
+++ b/deskutils/nextcloudclient/Makefile
@@ -40,7 +40,8 @@ WEBENGINE_DESC= QT5 Webengine support
#DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
# doxygen:devel/doxygen
-#DOCS_USE= tex=dvipsk:build,latex:build
+#DOCS_USES= tex
+#DOCS_USE= TEX=dvipsk:build,latex:build
#DOCS_CMAKE_ON= -DWITH_DOC:BOOL=ON
WEBENGINE_VARS= USE_QT+=webengine
diff --git a/editors/sly/Makefile b/editors/sly/Makefile
index f0b49f641f1c..575854764bd6 100644
--- a/editors/sly/Makefile
+++ b/editors/sly/Makefile
@@ -36,7 +36,8 @@ GENERATED_DOCS_FILES= sly.html
DOCS_BUILD_DEPENDS= texinfo>=5.2:print/texinfo
DOCS_PDF_IMPLIES= DOCS
-DOCS_PDF_USE= tex=latex:build tex=pdftex:build tex=dvipsk:build
+DOCS_PDF_USES= tex
+DOCS_PDF_USE= TEX=latex:build,pdftex:build,dvipsk:build
.include <bsd.port.options.mk>
diff --git a/graphics/atril/Makefile b/graphics/atril/Makefile
index f4c61fa563ca..da7dba3bdf20 100644
--- a/graphics/atril/Makefile
+++ b/graphics/atril/Makefile
@@ -83,7 +83,8 @@ EPUB_CONFIGURE_ENABLE= epub
EPUB_LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3
DVI_DESC= DVI viewer support
-DVI_USE= tex=base
+DVI_USES= tex
+DVI_USE= TEX=base
DVI_CONFIGURE_ENABLE= dvi
T1LIB_DESC= T1LIB for TYPE1 fonts to DVI (Enables DVI)
diff --git a/print/xreader/Makefile b/print/xreader/Makefile
index 3e290f4923f5..0ff5974831c5 100644
--- a/print/xreader/Makefile
+++ b/print/xreader/Makefile
@@ -44,7 +44,8 @@ DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
DJVU_MESON_ON= -Ddjvu=true
DVI_LIB_DEPENDS= libspectre.so:print/libspectre
-DVI_USE= tex=kpathsea
+DVI_USES= tex
+DVI_USE= TEX=kpathsea
DVI_MESON_ON= -Ddvi=true
EPUB_BUILD_DEPENDS= ${MATHJAX_DIR}/MathJax.js:www/mathjax
diff --git a/textproc/linuxdoc-tools/Makefile b/textproc/linuxdoc-tools/Makefile
index e7ebcaa69d75..8f6ec6451242 100644
--- a/textproc/linuxdoc-tools/Makefile
+++ b/textproc/linuxdoc-tools/Makefile
@@ -31,7 +31,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= bash:shells/bash
-DOCS_USE= tex=latex:build tex=pdftex:build tex=dvipsk:build
+DOCS_USES= tex
+DOCS_USE= TEX=latex:build,pdftex:build,dvipsk:build
DOCS_USES= makeinfo
DOCS_CONFIGURE_ENABLE= docs