aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-03-25 22:27:33 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-03-25 22:27:33 +0000
commitcc080452290a4220c3c1af274a792b1d9c9bfe8a (patch)
tree7b25605a4b84e05a71a5d9160f26123f5e7326b3
parentc56a7b2e00d1d5a829d02a07fe3f191fe089e75d (diff)
downloadports-cc080452290a4220c3c1af274a792b1d9c9bfe8a.tar.gz
ports-cc080452290a4220c3c1af274a792b1d9c9bfe8a.zip
graphics/kf5-kimageformats: add LIBHEIF option to enable heic support
-rw-r--r--graphics/kf5-kimageformats/Makefile6
-rw-r--r--graphics/kf5-kimageformats/pkg-plist4
2 files changed, 8 insertions, 2 deletions
diff --git a/graphics/kf5-kimageformats/Makefile b/graphics/kf5-kimageformats/Makefile
index 068c8728ea7f..01d15301af28 100644
--- a/graphics/kf5-kimageformats/Makefile
+++ b/graphics/kf5-kimageformats/Makefile
@@ -15,7 +15,7 @@ USE_QT= core gui printsupport widgets \
CFLAGS+= -I${LOCALBASE}/include/Imath
-OPTIONS_DEFINE= AVIF JXL OPENEXR
+OPTIONS_DEFINE= AVIF JXL LIBHEIF OPENEXR
OPTIONS_DEFAULT= AVIF JXL OPENEXR
OPTIONS_SUB= yes
@@ -25,6 +25,10 @@ AVIF_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_libavif
JXL_LIB_DEPENDS= libjxl.so:graphics/libjxl
JXL_CMAKE_BOOL= KIMAGEFORMATS_JXL
+LIBHEIF_DESC= ISO/IEC 23008-12:2017 HEIF file format support
+LIBHEIF_LIB_DEPENDS= libheif.so:graphics/libheif
+LIBHEIF_CMAKE_BOOL= KIMAGEFORMATS_HEIF
+
OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
diff --git a/graphics/kf5-kimageformats/pkg-plist b/graphics/kf5-kimageformats/pkg-plist
index 7157ef47f2e9..f0134abb4bd3 100644
--- a/graphics/kf5-kimageformats/pkg-plist
+++ b/graphics/kf5-kimageformats/pkg-plist
@@ -1,7 +1,9 @@
+%%QT_PLUGINDIR%%/imageformats/kimg_ani.so
%%AVIF%%%%QT_PLUGINDIR%%/imageformats/kimg_avif.so
%%QT_PLUGINDIR%%/imageformats/kimg_eps.so
%%OPENEXR%%%%QT_PLUGINDIR%%/imageformats/kimg_exr.so
%%QT_PLUGINDIR%%/imageformats/kimg_hdr.so
+%%LIBHEIF%%%%QT_PLUGINDIR%%/imageformats/kimg_heif.so
%%JXL%%%%QT_PLUGINDIR%%/imageformats/kimg_jxl.so
%%QT_PLUGINDIR%%/imageformats/kimg_kra.so
%%QT_PLUGINDIR%%/imageformats/kimg_ora.so
@@ -12,13 +14,13 @@
%%QT_PLUGINDIR%%/imageformats/kimg_rgb.so
%%QT_PLUGINDIR%%/imageformats/kimg_tga.so
%%QT_PLUGINDIR%%/imageformats/kimg_xcf.so
-%%QT_PLUGINDIR%%/imageformats/kimg_ani.so
share/kservices5/qimageioplugins/ani.desktop
%%AVIF%%share/kservices5/qimageioplugins/avif.desktop
share/kservices5/qimageioplugins/dds.desktop
share/kservices5/qimageioplugins/eps.desktop
%%OPENEXR%%share/kservices5/qimageioplugins/exr.desktop
share/kservices5/qimageioplugins/hdr.desktop
+%%LIBHEIF%%share/kservices5/qimageioplugins/heif.desktop
share/kservices5/qimageioplugins/jp2.desktop
%%JXL%%share/kservices5/qimageioplugins/jxl.desktop
share/kservices5/qimageioplugins/kra.desktop