aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2024-07-31 08:12:28 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2024-07-31 08:12:29 +0000
commitcc181346de3f0e0477ef3e9a4dd6f002db5892c3 (patch)
tree65b3454d44cb3179be7d11d5c765ba74d0c14188
parentc54ecc25f108da5e574e944938c19b078b0a11c7 (diff)
emulators/wine-devel: Leverage USES=llvm
This allows simplifying BUILD_DEPENDS, use of variables, and the overall structure, plus it's aligned with emulators/wine now.
-rw-r--r--emulators/wine-devel/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index d9360095156d..133e24030133 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -15,9 +15,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 i386
-BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex llvm${_LLVM_VERSION}>=0:devel/llvm${_LLVM_VERSION}
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
-USES= bison cpe desktop-file-utils gmake localbase \
+# Only devel/llvm17 and later come with necessary include files - PR274542
+USES= bison cpe desktop-file-utils gmake \
+ llvm:17,build,noexport localbase \
pkgconfig sdl shebangfix tar:xz
USE_GCC= yes
USE_SDL= sdl2
@@ -61,8 +63,8 @@ USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
SHEBANG_FILES= tools/make_requests tools/winemaker/winemaker \
tools/winedump/function_grep.pl
-BINARY_ALIAS+= clang=${LOCALBASE}/bin/clang${_LLVM_VERSION} \
- lld-link=${LOCALBASE}/bin/lld-link${_LLVM_VERSION}
+BINARY_ALIAS+= clang=${LOCALBASE}/bin/clang${LLVM_VERSION} \
+ lld-link=${LOCALBASE}/bin/lld-link${LLVM_VERSION}
SUB_FILES= pkg-message
@@ -124,11 +126,6 @@ CONFIGURE_ARGS+= --without-gstreamer
PLIST_SUB+= GSTREAMER="@comment "
.endif
-# Only devel/llvm17 and later come with necessary include files - PR274542
-.if ${LLVM_DEFAULT} < 17
-_LLVM_VERSION= 17
-.endif
-
.if ${ARCH} == amd64
# Wine is composed of three parts:
# - wine (aka this port on FreeBSD/i386) is the 32-bit component