aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2021-12-22 15:56:48 +0000
committerLewis Cook <lcook@FreeBSD.org>2021-12-22 16:00:35 +0000
commitcc6aef99d65a5cae3a48e007fa3036368938a153 (patch)
treee4a2cdfe25200b82a26e2ab3b28040d1a0e6bca3
parent1a2547c365a71b6b91179f3ff7f655fd700b97a4 (diff)
downloadports-cc6aef99d65a5cae3a48e007fa3036368938a153.tar.gz
ports-cc6aef99d65a5cae3a48e007fa3036368938a153.zip
sysutils/zrepl: Include build version in command output
While here, only include gmake as a dependency when building the documentation. PR: 260608 Reported by: Lapo Luchini <lapo@lapo.it>
-rw-r--r--sysutils/zrepl/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/sysutils/zrepl/Makefile b/sysutils/zrepl/Makefile
index 23b3cc16c683..21b7cae06377 100644
--- a/sysutils/zrepl/Makefile
+++ b/sysutils/zrepl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zrepl
DISTVERSIONPREFIX= v
DISTVERSION= 0.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MAINTAINER= lcook@FreeBSD.org
@@ -12,10 +12,13 @@ COMMENT= ZFS dataset replication tool
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake go:modules
+USES= go:modules
USE_RC_SUBR= zrepl
GO_MODULE= github.com/${PORTNAME}/${PORTNAME}
+GO_BUILDFLAGS= -ldflags "\
+ -s -w\
+ -X ${GO_MODULE}/version.${PORTNAME}Version=${DISTVERSION}"
SUB_FILES= pkg-message
@@ -23,7 +26,7 @@ OPTIONS_DEFINE= EXAMPLES MANPAGES
OPTIONS_DEFAULT= MANPAGES
MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.8.5,1:textproc/py-sphinx@${PY_FLAVOR}
-MANPAGES_USES= python:build,3.6+
+MANPAGES_USES= gmake python:build,3.6+
MANPAGES_PLIST_FILES= man/man1/zrepl.1.gz
.include <bsd.port.options.mk>