aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2024-03-23 17:35:13 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2024-03-23 17:45:45 +0000
commitcc9c37d73947e0184f66f0b5fa3fc021f7fdf51c (patch)
tree2ed9aec08f80e9e35c12fb35579110add2960c9f
parent0dc10f1983eebb0cd4f1b10ea079e8e0fbdaab5f (diff)
downloadports-cc9c37d73947e0184f66f0b5fa3fc021f7fdf51c.tar.gz
ports-cc9c37d73947e0184f66f0b5fa3fc021f7fdf51c.zip
*/*: Always use WRK_ENV with SETENVI
WRK_ENV contains environment variables like OSVERSION and UNAME_* that are needed when cross-building packages using Poudriere for a different version of FreeBSD or a different architecture than that of the host system.
-rw-r--r--devel/libpci/Makefile2
-rw-r--r--devel/redo/Makefile2
-rw-r--r--devel/tinycbor/Makefile2
-rw-r--r--science/cdo/Makefile2
-rw-r--r--textproc/translate-toolkit/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 358d235ce21d..8cc09e70074a 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -36,7 +36,7 @@ post-patch:
@${LN} -s . ${WRKSRC}/lib/pci
do-configure:
- @cd ${WRKSRC}/ && ${SETENVI} ${MAKE_ENV} ${MAKE_CMD} lib/config.h
+ @cd ${WRKSRC}/ && ${SETENVI} ${WRK_ENV} ${MAKE_ENV} ${MAKE_CMD} lib/config.h
post-build:
@cd ${WRKSRC}/lib/ && ${CC} ${CFLAGS} ${STRIP} -Wl,-soname=libpci.so.3 -shared *.o -lz -o libpci.so.3
diff --git a/devel/redo/Makefile b/devel/redo/Makefile
index 2877292d46d6..f3ea4f5efb25 100644
--- a/devel/redo/Makefile
+++ b/devel/redo/Makefile
@@ -30,7 +30,7 @@ do-configure:
@${ECHO_CMD} '${LDFLAGS}' > ${WRKSRC}/build/ldflags
do-build:
- @cd ${WRKSRC} && ${SETENVI} ${MAKE_ENV} ./package/make
+ @cd ${WRKSRC} && ${SETENVI} ${WRK_ENV} ${MAKE_ENV} ./package/make
do-install:
cd ${WRKSRC} && ./package/makeinstall
diff --git a/devel/tinycbor/Makefile b/devel/tinycbor/Makefile
index 2ebd07ac91d3..6319f1472ee5 100644
--- a/devel/tinycbor/Makefile
+++ b/devel/tinycbor/Makefile
@@ -23,7 +23,7 @@ GH_ACCOUNT= intel
USE_GITHUB= yes
do-configure:
- @cd ${WRKSRC}/ && ${SETENVI} ${MAKE_ENV} ${MAKE_CMD} configure
+ @cd ${WRKSRC}/ && ${SETENVI} ${WRK_ENV} ${MAKE_ENV} ${MAKE_CMD} configure
post-install:
${LN} -fs libtinycbor.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libtinycbor.so
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index ba3f6d3865b1..3e0140edccfc 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -70,6 +70,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/libcdi/src/cdi.inc ${STAGEDIR}${PREFIX}/include/cdi.inc
test-NETCDF-on:
- @cd ${WRKSRC}/ && ${SETENVI} CDO_PATH=src/cdo src/cdotest
+ @cd ${WRKSRC}/ && ${SETENVI} ${WRK_ENV} CDO_PATH=src/cdo src/cdotest
.include <bsd.port.mk>
diff --git a/textproc/translate-toolkit/Makefile b/textproc/translate-toolkit/Makefile
index f185e96effec..1398b9b34dca 100644
--- a/textproc/translate-toolkit/Makefile
+++ b/textproc/translate-toolkit/Makefile
@@ -77,7 +77,7 @@ YAML_VARS= MANPAGES+="po2yaml yaml2po"
post-build:
@${MKDIR} ${WRKSRC}/manpages
.for manpage in ${MANPAGES}
- cd ${WRKSRC}/build/lib/translate/convert && ${SETENVI} PYTHONPATH=${WRKSRC}/build/lib ${PYTHON_CMD} ${manpage}.py --man > ${WRKSRC}/manpages/${manpage}.1
+ cd ${WRKSRC}/build/lib/translate/convert && ${SETENVI} ${WRK_ENV} PYTHONPATH=${WRKSRC}/build/lib ${PYTHON_CMD} ${manpage}.py --man > ${WRKSRC}/manpages/${manpage}.1
.endfor
post-install: