aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:28:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:59:52 +0000
commitccc0b6055dbd8b78f21c93d46d2e7319c32bd609 (patch)
tree9267cf3d677bd9f66006cb897a66fc87f1c5af34
parente1e2a9c0d6ba0e65af55e0a5793d0d4f24f14941 (diff)
downloadports-ccc0b6055dbd8b78f21c93d46d2e7319c32bd609.tar.gz
ports-ccc0b6055dbd8b78f21c93d46d2e7319c32bd609.zip
graphics/p5-ming: Replace configure.in patch with upstream one
-rw-r--r--graphics/p5-ming/Makefile2
-rw-r--r--graphics/p5-ming/files/patch-configure.in73
2 files changed, 65 insertions, 10 deletions
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 4163403a6b47..05626d377a20 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -38,8 +38,6 @@ SHEBANG_FILES= perl_ext/examples/*.cgi
OPTIONS_DEFINE= EXAMPLES
-BINARY_ALIAS= freetype-config=true
-
post-patch:
@${REINPLACE_CMD} -e '/ming_is_compiled()/ s|^|#|; /LIBS/d' ${WRKSRC}/perl_ext/Makefile.PL
@${REINPLACE_CMD} -e 's|\.3pm|.3|g' ${WRKSRC}/perl_ext/Makefile.PL ${WRKSRC}/perl_ext/mkdoc
diff --git a/graphics/p5-ming/files/patch-configure.in b/graphics/p5-ming/files/patch-configure.in
index 0c3332359d41..1b79fe266905 100644
--- a/graphics/p5-ming/files/patch-configure.in
+++ b/graphics/p5-ming/files/patch-configure.in
@@ -1,13 +1,70 @@
---- configure.in.orig 2021-08-10 14:43:41 UTC
+Obtained from: https://github.com/libming/libming/commit/a89a619e187ebe070db2a1760f3b90489bfff382
+
+--- configure.in.orig 2017-04-07 08:12:56 UTC
+++ configure.in
-@@ -272,8 +272,8 @@ if test "$freetype_support" = "yes"; then
- ft_config="$freetype_config"
- fi
+@@ -247,7 +247,7 @@ AC_CHECK_LIB(X11, XGetImage, XLIB="-lX11", XLIB="")
+ AC_ARG_ENABLE(
+ [freetype],
+-[ --enable-freetype Enable freetype support (default: enabled)],
++[ --disable-freetype Disable freetype support (default: enabled)],
+ [case "${enableval}" in
+ yes) freetype_support=yes ;;
+ no) freetype_support=no ;;
+@@ -257,26 +257,10 @@ freetype_support=yes)
+
+ if test "$freetype_support" = "yes"; then
+ dnl Check for the freetype library
+- AC_ARG_WITH(freetype-config, [ --with-freetype-config=PROG Use FreeType configuration program PROG], freetype_config=$withval, freetype_config=yes)
+- if test "$freetype_config" = "yes"; then
+- AC_PATH_PROG(ft_config,freetype-config,no)
+- if test "$ft_config" = "no"; then
+- echo "To compile ming please install freetype:"
+- echo " as .deb user: sudo apt-get install libfreetype6 libfreetype6-dev"
+- echo ""
+- echo "or disable the freetype configuration option:"
+- echo " --disable-freetype"
+- AC_MSG_ERROR([Could not detect freetype-config!])
+- fi
+- else
+- ft_config="$freetype_config"
+- fi
+-
- FREETYPE_CFLAGS="`$ft_config --cflags`"
- FREETYPE_LIBS="`$ft_config --libs`"
-+ FREETYPE_CFLAGS="`pkg-config freetype2 --cflags`"
-+ FREETYPE_LIBS="`pkg-config freetype2 --libs`"
+-
+- AC_SUBST(FREETYPE_LIBS)
+- AC_SUBST(FREETYPE_CFLAGS)
++ PKG_PROG_PKG_CONFIG
++ PKG_CHECK_MODULES(FREETYPE, freetype2, HAS_FREETYPE=true,
++ AC_MSG_ERROR([Could not find freetype])
++ )
+ fi
+
+ dnl Check for the ungif or gif (new or old) libraries
+@@ -334,9 +318,9 @@ if test -n "${ZLIB}" -a -n "${ZLIB_INC}"; then
+ AC_DEFINE([USE_ZLIB], [1], [Use zlib])
+ fi
+
+-AM_CONDITIONAL(USE_FREETYPE, test x${ft_config} != x)
+-if test -n "${ft_config}"; then
+- AC_DEFINE(USE_FREETYPE, [1], [Use freetype library])
++AM_CONDITIONAL(USE_FREETYPE, test x${HAS_FREETYPE} != x)
++if test x${HAS_FREETYPE} = xtrue ; then
++ AC_DEFINE(USE_FREETYPE, [1], [Use freetype library])
+ fi
+
+ AM_CONDITIONAL(GIFLIB_GIFERRORSTRING, test x"$ac_cv_lib_gif_GifErrorString" = xyes)
+@@ -504,10 +488,10 @@ else
+ echo " ZLIB enabled ($ZLIB)"
+ fi
+
+-if test x"$ft_config" = "x"; then
++if test x"$HAS_FREETYPE" = "x"; then
+ echo " Freetype library disabled"
+ else
+- echo " Freetype library enabled ($ft_config)"
++ echo " Freetype library enabled ($FREETYPE_LIBS)"
+ fi
- AC_SUBST(FREETYPE_LIBS)
- AC_SUBST(FREETYPE_CFLAGS)
+ if test x"$GIFLIB" = "x" -o x"$GIFINC" = "x"; then