aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@ninth-nine.com>2022-06-09 22:13:51 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-06-09 22:13:51 +0000
commitcdc4f394015b90c1aa11d7a9dc725e4ce0414616 (patch)
tree9bad4ce8fa76c364421369cbec5101c09b8800e9
parentc86f32d652eb9dd023049122d8ca37cb13ed07b6 (diff)
downloadports-cdc4f394015b90c1aa11d7a9dc725e4ce0414616.tar.gz
ports-cdc4f394015b90c1aa11d7a9dc725e4ce0414616.zip
devel/py-jschema-to-python: New Port: Generate Python classes from a JSON schema
Add a new port, py-jschema-to-python is to generate Python classes from a JSON schema. - Author becomes maintainer PR: 264362
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jschema-to-python/Makefile24
-rw-r--r--devel/py-jschema-to-python/distinfo3
-rw-r--r--devel/py-jschema-to-python/files/patch-setup.cfg16
-rw-r--r--devel/py-jschema-to-python/pkg-descr3
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7ee4ec629366..ac54995c4dba 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4712,6 +4712,7 @@
SUBDIR += py-jmespath
SUBDIR += py-joblib
SUBDIR += py-jsbeautifier
+ SUBDIR += py-jschema-to-python
SUBDIR += py-jsmin
SUBDIR += py-json5
SUBDIR += py-json_tricks
diff --git a/devel/py-jschema-to-python/Makefile b/devel/py-jschema-to-python/Makefile
new file mode 100644
index 000000000000..401bf0ba9166
--- /dev/null
+++ b/devel/py-jschema-to-python/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= jschema-to-python
+DISTVERSION= 1.2.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= jschema_to_python-${DISTVERSION}
+
+MAINTAINER= nork@ninth-nine.com
+COMMENT= Generate Python classes from a JSON schema
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>0:devel/py-pbr@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonpickle>0:devel/py-jsonpickle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pbr>0:devel/py-pbr@${PY_FLAVOR}
+
+USES= dos2unix python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jschema-to-python/distinfo b/devel/py-jschema-to-python/distinfo
new file mode 100644
index 000000000000..7a1dfc551f9c
--- /dev/null
+++ b/devel/py-jschema-to-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1654780129
+SHA256 (jschema_to_python-1.2.3.tar.gz) = 76ff14fe5d304708ccad1284e4b11f96a658949a31ee7faed9e0995279549b91
+SIZE (jschema_to_python-1.2.3.tar.gz) = 10061
diff --git a/devel/py-jschema-to-python/files/patch-setup.cfg b/devel/py-jschema-to-python/files/patch-setup.cfg
new file mode 100644
index 000000000000..148d0943aa72
--- /dev/null
+++ b/devel/py-jschema-to-python/files/patch-setup.cfg
@@ -0,0 +1,16 @@
+--- setup.cfg.orig 2022-06-09 13:30:24 UTC
++++ setup.cfg
+@@ -1,10 +1,10 @@ author = Microsoft Corporation
+ [metadata]
+ name = jschema_to_python
+ author = Microsoft Corporation
+-author-email = v-lgold@microsoft.com
++author_email = v-lgold@microsoft.com
+ summary = Generate source code for Python classes from a JSON schema.
+-home-page = https://github.com/microsoft/jschema-to-python
+-description-file = README.rst
++home_page = https://github.com/microsoft/jschema-to-python
++description_file = README.rst
+ license = MIT
+ classifier =
+ Development Status :: 5 - Production/Stable
diff --git a/devel/py-jschema-to-python/pkg-descr b/devel/py-jschema-to-python/pkg-descr
new file mode 100644
index 000000000000..321174c95af2
--- /dev/null
+++ b/devel/py-jschema-to-python/pkg-descr
@@ -0,0 +1,3 @@
+Generate Python classes from a JSON schema.
+
+WWW: https://pypi.org/project/jschema-to-python/