aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-22 01:00:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-22 01:04:31 +0000
commitce3a02091dceed0036d56dfddead58232c04465c (patch)
treebbc61bdfcecbbf25c42b0a37be3dd7b7d3499699
parent1dde2b2d5f5243751409256d2fd7ab975bbea5ac (diff)
math/py-pynauty: New port: Isomorphism testing and automorphisms of graphs
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pynauty/Makefile24
-rw-r--r--math/py-pynauty/distinfo3
-rw-r--r--math/py-pynauty/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 14eae18d0e39..b1509694da06 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -873,6 +873,7 @@
SUBDIR += py-pyhull
SUBDIR += py-pyipopt
SUBDIR += py-pymc3
+ SUBDIR += py-pynauty
SUBDIR += py-pyneqsys
SUBDIR += py-pynleq2
SUBDIR += py-pynndescent
diff --git a/math/py-pynauty/Makefile b/math/py-pynauty/Makefile
new file mode 100644
index 000000000000..d67dff7e6e9b
--- /dev/null
+++ b/math/py-pynauty/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= pynauty
+DISTVERSION= 1.0.2
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Isomorphism testing and automorphisms of graphs
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= gmake:devel/gmake
+
+USES= python:3.6+ shebangfix
+USE_PYTHON= distutils autoplist
+
+SHEBANG_FILES= src/pynauty/tests/test_minimal.py
+
+BINARY_ALIAS= make=${GMAKE} python3=${PYTHON_CMD}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pynauty/nautywrap*.so
+
+.include <bsd.port.mk>
diff --git a/math/py-pynauty/distinfo b/math/py-pynauty/distinfo
new file mode 100644
index 000000000000..fd7f06b8dc6d
--- /dev/null
+++ b/math/py-pynauty/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1629593014
+SHA256 (pynauty-1.0.2.tar.gz) = 771c6254fd89760ed5ad057676fbe59d9abb898352652e9774a0d43dd6c50096
+SIZE (pynauty-1.0.2.tar.gz) = 1862748
diff --git a/math/py-pynauty/pkg-descr b/math/py-pynauty/pkg-descr
new file mode 100644
index 000000000000..5ad7b7a70959
--- /dev/null
+++ b/math/py-pynauty/pkg-descr
@@ -0,0 +1,6 @@
+Pynauty can be used to compare graphs for isomorphism and to determine their
+automorphism group in a Python programming environment. Pynauty is a Python/C
+extension module using library components from the Nauty package by Brendan
+McKay.
+
+WWW: https://github.com/pdobsan/pynauty