aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2022-07-17 11:55:28 +0000
committerKai Knoblich <kai@FreeBSD.org>2022-07-17 12:04:30 +0000
commitce547df4b991787d0b6b064bead52044db5a1299 (patch)
tree92dfdda191a4ce11ba52138e24d32937ddf96fbe
parent28fe4b3f414d8124bf1753ce9f895146b5823576 (diff)
net-mgmt/py-netutils: New port
This Python library contains a collection of objects for common network automation tasks. It intends to keep the following tenets: * Must not be any dependencies required to run the library. * May be some optional dependencies, to be managed by the user in opt in fashion. * Shall prefer functions over classes. * Shall prefer a folder and file structure that is flat. * Shall leverage docstrings as the primary documentation mechanism. * Must provide examples in every public function. * Shall retain a high test coverage. WWW: https://github.com/networktocode/netutils
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-netutils/Makefile18
-rw-r--r--net-mgmt/py-netutils/distinfo3
-rw-r--r--net-mgmt/py-netutils/pkg-descr15
4 files changed, 37 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index da7b3315c31b..9640aa6ac1b3 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -312,6 +312,7 @@
SUBDIR += py-napalm-logs
SUBDIR += py-ncclient
SUBDIR += py-netbox-plugin-extensions
+ SUBDIR += py-netutils
SUBDIR += py-nxapi-plumbing
SUBDIR += py-opn-cli
SUBDIR += py-pdagent
diff --git a/net-mgmt/py-netutils/Makefile b/net-mgmt/py-netutils/Makefile
new file mode 100644
index 000000000000..8afaeec6ac71
--- /dev/null
+++ b/net-mgmt/py-netutils/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= netutils
+DISTVERSION= 1.1.0
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Common helper functions useful in network automation
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-netutils/distinfo b/net-mgmt/py-netutils/distinfo
new file mode 100644
index 000000000000..13ec58b9672d
--- /dev/null
+++ b/net-mgmt/py-netutils/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1658048014
+SHA256 (netutils-1.1.0.tar.gz) = 90ab637c60ae18c515191224c52a7b0a1eb6fdde2f8dd40dfac638f2dd06ef2c
+SIZE (netutils-1.1.0.tar.gz) = 104415
diff --git a/net-mgmt/py-netutils/pkg-descr b/net-mgmt/py-netutils/pkg-descr
new file mode 100644
index 000000000000..f05e6e4f32c1
--- /dev/null
+++ b/net-mgmt/py-netutils/pkg-descr
@@ -0,0 +1,15 @@
+This Python library contains a collection of objects for common network
+automation tasks.
+
+It intends to keep the following tenets:
+
+* Must not be any dependencies required to run the library.
+* May be some optional dependencies, to be managed by the user
+ in opt in fashion.
+* Shall prefer functions over classes.
+* Shall prefer a folder and file structure that is flat.
+* Shall leverage docstrings as the primary documentation mechanism.
+* Must provide examples in every public function.
+* Shall retain a high test coverage.
+
+WWW: https://github.com/networktocode/netutils