aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-29 08:35:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-29 16:51:20 +0000
commitcf1a4afe005b78b343de532c9baad1c3c5f15e37 (patch)
treec9d57378f4845f3879d6f62bd1bf8e32d048ba28
parent0522565b99851ce70195983da0b96edc9a9a793d (diff)
www/py-kiss-headers: New port: Parser and serializer for http headers
-rw-r--r--www/Makefile1
-rw-r--r--www/py-kiss-headers/Makefile19
-rw-r--r--www/py-kiss-headers/distinfo3
-rw-r--r--www/py-kiss-headers/pkg-descr15
4 files changed, 38 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index dd69efd4b9c4..3e18db5fc2e2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1688,6 +1688,7 @@
SUBDIR += py-internetarchive
SUBDIR += py-jonpy
SUBDIR += py-jsonfield
+ SUBDIR += py-kiss-headers
SUBDIR += py-lektor
SUBDIR += py-lesscpy
SUBDIR += py-libsass
diff --git a/www/py-kiss-headers/Makefile b/www/py-kiss-headers/Makefile
new file mode 100644
index 000000000000..61e183f107fe
--- /dev/null
+++ b/www/py-kiss-headers/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= kiss-headers
+DISTVERSION= 2.3.1
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Parser and serializer for http headers
+WWW= https://ousret.github.io/kiss-headers/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-kiss-headers/distinfo b/www/py-kiss-headers/distinfo
new file mode 100644
index 000000000000..9c68427fd19a
--- /dev/null
+++ b/www/py-kiss-headers/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674980639
+SHA256 (kiss-headers-2.3.1.tar.gz) = 86e80d58da2af71fdb7c3adfe57544442fd0595928a95f6e8a9d490aa6ea29aa
+SIZE (kiss-headers-2.3.1.tar.gz) = 77846
diff --git a/www/py-kiss-headers/pkg-descr b/www/py-kiss-headers/pkg-descr
new file mode 100644
index 000000000000..cac706de6c65
--- /dev/null
+++ b/www/py-kiss-headers/pkg-descr
@@ -0,0 +1,15 @@
+kiss-headers is a basic library, small and concise to help get things done
+regarding headers in a better way.
+
+Features:
+* A backwards-compatible syntax using bracket style.
+* Capability to alter headers using simple, human-readable operator
+ notation + and -.
+* Flexibility if headers are from an email or HTTP, use as you need with one
+ library.
+* Ability to parse any object and extract recognized headers from it, it also
+ supports UTF-8 encoded headers.
+* Fully type-annotated.
+* Provide great auto-completion in Python interpreter or any capable IDE.
+* No dependencies. And never will be.
+* 90% test coverage.