aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-06-07 08:24:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-06-07 08:24:41 +0000
commitcf516e48cd82c1b452fe3c5d410211c627b766b4 (patch)
treef0ff3c225af0044e414b438ca8a9ca97d87943e2
parenta38f7cb647f2a1572fb1f7d9d8428d55497b89df (diff)
downloadports-cf516e48cd82c1b452fe3c5d410211c627b766b4.tar.gz
ports-cf516e48cd82c1b452fe3c5d410211c627b766b4.zip
archivers/bzip3: add new port
A better, faster and stronger spiritual successor to BZip2. Features higher compression ratios and better performance thanks to a order-0 context mixing entropy coder, a fast Burrows-Wheeler transform code making use of suffix arrays and a RLE with Lempel Ziv+Prediction pass based on LZ77-style string matching and PPM-style context modeling.
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/bzip3/Makefile17
-rw-r--r--archivers/bzip3/distinfo3
-rw-r--r--archivers/bzip3/pkg-descr5
-rw-r--r--archivers/bzip3/pkg-plist20
5 files changed, 46 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index b1e5e7ccef0c..f94187aeed97 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -15,6 +15,7 @@
SUBDIR += brotli
SUBDIR += bzip
SUBDIR += bzip2
+ SUBDIR += bzip3
SUBDIR += c-blosc
SUBDIR += c-blosc2
SUBDIR += cabextract
diff --git a/archivers/bzip3/Makefile b/archivers/bzip3/Makefile
new file mode 100644
index 000000000000..7e2850dbf875
--- /dev/null
+++ b/archivers/bzip3/Makefile
@@ -0,0 +1,17 @@
+PORTNAME= bzip3
+PORTVERSION= 1.3.1
+CATEGORIES= archivers
+MASTER_SITES= https://github.com/kspalaiologos/${PORTNAME}/releases/download/${PORTVERSION}/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Better and stronger spiritual successor to BZip2
+WWW= https://github.com/kspalaiologos/bzip3
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= libtool pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/bzip3/distinfo b/archivers/bzip3/distinfo
new file mode 100644
index 000000000000..1cb284898e20
--- /dev/null
+++ b/archivers/bzip3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1686125591
+SHA256 (bzip3-1.3.1.tar.gz) = 0361b72da62d2f2e24456be568b9e2a58b5bd0e9fd23f92d9173d1b2e3b4c3d8
+SIZE (bzip3-1.3.1.tar.gz) = 406543
diff --git a/archivers/bzip3/pkg-descr b/archivers/bzip3/pkg-descr
new file mode 100644
index 000000000000..0819865311b1
--- /dev/null
+++ b/archivers/bzip3/pkg-descr
@@ -0,0 +1,5 @@
+A better, faster and stronger spiritual successor to BZip2. Features
+higher compression ratios and better performance thanks to a order-0
+context mixing entropy coder, a fast Burrows-Wheeler transform code
+making use of suffix arrays and a RLE with Lempel Ziv+Prediction pass
+based on LZ77-style string matching and PPM-style context modeling.
diff --git a/archivers/bzip3/pkg-plist b/archivers/bzip3/pkg-plist
new file mode 100644
index 000000000000..3093dd6d4904
--- /dev/null
+++ b/archivers/bzip3/pkg-plist
@@ -0,0 +1,20 @@
+bin/bunzip3
+bin/bz3cat
+bin/bz3grep
+bin/bz3less
+bin/bz3more
+bin/bz3most
+bin/bzip3
+include/libbz3.h
+lib/libbzip3.a
+lib/libbzip3.so
+lib/libbzip3.so.0
+lib/libbzip3.so.0.0.0
+libdata/pkgconfig/bzip3.pc
+man/man1/bunzip3.1.gz
+man/man1/bz3cat.1.gz
+man/man1/bz3grep.1.gz
+man/man1/bz3less.1.gz
+man/man1/bz3more.1.gz
+man/man1/bz3most.1.gz
+man/man1/bzip3.1.gz