aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-05-30 18:21:00 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-05-30 19:02:17 +0000
commitcf58ecc3a65aaf905c0b07af1544ddb19b5af10b (patch)
tree409ad463e7f1e0c61d7618f7c9e4f7db6f34e81e
parentc90fbcb06ad58ab0adcb0924c08b0e3dd33d230c (diff)
downloadports-cf58ecc3a65aaf905c0b07af1544ddb19b5af10b.tar.gz
ports-cf58ecc3a65aaf905c0b07af1544ddb19b5af10b.zip
graphics/opencolorio: fix build on i386 with CPUTYPE older than pentium4
Fixing build errors such as: /wrkdirs/usr/ports/graphics/opencolorio/work/OpenColorIO-2.3.2/src/OpenColorIO/ops/cdl/CDLOpCPU.cpp:339:18: error: always_inline function '_mm_loadu_ps' requires target feature 'sse', but would be inlined into function 'LoadRenderParams' that is compiled without support for 'sse' slope = _mm_loadu_ps(renderParams.getSlope()); But it build fine with CPUTYPE=pentium4 or newer. Default on i386 is CPUTYPE=i486. Upstream reworked SIMD detection and usage in commit: https://github.com/AcademySoftwareFoundation/OpenColorIO/commit/caa20dd1962f0d659a9214ac28815a1b904d4118#diff-1e7de1ae2d059d21e1dd75d5812d5a34b0222cef273b7c3a2af62eb747f9d20a PR: 275402 Reported by: diizzy (via email) Approved by: portmgr (blanket, fix build) Fixes: 3e51c20bc069 (graphics/{,py-}opencolorio{,-tools}: Udpate to 2.3.2)
-rw-r--r--graphics/opencolorio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index e482865f5340..0ea8845f343d 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -44,9 +44,9 @@ PLIST_SUB= SHL3=${PORTVERSION} SHL2=${PORTVERSION:R}
.include <bsd.port.options.mk>
.if (defined(MACHINE_CPU) && ${MACHINE_CPU:Msse2})
-CMAKE_ON+= OCIO_USE_SSE
+CMAKE_ON+= OCIO_USE_SSE2
.else
-CMAKE_OFF+= OCIO_USE_SSE
+CMAKE_OFF+= OCIO_USE_SSE2
.endif
.if ${PORT_OPTIONS:MDOCS}