aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-08 14:26:49 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-08 15:30:55 +0000
commitd05a00a5b05d8c5e803f593330d8841198662a93 (patch)
treea79308bb09a86349750f68a59a11412c9026e6b6
parentfecc06b7b1637568a0fe899a3474eade15555f56 (diff)
comms/librs232: Fix build with llvm15
- Pet portclippy - Adopt port
-rw-r--r--comms/librs232/Makefile20
-rw-r--r--comms/librs232/pkg-plist2
2 files changed, 16 insertions, 6 deletions
diff --git a/comms/librs232/Makefile b/comms/librs232/Makefile
index a8ab729e5f1c..de950269b672 100644
--- a/comms/librs232/Makefile
+++ b/comms/librs232/Makefile
@@ -4,28 +4,38 @@ CATEGORIES= comms
DISTNAME= RS-232
MASTER_SITES= http://www.teuniz.net/RS-232/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Simple serial library
WWW= https://www.teuniz.net/RS-232/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/gpl.txt
+USES= uidfix
+USE_LDCONFIG= yes
+
WRKSRC= ${WRKDIR}/${DISTNAME}
+PORTEXAMPLES= demo_rx.c demo_tx.c
+
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= uidfix
-USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
-PORTEXAMPLES= demo_rx.c demo_tx.c
+.if defined(NO_PROFILE) || ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079 )
+PLIST_SUB+= PROFILE="@comment "
+.else
+PLIST_SUB+= PROFILE=""
+.endif
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc.txt ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${PORTEXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/comms/librs232/pkg-plist b/comms/librs232/pkg-plist
index fe3c94808dc4..852cb0b9af0f 100644
--- a/comms/librs232/pkg-plist
+++ b/comms/librs232/pkg-plist
@@ -1,5 +1,5 @@
include/rs232.h
-lib/librs232_p.a
+%%PROFILE%%lib/librs232_p.a
lib/librs232.a
lib/librs232.so
lib/librs232.so.1