aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-01-05 06:17:59 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-01-10 20:32:39 +0000
commitd110fac03fba6114a8ad47a3ed45d9674afcc50e (patch)
tree75ba5b3ac60d4acd3bacb63c98c7c88de8c5f76a
parentbf7e0f32b76c6e9af7c4c56c745d3b446e6ada11 (diff)
downloadports-d110fac03fba6114a8ad47a3ed45d9674afcc50e.tar.gz
ports-d110fac03fba6114a8ad47a3ed45d9674afcc50e.zip
deskutils/freeplane: Fix Unable to launch freeplane
Fix a typo in the launch script and add bash as a dependency. Create a new launch script. PR: 260753 Reported by: chris@crvintel.com
-rw-r--r--deskutils/freeplane/Makefile15
-rw-r--r--deskutils/freeplane/files/freeplane.in3
-rw-r--r--deskutils/freeplane/files/patch-freeplane.sh39
3 files changed, 37 insertions, 20 deletions
diff --git a/deskutils/freeplane/Makefile b/deskutils/freeplane/Makefile
index 9c419e217bc4..5c27da51e00c 100644
--- a/deskutils/freeplane/Makefile
+++ b/deskutils/freeplane/Makefile
@@ -2,6 +2,7 @@
PORTNAME= freeplane
DISTVERSION= 1.9.12
+PORTREVISION= 1
CATEGORIES= deskutils editors java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/archive/${PORTVERSION}
DISTNAME= ${PORTNAME}_bin-${PORTVERSION}
@@ -12,8 +13,10 @@ COMMENT= Free mind mapping and knowledge management software
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/license.txt
-USES= cpe zip
+RUN_DEPENDS= bash:shells/bash
+USES= cpe zip shebangfix
+SHEBANG_FILES= ${WRKSRC}/freeplane.sh
USE_JAVA= yes
NO_ARCH= yes
NO_BUILD= yes
@@ -23,10 +26,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} \
- "! ( -name freeplane\.sh* -or -name license\.txt -or -name *\.bat -or -name *\.exe )"
-# Install freeplane.sh with the right permission, link to it to bin/
-# and let it resolve the path to DATADIR automatically.
- ${INSTALL_SCRIPT} ${WRKSRC}/freeplane.sh ${STAGEDIR}${DATADIR}
- ${RLN} ${STAGEDIR}${DATADIR}/freeplane.sh ${STAGEDIR}${PREFIX}/bin/freeplane
+ "! ( -name license\.txt -or -name *\.bat -or -name *\.exe )"
+# Install freeplane.sh with the right permission
+ ${SED} -e 's|%%DATADIR%%|${DATADIR}|' < ${FILESDIR}/freeplane.in > \
+ ${WRKSRC}/freeplane
+ ${INSTALL_SCRIPT} ${WRKSRC}/freeplane ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/deskutils/freeplane/files/freeplane.in b/deskutils/freeplane/files/freeplane.in
new file mode 100644
index 000000000000..979424a424e4
--- /dev/null
+++ b/deskutils/freeplane/files/freeplane.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /bin/sh %%DATADIR%%/freeplane.sh
diff --git a/deskutils/freeplane/files/patch-freeplane.sh b/deskutils/freeplane/files/patch-freeplane.sh
index 481f3fed5aa8..02e1cf4c65a2 100644
--- a/deskutils/freeplane/files/patch-freeplane.sh
+++ b/deskutils/freeplane/files/patch-freeplane.sh
@@ -1,17 +1,28 @@
---- freeplane.sh.orig 2018-01-07 18:16:56 UTC
+--- freeplane.sh.orig 2022-01-05 06:17:27 UTC
+++ freeplane.sh
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
+@@ -57,7 +57,7 @@ findjava() {
+ fi
+ fi
- # we only want to test the script, not Freeplane itself
- if ( echo "${DEBUG}" | grep -qe "script" ); then
-@@ -123,7 +123,7 @@ if [ -x $(which readlink) ] && [ "`echo $OSTYPE | cut
- # if we have 'readlink' we can use it to get an absolute path
- # -m should be faster and link does always resolve, else this script
- # wouldn't be called, would it?
+- JAVA_VERSION=$(${JAVACMD} -version |& grep -E "[[:alnum:]]+ version" | awk '{print $3}' | tr -d '"')
++ JAVA_VERSION=$(${JAVACMD} -version | grep -E "[[:alnum:]]+ version" | awk '{print $3}' | tr -d '"')
+ JAVA_MAJOR_VERSION=$(echo $JAVA_VERSION | awk -F. '{print $1}')
+ if [ $JAVA_MAJOR_VERSION -ge 16 ]; then
+ if [ -z "${FREEPLANE_USE_UNSUPPORTED_JAVA_VERSION}" ]; then
+@@ -142,15 +142,7 @@ fi
+
+ output_debug_info
+
+-if [ -x $(which readlink) ] && [ "`echo $OSTYPE | cut -b1-6`" != "darwin" ]; then
+- # if we have 'readlink' we can use it to get an absolute path
+- # -m should be faster and link does always resolve, else this script
+- # wouldn't be called, would it?
- freefile=$(readlink -mn "$0")
-+ freefile=$(readlink -fn "$0")
- _debug "Link '$0' resolved to '${freefile}'."
- else
- freefile="$0"
+- _debug "Link '$0' resolved to '${freefile}'."
+-else
+- freefile="$0"
+-fi
++freefile="$0"
+
+ if [ "`echo $OSTYPE | cut -b1-6`" == "darwin" ]; then
+ xdockname='-Xdock:name=Freeplane'