aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-03-12 09:43:51 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-03-12 09:43:51 +0000
commitd196d2e2510aedbfd1134d5358ab0e961f12e964 (patch)
tree1f45b212f9c3fa8ed51c350951cc6bbf45fe0d8b
parent5197be8031e964425e405b32c7d9e801f142b251 (diff)
deskutils/nextcloudclient: Update to 3.7.4
- Improve WEBENGINE option description PR: 269809 Approved by: mr (maintainer)
-rw-r--r--deskutils/nextcloudclient/Makefile9
-rw-r--r--deskutils/nextcloudclient/distinfo6
-rw-r--r--deskutils/nextcloudclient/files/patch-src_CMakeLists.txt41
3 files changed, 49 insertions, 7 deletions
diff --git a/deskutils/nextcloudclient/Makefile b/deskutils/nextcloudclient/Makefile
index f813752f1246..fcdc524f0710 100644
--- a/deskutils/nextcloudclient/Makefile
+++ b/deskutils/nextcloudclient/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nextcloudclient
-PORTVERSION= 3.6.6
+PORTVERSION= 3.7.4
#PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
@@ -15,8 +15,9 @@ LIB_DEPENDS= libinotify.so:devel/libinotify \
libqt5keychain.so:security/qtkeychain@qt5
USES= cmake:noninja compiler:c++14-lang desktop-file-utils gmake \
- gnome iconv localbase:ldflags pkgconfig qt:5 shared-mime-info \
+ gnome iconv kde:5 localbase:ldflags pkgconfig qt:5 shared-mime-info \
sqlite ssl
+USE_KDE= archive
USE_QT= buildtools:build concurrent core dbus declarative graphicaleffects \
gui linguist:build location network printsupport qmake:build \
quickcontrols quickcontrols2 sql svg testlib webchannel websockets \
@@ -36,7 +37,7 @@ OPTIONS_DEFAULT_amd64= WEBENGINE
OPTIONS_DEFAULT_i386= WEBENGINE
OPTIONS_DEFAULT_aarch64= WEBENGINE
-WEBENGINE_DESC= QT5 Webengine support
+WEBENGINE_DESC= Use Webengine to provide web login flow
#DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
# doxygen:devel/doxygen
@@ -59,7 +60,7 @@ post-patch:
's|.lst |.lst.sample |' ${WRKSRC}/CMakeLists.txt
post-patch-WEBENGINE-off:
- @${REINPLACE_CMD} -e '/^find_package.*COMPONENTS WebEngineWidgets WebEngine/d' \
+ @${REINPLACE_CMD} -e '/add_compile_definitions(WITH_WEBENGINE=1)/d' \
${WRKSRC}/src/CMakeLists.txt
pre-configure:
diff --git a/deskutils/nextcloudclient/distinfo b/deskutils/nextcloudclient/distinfo
index 15d3a5e3116d..410bde3898af 100644
--- a/deskutils/nextcloudclient/distinfo
+++ b/deskutils/nextcloudclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674408218
-SHA256 (nextcloud-desktop-v3.6.6_GH0.tar.gz) = 04b3be9ab62eec7b81c971dc50c4e40666ee2d76c19cb72d9ad52e5a4d2edd47
-SIZE (nextcloud-desktop-v3.6.6_GH0.tar.gz) = 15497450
+TIMESTAMP = 1678375641
+SHA256 (nextcloud-desktop-v3.7.4_GH0.tar.gz) = 0d7b888b315293953ac33cb6eb8faa3bbc5b6201896c54c71b4648ec4d6ff597
+SIZE (nextcloud-desktop-v3.7.4_GH0.tar.gz) = 15701243
diff --git a/deskutils/nextcloudclient/files/patch-src_CMakeLists.txt b/deskutils/nextcloudclient/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..047f46c2bb70
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-src_CMakeLists.txt
@@ -0,0 +1,41 @@
+--- src/CMakeLists.txt.orig 2023-02-09 20:54:58 UTC
++++ src/CMakeLists.txt
+@@ -31,30 +31,16 @@ find_package(Qt5WebEngineWidgets ${REQUIRED_QT_VERSION
+ )
+
+ find_package(Qt5WebEngineWidgets ${REQUIRED_QT_VERSION} CONFIG QUIET)
+-if(APPLE)
+- set_package_properties(Qt5WebEngineWidgets PROPERTIES
+- DESCRIPTION "Qt5 WebEngineWidgets component."
+- TYPE RECOMMENDED
+- )
+-else()
+- set_package_properties(Qt5WebEngineWidgets PROPERTIES
+- DESCRIPTION "Qt5 WebEngineWidgets component."
+- TYPE REQUIRED
+- )
+-endif()
++set_package_properties(Qt5WebEngineWidgets PROPERTIES
++ DESCRIPTION "Qt5 WebEngineWidgets component."
++ TYPE RECOMMENDED
++)
+
+ find_package(Qt5WebEngine ${REQUIRED_QT_VERSION} CONFIG QUIET)
+-if(APPLE)
+- set_package_properties(Qt5WebEngine PROPERTIES
+- DESCRIPTION "Qt5 WebEngine component."
+- TYPE RECOMMENDED
+- )
+-else()
+- set_package_properties(Qt5WebEngine PROPERTIES
+- DESCRIPTION "Qt5 WebEngine component."
+- TYPE REQUIRED
+- )
+-endif()
++set_package_properties(Qt5WebEngine PROPERTIES
++ DESCRIPTION "Qt5 WebEngine component."
++ TYPE RECOMMENDED
++)
+
+ if(Qt5WebEngine_FOUND AND Qt5WebEngineWidgets_FOUND)
+ add_compile_definitions(WITH_WEBENGINE=1)