aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2022-10-11 00:52:50 +0000
committerJason Helfman <jgh@FreeBSD.org>2022-10-11 00:52:50 +0000
commitd20a3cf7e8483a0e5931c7cfc27686bcc699d910 (patch)
tree071b1bf9f38f08eeb9cb01c246bfc50926d34d87
parente2bbffc836c4f2aeb8bc4d728c3528fee6f76957 (diff)
downloadports-d20a3cf7e8483a0e5931c7cfc27686bcc699d910.tar.gz
ports-d20a3cf7e8483a0e5931c7cfc27686bcc699d910.zip
x11-fonts/atkinson-hyperlegible: shift to fontsdir for installations
-rw-r--r--x11-fonts/atkinson-hyperlegible/Makefile10
-rw-r--r--x11-fonts/atkinson-hyperlegible/pkg-plist40
2 files changed, 24 insertions, 26 deletions
diff --git a/x11-fonts/atkinson-hyperlegible/Makefile b/x11-fonts/atkinson-hyperlegible/Makefile
index d7dd8b7a249f..3015cc7c867a 100644
--- a/x11-fonts/atkinson-hyperlegible/Makefile
+++ b/x11-fonts/atkinson-hyperlegible/Makefile
@@ -1,5 +1,6 @@
PORTNAME= atkinson-hyperlegible
PORTVERSION= 2020.0514
+PORTREVISION= 1
CATEGORIES= x11-fonts accessibility
MASTER_SITES= https://brailleinstitute.org/wp-content/uploads/${PORTNAME}-font/:source1 \
http://brailleinstitute.org/wp-content/uploads/2020/11/:source2
@@ -39,20 +40,17 @@ post-extract:
@${FIND} ${WRKSRC} -type f -exec ${MV} {} ${WRKSRC}/allfonts \;
do-install:
- @${DO_NADA}
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
do-install-TTF-on:
- @${MKDIR} ${STAGEDIR}${FONTSDIR}
${INSTALL_DATA} ${WRKSRC}/allfonts/*.ttf ${STAGEDIR}${FONTSDIR}
do-install-OTF-on:
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/allfonts/*.otf ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/allfonts/*.otf ${STAGEDIR}${FONTSDIR}
post-install-WEB-on:
.for ext in svg eot woff woff2
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/allfonts/*.${ext} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/allfonts/*.${ext} ${STAGEDIR}${FONTSDIR}
.endfor
.include <bsd.port.mk>
diff --git a/x11-fonts/atkinson-hyperlegible/pkg-plist b/x11-fonts/atkinson-hyperlegible/pkg-plist
index 6a467d1a4d58..701be838254c 100644
--- a/x11-fonts/atkinson-hyperlegible/pkg-plist
+++ b/x11-fonts/atkinson-hyperlegible/pkg-plist
@@ -1,24 +1,24 @@
-%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.otf
-%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.otf
-%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.otf
-%%OTF%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.otf
+%%OTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102.otf
+%%OTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102.otf
+%%OTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102.otf
+%%OTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102.otf
%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102.ttf
%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102.ttf
%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102.ttf
%%TTF%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102.ttf
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.eot
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.svg
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102.woff
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Bold-102a.woff2
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.eot
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.svg
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102.woff
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-BoldItalic-102a.woff2
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.eot
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.svg
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102.woff
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Italic-102a.woff2
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.eot
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.svg
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102.woff
-%%WEB%%%%DATADIR%%/Atkinson-Hyperlegible-Regular-102a.woff2
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102.eot
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102.svg
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102.woff
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Bold-102a.woff2
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102.eot
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102.svg
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102.woff
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-BoldItalic-102a.woff2
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102.eot
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102.svg
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102.woff
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Italic-102a.woff2
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102.eot
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102.svg
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102.woff
+%%WEB%%%%FONTSDIR%%/Atkinson-Hyperlegible-Regular-102a.woff2