aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-08-06 19:39:19 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-08-06 19:42:02 +0000
commitd25fa2e8d52f978f4b028b446338b46a6c52542a (patch)
tree38d146258c13385db8caa741f650e74623f9d35f
parent358122b22e3bb467e77f2e9edd7edb38254e8eeb (diff)
devel/yaggo: Update to 1.5.11
Minor robustness improvements Add makeshift shebangfix Changes: https://github.com/gmarcais/yaggo/releases Reported by: portscout
-rw-r--r--devel/yaggo/Makefile9
-rw-r--r--devel/yaggo/distinfo5
-rw-r--r--devel/yaggo/files/patch-Makefile23
-rw-r--r--devel/yaggo/pkg-descr6
4 files changed, 26 insertions, 17 deletions
diff --git a/devel/yaggo/Makefile b/devel/yaggo/Makefile
index c24398e472dc..ac83edf90ff6 100644
--- a/devel/yaggo/Makefile
+++ b/devel/yaggo/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yaggo
-PORTVERSION= 1.5.9
+PORTVERSION= 1.5.11
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -9,12 +9,17 @@ WWW= https://github.com/gmarcais/yaggo
LICENSE= GPLv3
-USES= ruby
+USES= ruby
USE_GITHUB= yes
+
GH_ACCOUNT= gmarcais
NO_ARCH= yes
PLIST_FILES= bin/yaggo man/man1/yaggo.1.gz share/doc/yaggo/README.md
+pre-configure:
+ @${REINPLACE_CMD} -e 's|/usr/bin/env ruby|${PREFIX}/bin/ruby|g' \
+ ${WRKSRC}/bin/create_yaggo_one_file
+
.include <bsd.port.mk>
diff --git a/devel/yaggo/distinfo b/devel/yaggo/distinfo
index 4e530cd57eae..ba92d34d8279 100644
--- a/devel/yaggo/distinfo
+++ b/devel/yaggo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gmarcais-yaggo-v1.5.9_GH0.tar.gz) = c96f7d5932fad30c88300446cae9a49d35b6a1fcd5a971e02de129c5d7a53bb7
-SIZE (gmarcais-yaggo-v1.5.9_GH0.tar.gz) = 42480
+TIMESTAMP = 1691346120
+SHA256 (gmarcais-yaggo-v1.5.11_GH0.tar.gz) = cd15550d1b8ef136dbfb8a664da96c4aa024f98058a96ca64f9ebd6296241983
+SIZE (gmarcais-yaggo-v1.5.11_GH0.tar.gz) = 42563
diff --git a/devel/yaggo/files/patch-Makefile b/devel/yaggo/files/patch-Makefile
index f75ed9df603a..15527d3726c2 100644
--- a/devel/yaggo/files/patch-Makefile
+++ b/devel/yaggo/files/patch-Makefile
@@ -1,24 +1,23 @@
---- Makefile.orig 2015-10-14 16:25:43 UTC
+--- Makefile.orig 2023-07-27 18:44:09 UTC
+++ Makefile
-@@ -1,12 +1,14 @@
+@@ -1,12 +1,13 @@
-prefix ?= /usr/local
+PREFIX ?= /usr/local
-+DESTDIR ?=
-+MANPREFIX ?= $(PREFIX)/share
++MANPREFIX ?= ${PREFIX}
all: bin/create_yaggo_one_file
ruby bin/create_yaggo_one_file ./yaggo
install: all
-- mkdir -p $(prefix)/bin
-- mkdir -p $(prefix)/share/doc/yaggo
-- mkdir -p $(prefix)/share/man/man1
-- cp ./yaggo $(prefix)/bin
-- cp ./README.md $(prefix)/share/doc/yaggo
-- ./yaggo -m $(prefix)/share/man/man1/yaggo.1
+- mkdir -p $(DESTDIR)$(prefix)/bin
+- mkdir -p $(DESTDIR)$(prefix)/share/doc/yaggo
+- mkdir -p $(DESTDIR)$(prefix)/share/man/man1
+- cp ./yaggo $(DESTDIR)$(prefix)/bin
+- cp ./README.md $(DESTDIR)$(prefix)/share/doc/yaggo
+- ./yaggo -m $(DESTDIR)$(prefix)/share/man/man1/yaggo.1
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ mkdir -p $(DESTDIR)$(PREFIX)/share/doc/yaggo
-+ mkdir -p $(DESTDIR)$(MANPREFIX)/man/man1
++ mkdir -p $(DESTDIR)$(PREFIX)/man/man1
+ cp ./yaggo $(DESTDIR)$(PREFIX)/bin
+ cp ./README.md $(DESTDIR)$(PREFIX)/share/doc/yaggo
-+ ./yaggo -m $(DESTDIR)$(MANPREFIX)/man/man1/yaggo.1
++ ./yaggo -m $(DESTDIR)$(PREFIX)/man/man1/yaggo.1
diff --git a/devel/yaggo/pkg-descr b/devel/yaggo/pkg-descr
index 8523ee42ee8a..c2c9e6e7c1b3 100644
--- a/devel/yaggo/pkg-descr
+++ b/devel/yaggo/pkg-descr
@@ -1 +1,5 @@
-Generate command line parser using getopt_long.
+Yaggo is a tool to generate command line parsers for C++. Yaggo stands
+for "Yet Another GenGetOpt" and is inspired by GNU Gengetopt. It reads
+a configuration file describing the switches and argument for a C++
+program and it generates one header file that parses the command line
+using getopt_long(3). See the Example section below for more details.