aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-28 13:57:37 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-28 13:57:37 +0000
commitd2c4c14627bab9dba2b3a4437b7c286d5cc435f8 (patch)
treec4ff9fdbeb396b7aa8d0272c4b691c9f519f24ac
parentbff9ea9424744d453dd19ba56c70c972f0536190 (diff)
downloadports-d2c4c14627bab9dba2b3a4437b7c286d5cc435f8.tar.gz
ports-d2c4c14627bab9dba2b3a4437b7c286d5cc435f8.zip
USEify USES=php.
The following variables have been folded into arguments: - USE_PHPIZE -> USES=php:phpize - USE_PHPEXT -> USES=php:ext - USE_ZENDEXT -> USES=php:zend - USE_PHP_BUILD -> USES=php:build - WANT_PHP_CLI -> USES=php:cli - WANT_PHP_CGI -> USES=php:cgi - WANT_PHP_MOD -> USES=php:mod - WANT_PHP_WEB -> USES=php:web - WANT_PHP_EMB -> USES=php:embed PR: 210529 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6936
Notes
Notes: svn path=/head/; revision=417717
-rw-r--r--CHANGES17
-rw-r--r--Mk/Uses/php.mk99
-rw-r--r--Mk/bsd.sanity.mk14
-rw-r--r--dns/pear-Net_DNS/Makefile2
-rw-r--r--mail/squirrelmail/Makefile2
-rw-r--r--net/self-service-password/Makefile2
-rw-r--r--security/cryptstring/Makefile2
-rw-r--r--security/pear-Crypt_CHAP/Makefile2
-rw-r--r--security/pear-File_SMBPasswd/Makefile2
-rw-r--r--security/pear-Horde_Crypt_Blowfish/Makefile2
-rw-r--r--sysutils/gosa/Makefile2
-rw-r--r--www/thundercache/Makefile2
-rw-r--r--www/thundersnarf/Makefile2
13 files changed, 106 insertions, 44 deletions
diff --git a/CHANGES b/CHANGES
index fc8b7328d802..783176257b3e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,23 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20160628:
+AUTHOR: mat@FreeBSD.org
+
+ USEify USES=php.
+
+ The following variables have been folded into arguments:
+
+ - USE_PHPIZE -> USES=php:phpize
+ - USE_PHPEXT -> USES=php:ext
+ - USE_ZENDEXT -> USES=php:zend
+ - USE_PHP_BUILD -> USES=php:build
+ - WANT_PHP_CLI -> USES=php:cli
+ - WANT_PHP_CGI -> USES=php:cgi
+ - WANT_PHP_MOD -> USES=php:mod
+ - WANT_PHP_WEB -> USES=php:web
+ - WANT_PHP_EMB -> USES=php:embed
+
20160627:
AUTHOR: mat@FreeBSD.org
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 937619498182..81fdfb80beb2 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -4,7 +4,17 @@
#
# Feature: php
# Usage: USES=php
-# Valid ARGS: (none)
+# Valid ARGS: (none), phpize, ext, zend, build, cli, cgi, mod, web, embed
+#
+# - phpize : Use to build a PHP extension.
+# - ext : Use to build, install and register a PHP extension.
+# - zend : Use to build, install and register a Zend extension.
+# - build : Set PHP also as a build dependency.
+# - cli : Want the CLI version of PHP.
+# - cgi : Want the CGI version of PHP.
+# - mod : Want the Apache Module for PHP.
+# - web : Want the Apache Module or the CGI version of PHP.
+# - embed : Want the embedded library version of PHP.
#
# If the port requires a predefined set of PHP extensions, they can be
# listed in this way:
@@ -15,15 +25,6 @@
#
# DEFAULT_PHP_VER=N - Use PHP version N if PHP is not yet installed.
# IGNORE_WITH_PHP=N - The port doesn't work with PHP version N.
-# USE_PHPIZE=yes - Use to build a PHP extension.
-# USE_PHPEXT=yes - Use to build, install and register a PHP extension.
-# USE_ZENDEXT=yes - Use to build, install and register a Zend extension.
-# USE_PHP_BUILD=yes - Set PHP also as a build dependency.
-# WANT_PHP_CLI=yes - Want the CLI version of PHP.
-# WANT_PHP_CGI=yes - Want the CGI version of PHP.
-# WANT_PHP_MOD=yes - Want the Apache Module for PHP.
-# WANT_PHP_WEB=yes - Want the Apache Module or the CGI version of PHP.
-# WANT_PHP_EMB=yes - Want the embedded library version of PHP.
#
# You may combine multiple WANT_PHP_* knobs.
# Don't specify any WANT_PHP_* knob if your port will work with every PHP SAPI.
@@ -43,6 +44,44 @@ _INCLUDE_USES_PHP_MK= yes
WARNING+= "DEFAULT_PHP_VER is defined, consider using DEFAULT_VERSIONS=php=${DEFAULT_PHP_VER} instead"
. endif
+. if defined(USE_PHPIZE) && empty(php_ARGS:Mphpize)
+php_ARGS+= phpize
+. endif
+. if defined(USE_PHPEXT) && empty(php_ARGS:Mext)
+php_ARGS+= ext
+. endif
+. if defined(USE_ZENDEXT) && empty(php_ARGS:Mzend)
+php_ARGS+= zend
+. endif
+. if defined(USE_PHP_BUILD) && empty(php_ARGS:Mbuild)
+php_ARGS+= build
+. endif
+. if defined(WANT_PHP_CLI) && empty(php_ARGS:Mcli)
+php_ARGS+= cli
+. endif
+. if defined(WANT_PHP_CGI) && empty(php_ARGS:Mcgi)
+php_ARGS+= cgi
+. endif
+. if defined(WANT_PHP_MOD) && empty(php_ARGS:Mmod)
+php_ARGS+= mod
+. endif
+. if defined(WANT_PHP_WEB) && empty(php_ARGS:Mweb)
+php_ARGS+= web
+. endif
+. if defined(WANT_PHP_EMB) && empty(php_ARGS:Membed)
+php_ARGS+= embed
+. endif
+
+. if ${php_ARGS:Mbuild} && ( ${php_ARGS:Mphpize} || ${php_ARGS:Mext} || ${php_ARGS:Mzend} )
+DEV_WARNING+= "USES=php:build is included in USES=php:phpize, USES=php:ext, and USES=php:zend, so it is not needed"
+. endif
+. if ${php_ARGS:Mphpize} && ( ${php_ARGS:Mext} || ${php_ARGS:Mzend} )
+DEV_WARNING+= "USES=php:phpize is included in USES=php:ext and USES=php:zend, so it is not needed"
+. endif
+. if ${php_ARGS:Mext} && ${php_ARGS:Mzend}
+DEV_WARNING+= "USES=php:ext is included in USES=php:zend, so it is not needed"
+. endif
+
PHPBASE?= ${LOCALBASE}
. if exists(${PHPBASE}/etc/php.conf)
.include "${PHPBASE}/etc/php.conf"
@@ -98,16 +137,16 @@ IGNORE= cannot be installed: doesn't work with lang/php${PHP_VER} port\
. endfor
. endif
-. if defined(WANT_PHP_WEB)
-. if defined(WANT_PHP_CGI) || defined(WANT_PHP_MOD)
+. if ${php_ARGS:Mweb}
+. if ${php_ARGS:Mcgi} || ${php_ARGS:Mmod}
check-makevars::
- @${ECHO_CMD} "If you define WANT_PHP_WEB you cannot set also WANT_PHP_CGI"
- @${ECHO_CMD} "or WANT_PHP_MOD. Use only one of them."
+ @${ECHO_CMD} "If you use :web you cannot also use :cgi"
+ @${ECHO_CMD} "or :mod. Use only one of them."
@${FALSE}
. endif
. endif
-. if defined(WANT_PHP_CGI)
+. if ${php_ARGS:Mcgi}
. if defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mfpm} == ""
check-makevars::
@${ECHO_CMD} "This port requires the CGI version of PHP, but you have already"
@@ -116,7 +155,7 @@ check-makevars::
. endif
. endif
-. if defined(WANT_PHP_CLI)
+. if ${php_ARGS:Mcli}
. if defined(PHP_VERSION) && ${PHP_SAPI:Mcli} == ""
check-makevars::
@${ECHO_CMD} "This port requires the CLI version of PHP, but you have already"
@@ -125,7 +164,7 @@ check-makevars::
. endif
. endif
-. if defined(WANT_PHP_EMB)
+. if ${php_ARGS:Membed}
. if defined(PHP_VERSION) && ${PHP_SAPI:Membed} == ""
check-makevars::
@${ECHO_CMD} "This port requires the embedded library version of PHP, but you have already"
@@ -137,11 +176,11 @@ check-makevars::
PHP_PORT?= lang/php${PHP_VER}
MOD_PHP_PORT?= www/mod_php${PHP_VER}
-. if defined(USE_PHP_BUILD)
+. if ${php_ARGS:Mbuild}
BUILD_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
. endif
RUN_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
-. if defined(WANT_PHP_MOD) || (defined(WANT_PHP_WEB) && defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mfpm} == "")
+. if ${php_ARGS:Mmod} || (${php_ARGS:Mweb} && defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mfpm} == "")
USE_APACHE_RUN= 22+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp5.so:${MOD_PHP_PORT}
@@ -150,7 +189,7 @@ RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp5.so:${MOD_PHP_PORT}
PLIST_SUB+= PHP_EXT_DIR=${PHP_EXT_DIR}
SUB_LIST+= PHP_EXT_DIR=${PHP_EXT_DIR}
-. if defined(USE_PHPIZE) || defined(USE_PHPEXT) || defined(USE_ZENDEXT)
+. if ${php_ARGS:Mphpize} || ${php_ARGS:Mext} || ${php_ARGS:Mzend}
BUILD_DEPENDS+= ${PHPBASE}/bin/phpize:${PHP_PORT}
GNU_CONFIGURE= yes
USE_AUTOTOOLS+= autoconf:env
@@ -172,7 +211,7 @@ _USES_POST+=php
_INCLUDE_USES_PHP_POST_MK=yes
-. if (defined(USE_PHPEXT) || defined(USE_ZENDEXT))
+. if ${php_ARGS:Mext} || ${php_ARGS:Mzend}
PHP_MODNAME?= ${PORTNAME}
PHP_HEADER_DIRS?= ""
@@ -206,7 +245,7 @@ add-plist-phpext:
>> ${TMPPLIST}
@${ECHO_CMD} "@dir etc/php" \
>> ${TMPPLIST}
-. if defined(USE_ZENDEXT)
+. if ${php_ARGS:Mzend}
@${ECHO_CMD} "@exec echo zend_extension=%D/lib/php/${PHP_EXT_DIR}/${PHP_MODNAME}.so >> %D/etc/php/extensions.ini" \
>> ${TMPPLIST}
. else
@@ -215,7 +254,7 @@ add-plist-phpext:
. endif
@${ECHO_CMD} "@unexec cp %D/etc/php/extensions.ini %D/etc/php/extensions.ini.orig" \
>> ${TMPPLIST}
-. if defined(USE_ZENDEXT)
+. if ${php_ARGS:Mzend}
@${ECHO_CMD} "@unexec grep -v zend_extension=%D/lib/php/${PHP_EXT_DIR}/${PHP_MODNAME}\\\.so %D/etc/php/extensions.ini.orig > %D/etc/php/extensions.ini || true" \
>> ${TMPPLIST}
. else
@@ -235,7 +274,7 @@ php-ini:
@${ECHO_CMD} "The following line has been added to your ${PREFIX}/etc/php/extensions.ini"
@${ECHO_CMD} "configuration file to automatically load the installed extension:"
@${ECHO_CMD} ""
-. if defined(USE_ZENDEXT)
+. if ${php_ARGS:Mzend}
@${ECHO_CMD} "zend_extension=${PREFIX}/lib/php/${PHP_EXT_DIR}/${PHP_MODNAME}.so"
. else
@${ECHO_CMD} "extension=${PHP_MODNAME}.so"
@@ -245,7 +284,7 @@ php-ini:
. endif
# Extensions
-. if ${USE_PHP:tl} != "yes"
+. if defined(USE_PHP) && ${USE_PHP:tl} != "yes"
# non-version specific components
_USE_PHP_ALL= apc bcmath bitset bz2 calendar ctype curl dba dom \
exif fileinfo filter ftp gd gettext gmp \
@@ -297,7 +336,6 @@ ldap_DEPENDS= net/php${PHP_VER}-ldap
mbstring_DEPENDS= converters/php${PHP_VER}-mbstring
mcrypt_DEPENDS= security/php${PHP_VER}-mcrypt
memcache_DEPENDS= databases/pecl-memcache
-mhash_DEPENDS= security/php${PHP_VER}-mhash
mssql_DEPENDS= databases/php${PHP_VER}-mssql
mysql_DEPENDS= databases/php${PHP_VER}-mysql
mysqli_DEPENDS= databases/php${PHP_VER}-mysqli
@@ -349,19 +387,14 @@ zlib_DEPENDS= archivers/php${PHP_VER}-zlib
. for extension in ${USE_PHP}
. if ${_USE_PHP_VER${PHP_VER}:M${extension}} != ""
. if ${PHP_EXT_INC:M${extension}} == ""
-. if defined(USE_PHP_BUILD)
+. if ${php_ARGS:Mbuild}
BUILD_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/${extension}.so:${${extension}_DEPENDS}
. endif
RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/${extension}.so:${${extension}_DEPENDS}
. endif
. else
ext= ${extension}
-. if ${ext} == "mhash"
-. if defined(USE_PHP_BUILD)
-BUILD_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/hash.so:${hash_DEPENDS}
-. endif
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/hash.so:${hash_DEPENDS}
-. elif ${ext:tl} != "yes"
+. if ${ext:tl} != "yes"
check-makevars::
@${ECHO_CMD} "Unknown extension ${extension} for PHP ${PHP_VER}."
@${FALSE}
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 015ba37ea493..5dbc68e7df5c 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -178,7 +178,10 @@ SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_PYTHON_PREFIX USE_BZIP2 USE_XZ USE_PGSQL NEED_ROOT \
UNIQUENAME LATEST_LINK USE_SQLITE USE_FIREBIRD
SANITY_DEPRECATED= PYTHON_PKGNAMESUFFIX USE_AUTOTOOLS PLIST_DIRSTRY \
- USE_BDB USE_MYSQL WANT_MYSQL_VER USE_OPENSSL
+ USE_BDB USE_MYSQL WANT_MYSQL_VER USE_OPENSSL \
+ USE_PHPIZE USE_PHPEXT USE_ZENDEXT USE_PHP_BUILD \
+ WANT_PHP_CLI WANT_PHP_CGI WANT_PHP_MOD WANT_PHP_WEB \
+ WANT_PHP_EMB
SANITY_NOTNEEDED= WX_UNICODE
USE_AUTOTOOLS_ALT= USES=autoreconf and GNU_CONFIGURE=yes
@@ -223,6 +226,15 @@ USE_BDB_ALT= USES=bdb:${USE_BDB}
USE_MYSQL_ALT= USES=mysql:${USE_MYSQL}
WANT_MYSQL_VER_ALT= USES=mysql:${WANT_MYSQL_VER}
USE_OPENSSL_ALT= USES=ssl
+USE_PHPIZE_ALT= USES=php:phpize
+USE_PHPEXT_ALT= USES=php:ext
+USE_ZENDEXT_ALT= USES=php:zend
+USE_PHP_BUILD_ALT= USES=php:build
+WANT_PHP_CLI_ALT= USES=php:cli
+WANT_PHP_CGI_ALT= USES=php:cgi
+WANT_PHP_MOD_ALT= USES=php:mod
+WANT_PHP_WEB_ALT= USES=php:web
+WANT_PHP_EMB_ALT= USES=php:embed
.for a in ${SANITY_DEPRECATED}
.if defined(${a})
diff --git a/dns/pear-Net_DNS/Makefile b/dns/pear-Net_DNS/Makefile
index 4a76fb739082..83b520eef657 100644
--- a/dns/pear-Net_DNS/Makefile
+++ b/dns/pear-Net_DNS/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= Resolver library used to communicate with a DNS server
PORTSCOUT= skipv:1.00b2,1.00b1
-USE_PHP= mhash
+USE_PHP= hash
USES= pear
.include <bsd.port.mk>
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 1965b35de307..d8503e7c2bd0 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -19,7 +19,7 @@ BROKEN_powerpc64= Does not build
# patches, but the only guaranteed compatibility is with php 5.3.
# If you encounter problems, downgrade to php 5.3.
-USE_PHP= session mhash gettext mbstring pcre openssl xml
+USE_PHP= session hash gettext mbstring pcre openssl xml
WANT_PHP_WEB= yes
USES= cpe gettext perl5 tar:bzip2
diff --git a/net/self-service-password/Makefile b/net/self-service-password/Makefile
index a3914601d7c7..5215a6cee128 100644
--- a/net/self-service-password/Makefile
+++ b/net/self-service-password/Makefile
@@ -18,7 +18,7 @@ BROKEN_powerpc64= Does not build
NO_BUILD= yes
NO_ARCH= yes
-USE_PHP= ldap openssl session hash mhash mcrypt mbstring filter
+USE_PHP= ldap openssl session hash hash mcrypt mbstring filter
WANT_PHP_WEB= yes
diff --git a/security/cryptstring/Makefile b/security/cryptstring/Makefile
index 77ccd73b7f65..ac03704a6c02 100644
--- a/security/cryptstring/Makefile
+++ b/security/cryptstring/Makefile
@@ -16,7 +16,7 @@ EXPIRATION_DATE= 2016-07-04
LICENSE= BSD2CLAUSE
NO_BUILD= yes
-USE_PHP= mcrypt mhash
+USE_PHP= mcrypt hash
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/security/pear-Crypt_CHAP/Makefile b/security/pear-Crypt_CHAP/Makefile
index a810aaec3545..fb6253e04606 100644
--- a/security/pear-Crypt_CHAP/Makefile
+++ b/security/pear-Crypt_CHAP/Makefile
@@ -9,6 +9,6 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for generating CHAP packets
USES= pear
-USE_PHP= mcrypt mhash
+USE_PHP= mcrypt hash
.include <bsd.port.mk>
diff --git a/security/pear-File_SMBPasswd/Makefile b/security/pear-File_SMBPasswd/Makefile
index cf257f7911f6..8d1b8681025b 100644
--- a/security/pear-File_SMBPasswd/Makefile
+++ b/security/pear-File_SMBPasswd/Makefile
@@ -12,6 +12,6 @@ BUILD_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:security/pear-Crypt_CHAP
RUN_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:security/pear-Crypt_CHAP
USES= pear
-USE_PHP= mhash
+USE_PHP= hash
.include <bsd.port.mk>
diff --git a/security/pear-Horde_Crypt_Blowfish/Makefile b/security/pear-Horde_Crypt_Blowfish/Makefile
index 49587eade7d5..52be1dd4288e 100644
--- a/security/pear-Horde_Crypt_Blowfish/Makefile
+++ b/security/pear-Horde_Crypt_Blowfish/Makefile
@@ -17,7 +17,7 @@ MHASH_DESC= Depend on mhash PHP extension
OPENSSL_DESC= Depend on OpenSSL PHP extension
USES= horde
-MHASH_USE= PHP=mhash
+MHASH_USE= PHP=hash
OPENSSL_USE= PHP=openssl
.include <bsd.port.mk>
diff --git a/sysutils/gosa/Makefile b/sysutils/gosa/Makefile
index 6244ec042c09..163e3244a8bd 100644
--- a/sysutils/gosa/Makefile
+++ b/sysutils/gosa/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= p5-Crypt-SmbHash>=0.12:security/p5-Crypt-SmbHash \
pecl-imagick>=2.2.2:graphics/pecl-imagick
USES= tar:bzip2
-USE_PHP= gettext iconv imap ldap mbstring mhash mysql pcre posix \
+USE_PHP= gettext iconv imap ldap mbstring hash mysql pcre posix \
session spl xml zlib
NO_BUILD= yes
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index ae9bf732b8c8..d946319d6c02 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -53,7 +53,7 @@ WANT_PGSQL= server
.endif
.if ${PORT_OPTIONS:MPHP}
-USE_PHP+= curl pcre bcmath pdo mcrypt mhash session
+USE_PHP+= curl pcre bcmath pdo mcrypt hash session
. if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pdo_pgsql pgsql
. endif
diff --git a/www/thundersnarf/Makefile b/www/thundersnarf/Makefile
index 0faac2714f7a..14a2629bec08 100644
--- a/www/thundersnarf/Makefile
+++ b/www/thundersnarf/Makefile
@@ -36,7 +36,7 @@ WANT_PGSQL= server
.endif
.if ${PORT_OPTIONS:MPHP}
-USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql spl dom xmlrpc ctype openssl simplexml soap json
+USE_PHP+= curl pcre bcmath pdo mcrypt hash session pgsql spl dom xmlrpc ctype openssl simplexml soap json
. if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pdo_pgsql pgsql
. endif