aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2022-05-05 11:28:07 +0000
committerBernard Spil <brnrd@FreeBSD.org>2022-05-05 11:28:07 +0000
commitd2ed2b98e264a7f2991c1283773f2e63394f3776 (patch)
treeb26233853f63c1fc3055a83f3373068938c630ae
parent14d9cc841bd7e59c7fe99da5e38abe504b399839 (diff)
www/nextcloud: PHP 8.1 compat
* Pet portlint * Clean up * Standardize apps DIST_SUBDIR
-rw-r--r--finance/nextcloud-cospend/Makefile7
-rw-r--r--security/nextcloud-end_to_end_encryption/Makefile3
-rw-r--r--security/nextcloud-passman/Makefile5
-rw-r--r--security/nextcloud-passman/distinfo4
-rw-r--r--security/nextcloud-twofactor_admin/Makefile1
-rw-r--r--security/nextcloud-twofactor_nextcloud_notification/Makefile10
-rw-r--r--security/nextcloud-twofactor_nextcloud_notification/distinfo4
-rw-r--r--security/nextcloud-twofactor_u2f/Makefile1
-rw-r--r--security/nextcloud-twofactor_webauthn/Makefile2
-rw-r--r--security/nextcloud-twofactor_webauthn/distinfo4
-rw-r--r--www/nextcloud-appointments/Makefile1
-rw-r--r--www/nextcloud-calendar/Makefile1
-rw-r--r--www/nextcloud-forms/Makefile3
-rw-r--r--www/nextcloud-forms/distinfo4
-rw-r--r--www/nextcloud-notes/Makefile1
-rw-r--r--www/nextcloud-tasks/Makefile3
16 files changed, 18 insertions, 36 deletions
diff --git a/finance/nextcloud-cospend/Makefile b/finance/nextcloud-cospend/Makefile
index d3ff44562820..693077df9abe 100644
--- a/finance/nextcloud-cospend/Makefile
+++ b/finance/nextcloud-cospend/Makefile
@@ -2,16 +2,14 @@
PORTNAME= cospend
PORTVERSION= 1.4.6
-DISTVERSIONPREFIX= v
CATEGORIES= finance www editors
-MASTER_SITES= https://github.com/eneiluj/${PORTNAME}-nc/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+MASTER_SITES= https://github.com/eneiluj/${PORTNAME}-nc/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= nextcloud
MAINTAINER= mr@FreeBSD.org
-COMMENT= cospend app for Nextcloud
+COMMENT= Cospend app for Nextcloud
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -19,7 +17,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=22:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-end_to_end_encryption/Makefile b/security/nextcloud-end_to_end_encryption/Makefile
index 7f3d535b05b4..d329cf826475 100644
--- a/security/nextcloud-end_to_end_encryption/Makefile
+++ b/security/nextcloud-end_to_end_encryption/Makefile
@@ -15,10 +15,9 @@ COMMENT= End-to-End Encryption app for Nextcloud
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=22:www/nextcloud@${PHP_FLAVOR}
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=23:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-passman/Makefile b/security/nextcloud-passman/Makefile
index c1608067c38d..dbcac29b0b17 100644
--- a/security/nextcloud-passman/Makefile
+++ b/security/nextcloud-passman/Makefile
@@ -7,6 +7,7 @@ MASTER_SITES= https://releases.passman.cc/
PKGNAMEPREFIX= nextcloud-
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
DISTNAME= ${PORTNAME}_${PORTVERSION}
+DIST_SUBDIR= nextcloud
MAINTAINER= brnrd@FreeBSD.org
COMMENT= Full featured password manager for Nextcloud
@@ -16,13 +17,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=20:www/nextcloud@${PHP_FLAVOR}
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
do-install:
diff --git a/security/nextcloud-passman/distinfo b/security/nextcloud-passman/distinfo
index a4f19bde0d85..788dd9212ea7 100644
--- a/security/nextcloud-passman/distinfo
+++ b/security/nextcloud-passman/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1639730931
-SHA256 (passman_2.4.0.tar.gz) = 0d436caf9737b0e4bf34d2bc8753138c42034ba5062d53939501673723f76b08
-SIZE (passman_2.4.0.tar.gz) = 1978083
+SHA256 (nextcloud/passman_2.4.0.tar.gz) = 0d436caf9737b0e4bf34d2bc8753138c42034ba5062d53939501673723f76b08
+SIZE (nextcloud/passman_2.4.0.tar.gz) = 1978083
diff --git a/security/nextcloud-twofactor_admin/Makefile b/security/nextcloud-twofactor_admin/Makefile
index 01dac1776de4..1a9c44d381d6 100644
--- a/security/nextcloud-twofactor_admin/Makefile
+++ b/security/nextcloud-twofactor_admin/Makefile
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=17:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-twofactor_nextcloud_notification/Makefile b/security/nextcloud-twofactor_nextcloud_notification/Makefile
index e22fdb2aaca4..f48c9079ebf5 100644
--- a/security/nextcloud-twofactor_nextcloud_notification/Makefile
+++ b/security/nextcloud-twofactor_nextcloud_notification/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= security
MASTER_SITES= https://github.com/nextcloud-releases/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-WRKSRC= ${WRKDIR}/${PORTNAME}
+DIST_SUBDIR= nextcloud
MAINTAINER= brnrd@FreeBSD.org
COMMENT= Use Nextcloud notification as MFA app for Nextcloud
@@ -18,16 +18,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=22:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
-NEXTCLOUD_USERNAME?= ${WWWOWN}
-NEXTCLOUD_GROUPNAME?= ${WWWGRP}
-
-PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
- NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
-
+WRKSRC= ${WRKDIR}/${PORTNAME}
WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
do-install:
diff --git a/security/nextcloud-twofactor_nextcloud_notification/distinfo b/security/nextcloud-twofactor_nextcloud_notification/distinfo
index bdc191b0ea04..5768db2d5854 100644
--- a/security/nextcloud-twofactor_nextcloud_notification/distinfo
+++ b/security/nextcloud-twofactor_nextcloud_notification/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1651225541
-SHA256 (twofactor_nextcloud_notification-v3.4.0.tar.gz) = 7be167036288c90e61a2be5a728b3e0f32d8adc1331d18ad4bd68c638a8c1a1f
-SIZE (twofactor_nextcloud_notification-v3.4.0.tar.gz) = 833861
+SHA256 (nextcloud/twofactor_nextcloud_notification-v3.4.0.tar.gz) = 7be167036288c90e61a2be5a728b3e0f32d8adc1331d18ad4bd68c638a8c1a1f
+SIZE (nextcloud/twofactor_nextcloud_notification-v3.4.0.tar.gz) = 833861
diff --git a/security/nextcloud-twofactor_u2f/Makefile b/security/nextcloud-twofactor_u2f/Makefile
index f93ff9750298..fb94cc12c2cc 100644
--- a/security/nextcloud-twofactor_u2f/Makefile
+++ b/security/nextcloud-twofactor_u2f/Makefile
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=20:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/security/nextcloud-twofactor_webauthn/Makefile b/security/nextcloud-twofactor_webauthn/Makefile
index d649f8cb6312..42fa7926819d 100644
--- a/security/nextcloud-twofactor_webauthn/Makefile
+++ b/security/nextcloud-twofactor_webauthn/Makefile
@@ -5,6 +5,7 @@ CATEGORIES= security
MASTER_SITES= https://github.com/nextcloud-releases/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DIST_SUBDIR= nextcloud
MAINTAINER= brnrd@FreeBSD.org
COMMENT= U2F webauthn app for Nextcloud
@@ -15,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=21:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/security/nextcloud-twofactor_webauthn/distinfo b/security/nextcloud-twofactor_webauthn/distinfo
index fc8162afa36e..59233883eebf 100644
--- a/security/nextcloud-twofactor_webauthn/distinfo
+++ b/security/nextcloud-twofactor_webauthn/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1646681059
-SHA256 (twofactor_webauthn-v0.3.1.tar.gz) = 15d8eadf79ad5dcbad1ef79dbd91de04605693d8c8aeb8bf423b9188a4e77ca4
-SIZE (twofactor_webauthn-v0.3.1.tar.gz) = 2920762
+SHA256 (nextcloud/twofactor_webauthn-v0.3.1.tar.gz) = 15d8eadf79ad5dcbad1ef79dbd91de04605693d8c8aeb8bf423b9188a4e77ca4
+SIZE (nextcloud/twofactor_webauthn-v0.3.1.tar.gz) = 2920762
diff --git a/www/nextcloud-appointments/Makefile b/www/nextcloud-appointments/Makefile
index f84ecc023d69..c3539fb534fc 100644
--- a/www/nextcloud-appointments/Makefile
+++ b/www/nextcloud-appointments/Makefile
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=21:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud-calendar/Makefile b/www/nextcloud-calendar/Makefile
index cd1dfdefff73..f61e487d7226 100644
--- a/www/nextcloud-calendar/Makefile
+++ b/www/nextcloud-calendar/Makefile
@@ -17,7 +17,6 @@ LICENSE= AGPLv3
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=20:www/nextcloud@${PHP_FLAVOR}
USES= cpe php:flavors
-IGNORE_WITH_PHP=81
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
diff --git a/www/nextcloud-forms/Makefile b/www/nextcloud-forms/Makefile
index c1a2d49e3c53..c5497b8008da 100644
--- a/www/nextcloud-forms/Makefile
+++ b/www/nextcloud-forms/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= www
MASTER_SITES= https://github.com/nextcloud-releases/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
-DIST_SUBDIR= nextcloud/${PORTNAME}-${DISTVERSION}
+DIST_SUBDIR= nextcloud
MAINTAINER= brnrd@FreeBSD.org
COMMENT= Forms app for Nextcloud
@@ -18,7 +18,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=22:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud-forms/distinfo b/www/nextcloud-forms/distinfo
index 3c5dbf49feeb..eb4fdf5e1272 100644
--- a/www/nextcloud-forms/distinfo
+++ b/www/nextcloud-forms/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1649510164
-SHA256 (nextcloud/forms-2.5.0/forms-v2.5.0.tar.gz) = aa17dfb88acbe4660d6a5e4545bbcda65721a1cd4745c2e345951b8aba6973ec
-SIZE (nextcloud/forms-2.5.0/forms-v2.5.0.tar.gz) = 4621967
+SHA256 (nextcloud/forms-v2.5.0.tar.gz) = aa17dfb88acbe4660d6a5e4545bbcda65721a1cd4745c2e345951b8aba6973ec
+SIZE (nextcloud/forms-v2.5.0.tar.gz) = 4621967
diff --git a/www/nextcloud-notes/Makefile b/www/nextcloud-notes/Makefile
index 7d23a76030f8..5e6e1e04c3b3 100644
--- a/www/nextcloud-notes/Makefile
+++ b/www/nextcloud-notes/Makefile
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=20:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/nextcloud-tasks/Makefile b/www/nextcloud-tasks/Makefile
index c9ca5ff2aadb..8abb4f1454c5 100644
--- a/www/nextcloud-tasks/Makefile
+++ b/www/nextcloud-tasks/Makefile
@@ -2,8 +2,8 @@
PORTNAME= tasks
PORTVERSION= 0.14.4
-CATEGORIES= www
DISTVERSIONPREFIX= v
+CATEGORIES= www
MASTER_SITES= https://github.com/nextcloud/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
PKGNAMEPREFIX= nextcloud-
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -19,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=20:www/nextcloud@${PHP_FLAVOR}
USES= php:flavors
-IGNORE_WITH_PHP=81
NO_BUILD= yes
NO_ARCH= yes