aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-09 10:14:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-09 10:18:41 +0000
commitd3f8a43f8eb72934628597ec9301788aeb8e0e4b (patch)
tree182216cc2a79636e4b01f5cf8f7326534377bd84
parent276c0719eb5c609144e4e08691127d3f2c820410 (diff)
downloadports-d3f8a43f8eb72934628597ec9301788aeb8e0e4b.tar.gz
ports-d3f8a43f8eb72934628597ec9301788aeb8e0e4b.zip
net/nebula: New port: Scalable overlay networking tool
-rw-r--r--net/Makefile1
-rw-r--r--net/nebula/Makefile20
-rw-r--r--net/nebula/distinfo5
-rw-r--r--net/nebula/pkg-descr11
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index af1d2fe1c35e..54395d3d1a2c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -499,6 +499,7 @@
SUBDIR += ndpi
SUBDIR += ndproxy
SUBDIR += neatvnc
+ SUBDIR += nebula
SUBDIR += nemesis
SUBDIR += nepenthes
SUBDIR += net6
diff --git a/net/nebula/Makefile b/net/nebula/Makefile
new file mode 100644
index 000000000000..c996edf1ba70
--- /dev/null
+++ b/net/nebula/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= nebula
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.6.1
+CATEGORIES= net
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Scalable overlay networking tool
+WWW= https://github.com/slackhq/nebula
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/slackhq/nebula
+GO_TARGET= ./cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/nebula/distinfo b/net/nebula/distinfo
new file mode 100644
index 000000000000..1c261f132703
--- /dev/null
+++ b/net/nebula/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1673258645
+SHA256 (go/net_nebula/nebula-v1.6.1/v1.6.1.mod) = b555f4be50246ff2d5373474de23bffccbea76514879dc2400fc5031cde73c3c
+SIZE (go/net_nebula/nebula-v1.6.1/v1.6.1.mod) = 2042
+SHA256 (go/net_nebula/nebula-v1.6.1/v1.6.1.zip) = d0e28bf9e41484276be9da78530b1ba97b87fdd6b624fe4fd31505c4c12d0afe
+SIZE (go/net_nebula/nebula-v1.6.1/v1.6.1.zip) = 1059841
diff --git a/net/nebula/pkg-descr b/net/nebula/pkg-descr
new file mode 100644
index 000000000000..702dd3763918
--- /dev/null
+++ b/net/nebula/pkg-descr
@@ -0,0 +1,11 @@
+Nebula is a scalable overlay networking tool with a focus on performance,
+simplicity and security. It lets you seamlessly connect computers anywhere
+in the world. Nebula is portable, and runs on Linux, OSX, Windows, iOS, and
+Android. It can be used to connect a small number of computers, but is also
+able to connect tens of thousands of computers.
+
+Nebula incorporates a number of existing concepts like encryption, security
+groups, certificates, and tunneling, and each of those individual pieces
+existed before Nebula in various forms. What makes Nebula different to existing
+offerings is that it brings all of these ideas together, resulting in a sum that
+is greater than its individual parts.