aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:46:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:46:47 +0000
commitd3fc725e0b6787537db404b6f1d145445106b847 (patch)
tree9078a6fd76e139773206b0c88f370a2b88f1c3d4
parent7411fb870d8a68f6175c28a3b755807d4163b94d (diff)
downloadports-d3fc725e0b6787537db404b6f1d145445106b847.tar.gz
ports-d3fc725e0b6787537db404b6f1d145445106b847.zip
devel/py-pyquery: Add py-pyquery 1.4.3
pyquery allows you to make jQuery queries on xml documents. The API is as much as possible the similar to jQuery. pyquery uses lxml for fast xml and html manipulation. WWW: https://github.com/gawel/pyquery
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyquery/Makefile23
-rw-r--r--devel/py-pyquery/distinfo3
-rw-r--r--devel/py-pyquery/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index edb18024da0f..777738e5e0c2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4938,6 +4938,7 @@
SUBDIR += py-pyplusplus
SUBDIR += py-pypugjs
SUBDIR += py-pyqtree
+ SUBDIR += py-pyquery
SUBDIR += py-pyral
SUBDIR += py-pyrepl
SUBDIR += py-pyrfc3339
diff --git a/devel/py-pyquery/Makefile b/devel/py-pyquery/Makefile
new file mode 100644
index 000000000000..e748c923afd3
--- /dev/null
+++ b/devel/py-pyquery/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyquery
+PORTVERSION= 1.4.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= jQuery-like library for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssselect>=0.7.0:www/py-cssselect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.1:devel/py-lxml@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyquery/distinfo b/devel/py-pyquery/distinfo
new file mode 100644
index 000000000000..c62a0565c016
--- /dev/null
+++ b/devel/py-pyquery/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626542058
+SHA256 (pyquery-1.4.3.tar.gz) = a388eefb6bc4a55350de0316fbd97cda999ae669b6743ae5b99102ba54f5aa72
+SIZE (pyquery-1.4.3.tar.gz) = 47448
diff --git a/devel/py-pyquery/pkg-descr b/devel/py-pyquery/pkg-descr
new file mode 100644
index 000000000000..869e24e16733
--- /dev/null
+++ b/devel/py-pyquery/pkg-descr
@@ -0,0 +1,5 @@
+pyquery allows you to make jQuery queries on xml documents. The API is as much
+as possible the similar to jQuery. pyquery uses lxml for fast xml and html
+manipulation.
+
+WWW: https://github.com/gawel/pyquery