aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2024-11-29 01:11:47 +0000
committerXin LI <delphij@FreeBSD.org>2024-11-29 02:56:03 +0000
commitd7144e7d74cf47fc5ffc8b5e254e1470f312c989 (patch)
tree3b48436024f6d021f326bcefb48c3b40519746cb
parentb85ae9d24ea1ea119fba33fc235d40fef02bb2ad (diff)
downloadports-d7144e7d74cf47fc5ffc8b5e254e1470f312c989.tar.gz
ports-d7144e7d74cf47fc5ffc8b5e254e1470f312c989.zip
net/openldap25-server: upgrade to 2.5.19.
-rw-r--r--net/openldap25-server/Makefile4
-rw-r--r--net/openldap25-server/distinfo6
-rw-r--r--net/openldap25-server/files/patch-configure11
-rw-r--r--net/openldap25-server/files/patch-configure.ac11
-rw-r--r--net/openldap25-server/files/patch-libraries_libldap_tls__o.c12
5 files changed, 12 insertions, 32 deletions
diff --git a/net/openldap25-server/Makefile b/net/openldap25-server/Makefile
index 8e536dc4b7d1..2f3fcfff2d08 100644
--- a/net/openldap25-server/Makefile
+++ b/net/openldap25-server/Makefile
@@ -1,5 +1,5 @@
PORTNAME= openldap
-DISTVERSION= 2.5.18
+DISTVERSION= 2.5.19
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= https://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/ \
@@ -49,7 +49,7 @@ GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PORTREVISION_CLIENT= 0
PORTREVISION_SERVER= 0
OPENLDAP_SHLIB_MAJOR= 0
-OPENLDAP_SHLIB_MINOR= 1.13
+OPENLDAP_SHLIB_MINOR= 1.14
OPENLDAP_MAJOR= ${DISTVERSION:R}
OPTIONS_DEFINE= DEBUG FETCH GSSAPI
diff --git a/net/openldap25-server/distinfo b/net/openldap25-server/distinfo
index b783ecfda7b7..235a8e47702d 100644
--- a/net/openldap25-server/distinfo
+++ b/net/openldap25-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1717220274
-SHA256 (openldap-2.5.18.tgz) = 2670ae43d8d99dd6b1ba182101d982350d613d09c098eb1607ea6b36e6b51d3e
-SIZE (openldap-2.5.18.tgz) = 6462214
+TIMESTAMP = 1732840944
+SHA256 (openldap-2.5.19.tgz) = 56e2936c7169aa7547cfc93d5c87db46aa05e98dee6321590c3ada92e1fbb66c
+SIZE (openldap-2.5.19.tgz) = 6458108
diff --git a/net/openldap25-server/files/patch-configure b/net/openldap25-server/files/patch-configure
index 64e5de17eab3..a3372a8f7efc 100644
--- a/net/openldap25-server/files/patch-configure
+++ b/net/openldap25-server/files/patch-configure
@@ -1,14 +1,5 @@
---- configure.orig 2024-05-21 17:19:57 UTC
+--- configure.orig 2024-11-26 17:12:48 UTC
+++ configure
-@@ -14157,7 +14157,7 @@ fi
- PERL_CPPFLAGS="$PERL_CPPFLAGS $opt"
- done
- PERL_LDFLAGS=""
-- for opt in `$PERLBIN" -MExtUtils::Embed -e ldopts`; do
-+ for opt in `$PERLBIN -MExtUtils::Embed -e ldopts`; do
- case "$opt" in
- "-lc" )
- continue;;
@@ -16837,9 +16837,9 @@ if test $have_uuid = no ; then
fi
diff --git a/net/openldap25-server/files/patch-configure.ac b/net/openldap25-server/files/patch-configure.ac
deleted file mode 100644
index 6bd215811596..000000000000
--- a/net/openldap25-server/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2024-05-21 17:19:57 UTC
-+++ configure.ac
-@@ -746,7 +746,7 @@ if test $ol_enable_perl != no ; then
- PERL_CPPFLAGS="$PERL_CPPFLAGS $opt"
- done
- PERL_LDFLAGS=""
-- for opt in `$PERLBIN" -MExtUtils::Embed -e ldopts`; do
-+ for opt in `$PERLBIN -MExtUtils::Embed -e ldopts`; do
- case "$opt" in
- "-lc" )
- continue;;
diff --git a/net/openldap25-server/files/patch-libraries_libldap_tls__o.c b/net/openldap25-server/files/patch-libraries_libldap_tls__o.c
index 563d964041a8..9b4681e95901 100644
--- a/net/openldap25-server/files/patch-libraries_libldap_tls__o.c
+++ b/net/openldap25-server/files/patch-libraries_libldap_tls__o.c
@@ -1,6 +1,6 @@
---- libraries/libldap/tls_o.c.orig 2024-01-29 18:53:15 UTC
+--- libraries/libldap/tls_o.c.orig 2024-11-26 17:12:48 UTC
+++ libraries/libldap/tls_o.c
-@@ -279,7 +279,7 @@ tlso_ctx_free ( tls_ctx *ctx )
+@@ -286,7 +286,7 @@ tlso_ctx_free ( tls_ctx *ctx )
SSL_CTX_free( c );
}
@@ -9,12 +9,12 @@
static char *
tlso_stecpy( char *dst, const char *src, const char *end )
{
-@@ -425,7 +425,7 @@ tlso_ctx_init( struct ldapoptions *lo, struct ldaptls
+@@ -433,7 +433,7 @@ tlso_ctx_init( struct ldapoptions *lo, struct ldaptls
if ( lo->ldo_tls_ciphersuite ) {
char *oldsuites = lt->lt_ciphersuite;
-#if OPENSSL_VERSION_NUMBER >= 0x10101000
+#if OPENSSL_VERSION_NUMBER >= 0x10101000 && !defined(OPENSSL_NO_TLS1_3)
- tlso_ctx_cipher13( ctx, lt->lt_ciphersuite, &oldsuites );
- #endif
- if ( oldsuites && !SSL_CTX_set_cipher_list( ctx, oldsuites ) )
+ if ( tlso_ctx_cipher13( ctx, lt->lt_ciphersuite, &oldsuites ))
+ {
+ Debug1( LDAP_DEBUG_ANY,